~ubuntu-branches/debian/squeeze/f-spot/squeeze

« back to all changes in this revision

Viewing changes to debian/patches/svn-r4555_fix-crash-on-icon-size-change.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Iain Lane, Mirco Bauer, Iain Lane
  • Date: 2009-02-07 20:23:32 UTC
  • mfrom: (1.1.18 upstream)
  • Revision ID: james.westby@ubuntu.com-20090207202332-oc93rfjo1st0571s
Tags: 0.5.0.3-2
[ Mirco Bauer]
* Upload to unstable.
* debian/control:
  + Lowered GNOME# build-deps to 2.0 ABI as that transition didn't happen
    yet in unstable.

[ Iain Lane ]
* debian/patches/svn-r4545_locales-import.dpatch: Patch backported from SVN
  trunk revision 4545 - initialize the translation catalog earlier (LP: #293305)
  (Closes: #514457). Thanks to Florian Heinle for finding the patch and to
  Chris Coulson for preparing the update.
* debian/control: Build-depend on libmono-dev (>= 1.2.4) to match configure
  checks.
* debian/rules: Pass CSC=/usr/bin/csc to configure for gio-sharp to fix FTBFS

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## svn-r4555_fix-crash-on-icon-size-change.dpatch by Chris Coulson <chrisccoulson@googlemail.com>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Patch backported from SVN trunk revisions 4555 and 4556
 
6
## DP: Launchpad bug: https://bugs.launchpad.net/f-spot/+bug/291189
 
7
## DP: Gnome bug: http://bugzilla.gnome.org/show_bug.cgi?id=557793
 
8
 
 
9
@DPATCH@
 
10
diff -urNad f-spot-0.5.0.3~/src/Core/Tag.cs f-spot-0.5.0.3/src/Core/Tag.cs
 
11
--- f-spot-0.5.0.3~/src/Core/Tag.cs     2008-08-31 09:52:18.000000000 +0100
 
12
+++ f-spot-0.5.0.3/src/Core/Tag.cs      2008-11-04 17:39:37.000000000 +0000
 
13
@@ -108,6 +108,9 @@
 
14
                                        if (Math.Max (cached_icon.Width, cached_icon.Height) <= (int) tag_icon_size) 
 
15
                                                return cached_icon;
 
16
                                }
 
17
+                               if (icon == null)
 
18
+                                       return null;
 
19
+                                       
 
20
                                if (Math.Max (icon.Width, icon.Height) >= (int) tag_icon_size) { //Don't upscale
 
21
                                        if (cached_icon != null)
 
22
                                                cached_icon.Dispose ();
 
23
diff -urNad f-spot-0.5.0.3~/src/TagSelectionWidget.cs f-spot-0.5.0.3/src/TagSelectionWidget.cs
 
24
--- f-spot-0.5.0.3~/src/TagSelectionWidget.cs   2008-09-26 09:27:39.000000000 +0100
 
25
+++ f-spot-0.5.0.3/src/TagSelectionWidget.cs    2008-11-04 17:37:19.000000000 +0000
 
26
@@ -192,7 +192,7 @@
 
27
                SetBackground (renderer, tag);
 
28
 
 
29
                // FIXME I can't set the Pixbuf to null, not sure if it's a GTK# bug...
 
30
-               if (tag.Icon != null) {
 
31
+               if (tag.SizedIcon != null) {
 
32
                        if (FSpot.ColorManagement.IsEnabled) {
 
33
                                //FIXME
 
34
                                Gdk.Pixbuf temp = tag.SizedIcon.Copy();