~ubuntu-branches/debian/squeeze/ntp/squeeze-201010051545

« back to all changes in this revision

Viewing changes to debian/patches/libedit.patch

  • Committer: Bazaar Package Importer
  • Author(s): Kurt Roeckx
  • Date: 2009-01-05 21:10:03 UTC
  • mfrom: (1.2.4 upstream)
  • Revision ID: james.westby@ubuntu.com-20090105211003-mh6zc3um4k1uhsj7
Tags: 1:4.2.4p4+dfsg-8
It did not properly check the return value of EVP_VerifyFinal
which results in an malformed DSA signature being treated as
a good signature rather than as an error.  (CVE-2009-0021)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
fixes to be able to use libedit instead of readline; see also bug #448408
 
2
 
 
3
--- a/configure.ac
 
4
+++ b/configure.ac
 
5
@@ -334,8 +334,8 @@ AC_CHECK_LIB(md5, MD5Init, , 
 
6
   AC_CHECK_LIB(md, MD5Init))
 
7
 AC_CHECK_FUNCS(MD5Init)
 
8
 dnl HMS: What a hack...
 
9
-AC_CHECK_HEADERS(readline/history.h readline/readline.h)
 
10
-case "$ac_cv_header_readline_history_h$ac_cv_header_readline_readline_h" in
 
11
+AC_CHECK_HEADERS(editline/history.h editline/readline.h)
 
12
+case "$ac_cv_header_editline_history_h$ac_cv_header_editline_readline_h" in
 
13
  *no*) ;;
 
14
  *) save_LIBS=$LIBS
 
15
     LIBS=
 
16
--- a/ntpdc/ntpdc.c
 
17
+++ b/ntpdc/ntpdc.c
 
18
@@ -27,8 +27,8 @@
 
19
 #endif /* SYS_WINNT */
 
20
 
 
21
 #if defined(HAVE_LIBREADLINE) || defined (HAVE_LIBEDIT)
 
22
-# include <readline/readline.h>
 
23
-# include <readline/history.h>
 
24
+# include <editline/readline.h>
 
25
+# include <editline/history.h>
 
26
 #endif /* HAVE_LIBREADLINE || HAVE_LIBEDIT */
 
27
 
 
28
 #ifdef SYS_VXWORKS
 
29
--- a/ntpq/ntpq.c
 
30
+++ b/ntpq/ntpq.c
 
31
@@ -31,8 +31,8 @@
 
32
 #endif /* SYS_WINNT */
 
33
 
 
34
 #if defined(HAVE_LIBREADLINE) || defined(HAVE_LIBEDIT)
 
35
-# include <readline/readline.h>
 
36
-# include <readline/history.h>
 
37
+# include <editline/readline.h>
 
38
+# include <editline/history.h>
 
39
 #endif /* HAVE_LIBREADLINE || HAVE_LIBEDIT */
 
40
 
 
41
 #ifdef SYS_VXWORKS