~ubuntu-branches/debian/stretch/gpaint/stretch

« back to all changes in this revision

Viewing changes to debian/patches/20_fix_line_width_combo.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Goedson Teixeira Paixao
  • Date: 2009-12-29 23:04:23 UTC
  • Revision ID: james.westby@ubuntu.com-20091229230423-x1foh5o43h0xxztj
Tags: 0.3.3-6
* debian/patches/26_fix_toolbar.diff: don't set the style for the toolbar,
  allowing gpaint to follow the user's preferences (Closes: #497488)
  (LP: #127296)
* debian/patches/21_fix_crash_on_fill_button_click.dpatch: fixed the check
  for null drawing_area.
* debian/patches/*.dpatch: renamed to *.diff since we're not using dpatch
  anymore
* debian/control: added ${misc:Depends} to the binary package Depends
* debian/patches/*.diff: Added meta information tags compliant with DEP-3
  recommendations.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 20_fix_line_width_combo.dpatch by Thomas Viehmann <tv@beamnet.de>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Fixes line width combo box by putting items in the drop down
6
 
## DP: part again in gpaint.glade.
7
 
 
8
 
@DPATCH@
9
 
Index: b/gpaint.glade
10
 
===================================================================
11
 
--- a/gpaint.glade      2009-12-19 17:12:10.000000000 -0200
12
 
+++ b/gpaint.glade      2009-12-19 17:12:11.000000000 -0200
13
 
@@ -1230,6 +1230,34 @@
14
 
                      <property name="column_spacing">0</property>
15
 
 
16
 
                      <child>
17
 
+                       <widget class="GtkLabel" id="Line Width">
18
 
+                         <property name="visible">True</property>
19
 
+                         <property name="label" translatable="yes">line width</property>
20
 
+                         <property name="use_underline">False</property>
21
 
+                         <property name="use_markup">False</property>
22
 
+                         <property name="justify">GTK_JUSTIFY_CENTER</property>
23
 
+                         <property name="wrap">False</property>
24
 
+                         <property name="selectable">False</property>
25
 
+                         <property name="xalign">0.5</property>
26
 
+                         <property name="yalign">0.5</property>
27
 
+                         <property name="xpad">0</property>
28
 
+                         <property name="ypad">0</property>
29
 
+                         <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
30
 
+                         <property name="width_chars">-1</property>
31
 
+                         <property name="single_line_mode">False</property>
32
 
+                         <property name="angle">0</property>
33
 
+                         <signal name="realize" handler="on_small_label_realize"/>
34
 
+                       </widget>
35
 
+                       <packing>
36
 
+                         <property name="left_attach">0</property>
37
 
+                         <property name="right_attach">1</property>
38
 
+                         <property name="top_attach">0</property>
39
 
+                         <property name="bottom_attach">1</property>
40
 
+                         <property name="x_options"></property>
41
 
+                         <property name="y_options"></property>
42
 
+                       </packing>
43
 
+                     </child>
44
 
+                     <child>
45
 
                        <widget class="GtkCombo" id="line_width_combo">
46
 
                          <property name="width_request">60</property>
47
 
                          <property name="height_request">25</property>
48
 
@@ -1239,27 +1267,264 @@
49
 
                          <property name="case_sensitive">False</property>
50
 
                          <property name="enable_arrow_keys">True</property>
51
 
                          <property name="enable_arrows_always">False</property>
52
 
-                         <signal name="check_resize" handler="on_line_width_combo_check_resize"/>
53
 
                          <signal name="add" handler="on_line_width_combo_add"/>
54
 
+                         <signal name="check_resize" handler="on_line_width_combo_check_resize"/>
55
 
 
56
 
                          <child internal-child="entry">
57
 
-                           <widget class="GtkEntry" id="entry1">
58
 
+                           <widget class="GtkEntry" id="line_width_combo_combo_entry">
59
 
                              <property name="visible">True</property>
60
 
+                             <property name="tooltip" translatable="yes">line width</property>
61
 
                              <property name="can_focus">True</property>
62
 
                              <property name="editable">True</property>
63
 
                              <property name="visibility">True</property>
64
 
                              <property name="max_length">0</property>
65
 
                              <property name="text" translatable="yes"></property>
66
 
                              <property name="has_frame">True</property>
67
 
-                             <property name="invisible_char">•</property>
68
 
+                             <property name="invisible_char">*</property>
69
 
                              <property name="activates_default">False</property>
70
 
+                             <signal name="changed" handler="on_line_width_combo_combo_entry_changed"/>
71
 
                            </widget>
72
 
                          </child>
73
 
 
74
 
                          <child internal-child="list">
75
 
-                           <widget class="GtkList" id="list1">
76
 
+                           <widget class="GtkList" id="convertwidget1">
77
 
                              <property name="visible">True</property>
78
 
                              <property name="selection_mode">GTK_SELECTION_BROWSE</property>
79
 
+
80
 
+                             <child>
81
 
+                               <widget class="GtkListItem" id="convertwidget2">
82
 
+                                 <property name="visible">True</property>
83
 
+
84
 
+                                 <child>
85
 
+                                   <widget class="GtkLabel" id="convertwidget3">
86
 
+                                     <property name="visible">True</property>
87
 
+                                     <property name="label" translatable="yes">1</property>
88
 
+                                     <property name="use_underline">False</property>
89
 
+                                     <property name="use_markup">False</property>
90
 
+                                     <property name="justify">GTK_JUSTIFY_LEFT</property>
91
 
+                                     <property name="wrap">False</property>
92
 
+                                     <property name="selectable">False</property>
93
 
+                                     <property name="xalign">0</property>
94
 
+                                     <property name="yalign">0.5</property>
95
 
+                                     <property name="xpad">0</property>
96
 
+                                     <property name="ypad">0</property>
97
 
+                                     <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
98
 
+                                     <property name="width_chars">-1</property>
99
 
+                                     <property name="single_line_mode">False</property>
100
 
+                                     <property name="angle">0</property>
101
 
+                                   </widget>
102
 
+                                 </child>
103
 
+                               </widget>
104
 
+                             </child>
105
 
+
106
 
+                             <child>
107
 
+                               <widget class="GtkListItem" id="convertwidget4">
108
 
+                                 <property name="visible">True</property>
109
 
+
110
 
+                                 <child>
111
 
+                                   <widget class="GtkLabel" id="convertwidget5">
112
 
+                                     <property name="visible">True</property>
113
 
+                                     <property name="label" translatable="yes">2</property>
114
 
+                                     <property name="use_underline">False</property>
115
 
+                                     <property name="use_markup">False</property>
116
 
+                                     <property name="justify">GTK_JUSTIFY_LEFT</property>
117
 
+                                     <property name="wrap">False</property>
118
 
+                                     <property name="selectable">False</property>
119
 
+                                     <property name="xalign">0</property>
120
 
+                                     <property name="yalign">0.5</property>
121
 
+                                     <property name="xpad">0</property>
122
 
+                                     <property name="ypad">0</property>
123
 
+                                     <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
124
 
+                                     <property name="width_chars">-1</property>
125
 
+                                     <property name="single_line_mode">False</property>
126
 
+                                     <property name="angle">0</property>
127
 
+                                   </widget>
128
 
+                                 </child>
129
 
+                               </widget>
130
 
+                             </child>
131
 
+
132
 
+                             <child>
133
 
+                               <widget class="GtkListItem" id="convertwidget6">
134
 
+                                 <property name="visible">True</property>
135
 
+
136
 
+                                 <child>
137
 
+                                   <widget class="GtkLabel" id="convertwidget7">
138
 
+                                     <property name="visible">True</property>
139
 
+                                     <property name="label" translatable="yes">3</property>
140
 
+                                     <property name="use_underline">False</property>
141
 
+                                     <property name="use_markup">False</property>
142
 
+                                     <property name="justify">GTK_JUSTIFY_LEFT</property>
143
 
+                                     <property name="wrap">False</property>
144
 
+                                     <property name="selectable">False</property>
145
 
+                                     <property name="xalign">0</property>
146
 
+                                     <property name="yalign">0.5</property>
147
 
+                                     <property name="xpad">0</property>
148
 
+                                     <property name="ypad">0</property>
149
 
+                                     <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
150
 
+                                     <property name="width_chars">-1</property>
151
 
+                                     <property name="single_line_mode">False</property>
152
 
+                                     <property name="angle">0</property>
153
 
+                                   </widget>
154
 
+                                 </child>
155
 
+                               </widget>
156
 
+                             </child>
157
 
+
158
 
+                             <child>
159
 
+                               <widget class="GtkListItem" id="convertwidget8">
160
 
+                                 <property name="visible">True</property>
161
 
+
162
 
+                                 <child>
163
 
+                                   <widget class="GtkLabel" id="convertwidget9">
164
 
+                                     <property name="visible">True</property>
165
 
+                                     <property name="label" translatable="yes">4</property>
166
 
+                                     <property name="use_underline">False</property>
167
 
+                                     <property name="use_markup">False</property>
168
 
+                                     <property name="justify">GTK_JUSTIFY_LEFT</property>
169
 
+                                     <property name="wrap">False</property>
170
 
+                                     <property name="selectable">False</property>
171
 
+                                     <property name="xalign">0</property>
172
 
+                                     <property name="yalign">0.5</property>
173
 
+                                     <property name="xpad">0</property>
174
 
+                                     <property name="ypad">0</property>
175
 
+                                     <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
176
 
+                                     <property name="width_chars">-1</property>
177
 
+                                     <property name="single_line_mode">False</property>
178
 
+                                     <property name="angle">0</property>
179
 
+                                   </widget>
180
 
+                                 </child>
181
 
+                               </widget>
182
 
+                             </child>
183
 
+
184
 
+                             <child>
185
 
+                               <widget class="GtkListItem" id="convertwidget10">
186
 
+                                 <property name="visible">True</property>
187
 
+
188
 
+                                 <child>
189
 
+                                   <widget class="GtkLabel" id="convertwidget11">
190
 
+                                     <property name="visible">True</property>
191
 
+                                     <property name="label" translatable="yes">5</property>
192
 
+                                     <property name="use_underline">False</property>
193
 
+                                     <property name="use_markup">False</property>
194
 
+                                     <property name="justify">GTK_JUSTIFY_LEFT</property>
195
 
+                                     <property name="wrap">False</property>
196
 
+                                     <property name="selectable">False</property>
197
 
+                                     <property name="xalign">0</property>
198
 
+                                     <property name="yalign">0.5</property>
199
 
+                                     <property name="xpad">0</property>
200
 
+                                     <property name="ypad">0</property>
201
 
+                                     <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
202
 
+                                     <property name="width_chars">-1</property>
203
 
+                                     <property name="single_line_mode">False</property>
204
 
+                                     <property name="angle">0</property>
205
 
+                                   </widget>
206
 
+                                 </child>
207
 
+                               </widget>
208
 
+                             </child>
209
 
+
210
 
+
211
 
+                             <child>
212
 
+                               <widget class="GtkListItem" id="convertwidget12">
213
 
+                                 <property name="visible">True</property>
214
 
+
215
 
+                                 <child>
216
 
+                                   <widget class="GtkLabel" id="convertwidget13">
217
 
+                                     <property name="visible">True</property>
218
 
+                                     <property name="label" translatable="yes">6</property>
219
 
+                                     <property name="use_underline">False</property>
220
 
+                                     <property name="use_markup">False</property>
221
 
+                                     <property name="justify">GTK_JUSTIFY_LEFT</property>
222
 
+                                     <property name="wrap">False</property>
223
 
+                                     <property name="selectable">False</property>
224
 
+                                     <property name="xalign">0</property>
225
 
+                                     <property name="yalign">0.5</property>
226
 
+                                     <property name="xpad">0</property>
227
 
+                                     <property name="ypad">0</property>
228
 
+                                     <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
229
 
+                                     <property name="width_chars">-1</property>
230
 
+                                     <property name="single_line_mode">False</property>
231
 
+                                     <property name="angle">0</property>
232
 
+                                   </widget>
233
 
+                                 </child>
234
 
+                               </widget>
235
 
+                             </child>
236
 
+
237
 
+                             <child>
238
 
+                               <widget class="GtkListItem" id="convertwidget14">
239
 
+                                 <property name="visible">True</property>
240
 
+
241
 
+                                 <child>
242
 
+                                   <widget class="GtkLabel" id="convertwidget15">
243
 
+                                     <property name="visible">True</property>
244
 
+                                     <property name="label" translatable="yes">7</property>
245
 
+                                     <property name="use_underline">False</property>
246
 
+                                     <property name="use_markup">False</property>
247
 
+                                     <property name="justify">GTK_JUSTIFY_LEFT</property>
248
 
+                                     <property name="wrap">False</property>
249
 
+                                     <property name="selectable">False</property>
250
 
+                                     <property name="xalign">0</property>
251
 
+                                     <property name="yalign">0.5</property>
252
 
+                                     <property name="xpad">0</property>
253
 
+                                     <property name="ypad">0</property>
254
 
+                                     <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
255
 
+                                     <property name="width_chars">-1</property>
256
 
+                                     <property name="single_line_mode">False</property>
257
 
+                                     <property name="angle">0</property>
258
 
+                                   </widget>
259
 
+                                 </child>
260
 
+                               </widget>
261
 
+                             </child>
262
 
+
263
 
+                             <child>
264
 
+                               <widget class="GtkListItem" id="convertwidget16">
265
 
+                                 <property name="visible">True</property>
266
 
+
267
 
+                                 <child>
268
 
+                                   <widget class="GtkLabel" id="convertwidget17">
269
 
+                                     <property name="visible">True</property>
270
 
+                                     <property name="label" translatable="yes">8</property>
271
 
+                                     <property name="use_underline">False</property>
272
 
+                                     <property name="use_markup">False</property>
273
 
+                                     <property name="justify">GTK_JUSTIFY_LEFT</property>
274
 
+                                     <property name="wrap">False</property>
275
 
+                                     <property name="selectable">False</property>
276
 
+                                     <property name="xalign">0</property>
277
 
+                                     <property name="yalign">0.5</property>
278
 
+                                     <property name="xpad">0</property>
279
 
+                                     <property name="ypad">0</property>
280
 
+                                     <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
281
 
+                                     <property name="width_chars">-1</property>
282
 
+                                     <property name="single_line_mode">False</property>
283
 
+                                     <property name="angle">0</property>
284
 
+                                   </widget>
285
 
+                                 </child>
286
 
+                               </widget>
287
 
+                             </child>
288
 
+
289
 
+                             <child>
290
 
+                               <widget class="GtkListItem" id="convertwidget18">
291
 
+                                 <property name="visible">True</property>
292
 
+
293
 
+                                 <child>
294
 
+                                   <widget class="GtkLabel" id="convertwidget19">
295
 
+                                     <property name="visible">True</property>
296
 
+                                     <property name="label" translatable="yes">9</property>
297
 
+                                     <property name="use_underline">False</property>
298
 
+                                     <property name="use_markup">False</property>
299
 
+                                     <property name="justify">GTK_JUSTIFY_LEFT</property>
300
 
+                                     <property name="wrap">False</property>
301
 
+                                     <property name="selectable">False</property>
302
 
+                                     <property name="xalign">0</property>
303
 
+                                     <property name="yalign">0.5</property>
304
 
+                                     <property name="xpad">0</property>
305
 
+                                     <property name="ypad">0</property>
306
 
+                                     <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
307
 
+                                     <property name="width_chars">-1</property>
308
 
+                                     <property name="single_line_mode">False</property>
309
 
+                                     <property name="angle">0</property>
310
 
+                                   </widget>
311
 
+                                 </child>
312
 
+                               </widget>
313
 
+                             </child>
314
 
                            </widget>
315
 
                          </child>
316
 
                        </widget>
317
 
@@ -1272,35 +1537,6 @@
318
 
                          <property name="y_options"></property>
319
 
                        </packing>
320
 
                      </child>
321
 
-
322
 
-                     <child>
323
 
-                       <widget class="GtkLabel" id="Line Width">
324
 
-                         <property name="visible">True</property>
325
 
-                         <property name="label" translatable="yes">line width</property>
326
 
-                         <property name="use_underline">False</property>
327
 
-                         <property name="use_markup">False</property>
328
 
-                         <property name="justify">GTK_JUSTIFY_CENTER</property>
329
 
-                         <property name="wrap">False</property>
330
 
-                         <property name="selectable">False</property>
331
 
-                         <property name="xalign">0.5</property>
332
 
-                         <property name="yalign">0.5</property>
333
 
-                         <property name="xpad">0</property>
334
 
-                         <property name="ypad">0</property>
335
 
-                         <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
336
 
-                         <property name="width_chars">-1</property>
337
 
-                         <property name="single_line_mode">False</property>
338
 
-                         <property name="angle">0</property>
339
 
-                         <signal name="realize" handler="on_small_label_realize"/>
340
 
-                       </widget>
341
 
-                       <packing>
342
 
-                         <property name="left_attach">0</property>
343
 
-                         <property name="right_attach">1</property>
344
 
-                         <property name="top_attach">0</property>
345
 
-                         <property name="bottom_attach">1</property>
346
 
-                         <property name="x_options"></property>
347
 
-                         <property name="y_options"></property>
348
 
-                       </packing>
349
 
-                     </child>
350
 
                    </widget>
351
 
                  </child>
352
 
                </widget>