~ubuntu-branches/debian/stretch/gpaint/stretch

« back to all changes in this revision

Viewing changes to debian/patches/22_fix_not_printable_string.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Goedson Teixeira Paixao
  • Date: 2009-12-29 23:04:23 UTC
  • Revision ID: james.westby@ubuntu.com-20091229230423-x1foh5o43h0xxztj
Tags: 0.3.3-6
* debian/patches/26_fix_toolbar.diff: don't set the style for the toolbar,
  allowing gpaint to follow the user's preferences (Closes: #497488)
  (LP: #127296)
* debian/patches/21_fix_crash_on_fill_button_click.dpatch: fixed the check
  for null drawing_area.
* debian/patches/*.dpatch: renamed to *.diff since we're not using dpatch
  anymore
* debian/control: added ${misc:Depends} to the binary package Depends
* debian/patches/*.diff: Added meta information tags compliant with DEP-3
  recommendations.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 22_fix_not_printable_string.dpatch by  <Ying-Chun Liu (PaulLiu) <grandpaul@gmail.com>>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Ignore non-printable characters on text input.
6
 
 
7
 
@DPATCH@
8
 
Index: b/src/text.c
9
 
===================================================================
10
 
--- a/src/text.c        2009-12-19 17:12:11.000000000 -0200
11
 
+++ b/src/text.c        2009-12-19 17:12:11.000000000 -0200
12
 
@@ -238,7 +238,9 @@
13
 
     }
14
 
     else if (keyevent->string)
15
 
     {
16
 
+      if (isprint(keyevent->string[0])) {
17
 
         g_string_append(text->textbuf, keyevent->string);
18
 
+      }
19
 
     }
20
 
     else if ((keyevent->keyval >= GDK_space) && (keyevent->keyval < GDK_Shift_L))
21
 
     {