~ubuntu-branches/debian/stretch/gpaint/stretch

« back to all changes in this revision

Viewing changes to debian/patches/23_add_accelerator_keys.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Goedson Teixeira Paixao
  • Date: 2009-12-29 23:04:23 UTC
  • Revision ID: james.westby@ubuntu.com-20091229230423-x1foh5o43h0xxztj
Tags: 0.3.3-6
* debian/patches/26_fix_toolbar.diff: don't set the style for the toolbar,
  allowing gpaint to follow the user's preferences (Closes: #497488)
  (LP: #127296)
* debian/patches/21_fix_crash_on_fill_button_click.dpatch: fixed the check
  for null drawing_area.
* debian/patches/*.dpatch: renamed to *.diff since we're not using dpatch
  anymore
* debian/control: added ${misc:Depends} to the binary package Depends
* debian/patches/*.diff: Added meta information tags compliant with DEP-3
  recommendations.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## add_accelerator_keys.dpatch by Matt Wheeler <m@funkyhat.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: No description.
6
 
 
7
 
@DPATCH@
8
 
Index: b/gpaint.glade
9
 
===================================================================
10
 
--- a/gpaint.glade      2009-12-19 17:12:11.000000000 -0200
11
 
+++ b/gpaint.glade      2009-12-19 17:12:11.000000000 -0200
12
 
@@ -341,6 +341,7 @@
13
 
                          <property name="label" translatable="yes">_New</property>
14
 
                          <property name="use_underline">True</property>
15
 
                          <signal name="activate" handler="on_new_file_menu_activate"/>
16
 
+                          <accelerator key="N" modifiers="GDK_CONTROL_MASK" signal="activate"/>
17
 
 
18
 
                          <child internal-child="image">
19
 
                            <widget class="GtkImage" id="image25">
20
 
@@ -362,6 +363,7 @@
21
 
                          <property name="label" translatable="yes">_Open</property>
22
 
                          <property name="use_underline">True</property>
23
 
                          <signal name="activate" handler="on_open_menu_activate"/>
24
 
+                          <accelerator key="O" modifiers="GDK_CONTROL_MASK" signal="activate"/>
25
 
 
26
 
                          <child internal-child="image">
27
 
                            <widget class="GtkImage" id="image26">
28
 
@@ -383,6 +385,7 @@
29
 
                          <property name="label" translatable="yes">_Save</property>
30
 
                          <property name="use_underline">True</property>
31
 
                          <signal name="activate" handler="on_save_menu_activate"/>
32
 
+                          <accelerator key="S" modifiers="GDK_CONTROL_MASK" signal="activate"/>
33
 
 
34
 
                          <child internal-child="image">
35
 
                            <widget class="GtkImage" id="image27">
36
 
@@ -453,6 +456,7 @@
37
 
                          <property name="label" translatable="yes">_Print</property>
38
 
                          <property name="use_underline">True</property>
39
 
                          <signal name="activate" handler="on_print_menu_activate"/>
40
 
+                          <accelerator key="P" modifiers="GDK_CONTROL_MASK" signal="activate"/>
41
 
 
42
 
                          <child internal-child="image">
43
 
                            <widget class="GtkImage" id="image30">
44
 
@@ -480,6 +484,7 @@
45
 
                          <property name="label" translatable="yes">_Close</property>
46
 
                          <property name="use_underline">True</property>
47
 
                          <signal name="activate" handler="on_close_window_activate"/>
48
 
+                          <accelerator key="W" modifiers="GDK_CONTROL_MASK" signal="activate"/>
49
 
 
50
 
                          <child internal-child="image">
51
 
                            <widget class="GtkImage" id="image31">
52
 
@@ -501,6 +506,7 @@
53
 
                          <property name="label" translatable="yes">_Quit</property>
54
 
                          <property name="use_underline">True</property>
55
 
                          <signal name="activate" handler="on_quit_menu_activate"/>
56
 
+                          <accelerator key="Q" modifiers="GDK_CONTROL_MASK" signal="activate"/>
57
 
 
58
 
                          <child internal-child="image">
59
 
                            <widget class="GtkImage" id="image32">
60
 
@@ -535,6 +541,7 @@
61
 
                          <property name="label" translatable="yes">Cu_t</property>
62
 
                          <property name="use_underline">True</property>
63
 
                          <signal name="activate" handler="on_cut_menu_activate"/>
64
 
+                          <accelerator key="X" modifiers="GDK_CONTROL_MASK" signal="activate"/>
65
 
 
66
 
                          <child internal-child="image">
67
 
                            <widget class="GtkImage" id="image33">
68
 
@@ -556,6 +563,7 @@
69
 
                          <property name="label" translatable="yes">_Copy</property>
70
 
                          <property name="use_underline">True</property>
71
 
                          <signal name="activate" handler="on_copy_menu_activate"/>
72
 
+                          <accelerator key="C" modifiers="GDK_CONTROL_MASK" signal="activate"/>
73
 
 
74
 
                          <child internal-child="image">
75
 
                            <widget class="GtkImage" id="image34">
76
 
@@ -577,6 +585,7 @@
77
 
                          <property name="label" translatable="yes">_Paste</property>
78
 
                          <property name="use_underline">True</property>
79
 
                          <signal name="activate" handler="on_paste_menu_activate"/>
80
 
+                          <accelerator key="V" modifiers="GDK_CONTROL_MASK" signal="activate"/>
81
 
 
82
 
                          <child internal-child="image">
83
 
                            <widget class="GtkImage" id="image35">
84
 
@@ -625,6 +634,7 @@
85
 
                          <property name="label" translatable="yes">_Select All</property>
86
 
                          <property name="use_underline">True</property>
87
 
                          <signal name="activate" handler="on_select_all_activate"/>
88
 
+                          <accelerator key="A" modifiers="GDK_CONTROL_MASK" signal="activate"/>
89
 
                        </widget>
90
 
                      </child>
91
 
                    </widget>