~ubuntu-branches/debian/wheezy/autofs/wheezy

« back to all changes in this revision

Viewing changes to debian/patches/068_fix_invalid_rpcgen_code.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Steve Langasek
  • Date: 2008-03-08 01:36:09 UTC
  • mfrom: (1.1.3 upstream)
  • Revision ID: james.westby@ubuntu.com-20080308013609-cvs4f2ecoyoism02
Tags: 4.1.4+debian-2.1
* Non-maintainer upload.
* High-urgency upload for RC bugfix.
* Add -DLDAP_DEPRECATED to CFLAGS, to fix compatibility with OpenLDAP
  2.4 on 64-bit architectures.  Closes: #463419.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#!/bin/sh /usr/share/dpatch/dpatch-run
 
2
## 068_fix_invalid_rpcgen_code.dpatch
 
3
##
 
4
## DP: No description.
 
5
 
 
6
@DPATCH@
 
7
 
 
8
diff -Naur .B/lib/Makefile .A/lib/Makefile
 
9
--- .B/lib/Makefile     2005-01-09 09:16:43.000000000 +0000
 
10
+++ .A/lib/Makefile     2007-01-07 21:36:36.000000000 +0000
 
11
@@ -39,6 +39,10 @@
 
12
 
 
13
 mount_xdr.c: mount.h
 
14
        $(RPCGEN) -c -o mount_xdr.c mount.x
 
15
+       sed -i -e 's/IXDR_GET_LONG(\([^)]*\))/((long)IXDR_GET_U_INT32(\1))/' mount_xdr.c
 
16
+       sed -i -e 's/IXDR_PUT_LONG(\([^)]*\),\([^)]*\))/((long)IXDR_PUT_INT32(\1,(long)(\2)))/' mount_xdr.c
 
17
+       sed -i -e 's/IXDR_GET_SHORT(\([^)]*\))/((short)IXDR_GET_U_INT32(\1))/' mount_xdr.c
 
18
+       sed -i -e 's/IXDR_PUT_SHORT(\([^)]*\),\([^)]*\))/((long)IXDR_PUT_INT32(\1,(long)(\2)))/' mount_xdr.c
 
19
 
 
20
 mount_xdr.o: mount_xdr.c
 
21
        $(CC) $(CFLAGS) -Wno-unused-variable -o mount_xdr.o -c mount_xdr.c