~ubuntu-branches/debian/wheezy/autofs/wheezy

« back to all changes in this revision

Viewing changes to debian/patches/076_ldap_deprecated.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Steve Langasek
  • Date: 2008-03-08 01:36:09 UTC
  • mfrom: (1.1.3 upstream)
  • Revision ID: james.westby@ubuntu.com-20080308013609-cvs4f2ecoyoism02
Tags: 4.1.4+debian-2.1
* Non-maintainer upload.
* High-urgency upload for RC bugfix.
* Add -DLDAP_DEPRECATED to CFLAGS, to fix compatibility with OpenLDAP
  2.4 on 64-bit architectures.  Closes: #463419.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#!/bin/sh /usr/share/dpatch/dpatch-run
 
2
## 076_ldap_deprecated.dpatch
 
3
##
 
4
## DP: No description.
 
5
 
 
6
@DPATCH@
 
7
 
 
8
diff -Naur .B/aclocal.m4 .A/aclocal.m4
 
9
--- .B/aclocal.m4       2003-09-29 08:22:35.000000000 +0000
 
10
+++ .A/aclocal.m4       2007-01-07 21:36:36.000000000 +0000
 
11
@@ -9,8 +9,8 @@
 
12
 AC_DEFUN(AF_PATH_INCLUDE,
 
13
 [AC_PATH_PROGS($1,$2,$3,$4)
 
14
 if test -n "$$1"; then
 
15
-  AC_DEFINE(HAVE_$1)
 
16
-  AC_DEFINE_UNQUOTED(PATH_$1, "$$1")
 
17
+  AC_DEFINE(HAVE_$1,1,[define if you have $1])
 
18
+  AC_DEFINE_UNQUOTED(PATH_$1, "$$1", [define if you have $1])
 
19
   HAVE_$1=1
 
20
 else
 
21
   HAVE_$1=0
 
22
@@ -28,7 +28,7 @@
 
23
 [if test -n "$MOUNT" ; then
 
24
   AC_MSG_CHECKING([if mount accepts the -s option])
 
25
   if "$MOUNT" -s > /dev/null 2>&1 ; then
 
26
-    AC_DEFINE(HAVE_SLOPPY_MOUNT)
 
27
+    AC_DEFINE(HAVE_SLOPPY_MOUNT, 1, [define if the mount command supports the -s option])
 
28
     AC_MSG_RESULT(yes)
 
29
   else
 
30
     AC_MSG_RESULT(no)
 
31
diff -Naur .B/configure .A/configure
 
32
--- .B/configure        2007-01-07 21:36:36.000000000 +0000
 
33
+++ .A/configure        2007-01-07 21:36:36.000000000 +0000
 
34
@@ -1359,11 +1359,13 @@
 
35
 test -n "$MOUNT" || MOUNT="/bin/mount"
 
36
 
 
37
 if test -n "$MOUNT"; then
 
38
-  cat >>confdefs.h <<\_ACEOF
 
39
+
 
40
+cat >>confdefs.h <<\_ACEOF
 
41
 #define HAVE_MOUNT 1
 
42
 _ACEOF
 
43
 
 
44
-  cat >>confdefs.h <<_ACEOF
 
45
+
 
46
+cat >>confdefs.h <<_ACEOF
 
47
 #define PATH_MOUNT "$MOUNT"
 
48
 _ACEOF
 
49
 
 
50
@@ -1418,11 +1420,13 @@
 
51
 test -n "$UMOUNT" || UMOUNT="/bin/umount"
 
52
 
 
53
 if test -n "$UMOUNT"; then
 
54
-  cat >>confdefs.h <<\_ACEOF
 
55
+
 
56
+cat >>confdefs.h <<\_ACEOF
 
57
 #define HAVE_UMOUNT 1
 
58
 _ACEOF
 
59
 
 
60
-  cat >>confdefs.h <<_ACEOF
 
61
+
 
62
+cat >>confdefs.h <<_ACEOF
 
63
 #define PATH_UMOUNT "$UMOUNT"
 
64
 _ACEOF
 
65
 
 
66
@@ -1476,11 +1480,13 @@
 
67
 done
 
68
 
 
69
 if test -n "$E2FSCK"; then
 
70
-  cat >>confdefs.h <<\_ACEOF
 
71
+
 
72
+cat >>confdefs.h <<\_ACEOF
 
73
 #define HAVE_E2FSCK 1
 
74
 _ACEOF
 
75
 
 
76
-  cat >>confdefs.h <<_ACEOF
 
77
+
 
78
+cat >>confdefs.h <<_ACEOF
 
79
 #define PATH_E2FSCK "$E2FSCK"
 
80
 _ACEOF
 
81
 
 
82
@@ -1534,11 +1540,13 @@
 
83
 done
 
84
 
 
85
 if test -n "$E3FSCK"; then
 
86
-  cat >>confdefs.h <<\_ACEOF
 
87
+
 
88
+cat >>confdefs.h <<\_ACEOF
 
89
 #define HAVE_E3FSCK 1
 
90
 _ACEOF
 
91
 
 
92
-  cat >>confdefs.h <<_ACEOF
 
93
+
 
94
+cat >>confdefs.h <<_ACEOF
 
95
 #define PATH_E3FSCK "$E3FSCK"
 
96
 _ACEOF
 
97
 
 
98
@@ -1556,7 +1564,8 @@
 
99
   echo "$as_me:$LINENO: checking if mount accepts the -s option" >&5
 
100
 echo $ECHO_N "checking if mount accepts the -s option... $ECHO_C" >&6
 
101
   if "$MOUNT" -s > /dev/null 2>&1 ; then
 
102
-    cat >>confdefs.h <<\_ACEOF
 
103
+
 
104
+cat >>confdefs.h <<\_ACEOF
 
105
 #define HAVE_SLOPPY_MOUNT 1
 
106
 _ACEOF
 
107
 
 
108
@@ -3403,6 +3412,7 @@
 
109
 fi;
 
110
 if test -z "$HAVE_LDAP"; then
 
111
        HAVE_LDAP=0
 
112
+       LDAP_FLAGS="$LDAP_FLAGS -DLDAP_DEPRECATED=1"
 
113
        echo "$as_me:$LINENO: checking for ldap_init in -lldap" >&5
 
114
 echo $ECHO_N "checking for ldap_init in -lldap... $ECHO_C" >&6
 
115
 if test "${ac_cv_lib_ldap_ldap_init+set}" = set; then
 
116
@@ -4302,7 +4312,8 @@
 
117
   enableval=yes
 
118
 fi;
 
119
 if test x$enable_ext_env = xyes; then
 
120
-       cat >>confdefs.h <<\_ACEOF
 
121
+
 
122
+cat >>confdefs.h <<\_ACEOF
 
123
 #define ENABLE_EXT_ENV 1
 
124
 _ACEOF
 
125
 
 
126
@@ -4319,7 +4330,8 @@
 
127
   enableval=yes
 
128
 fi;
 
129
 if test x$enable_mount_locking = xyes -o x$enableval = xyes; then
 
130
-       cat >>confdefs.h <<\_ACEOF
 
131
+
 
132
+cat >>confdefs.h <<\_ACEOF
 
133
 #define ENABLE_MOUNT_LOCKING 1
 
134
 _ACEOF
 
135
 
 
136
diff -Naur .B/configure.in .A/configure.in
 
137
--- .B/configure.in     2007-01-07 21:36:36.000000000 +0000
 
138
+++ .A/configure.in     2007-01-07 21:36:36.000000000 +0000
 
139
@@ -118,6 +118,7 @@
 
140
 )
 
141
 if test -z "$HAVE_LDAP"; then
 
142
        HAVE_LDAP=0
 
143
+       LDAP_FLAGS="$LDAP_FLAGS -DLDAP_DEPRECATED=1"
 
144
        AC_CHECK_LIB(ldap, ldap_init, HAVE_LDAP=1 LIBLDAP="$LIBLDAP -lldap -llber -lresolv", ,
 
145
                     -llber -lresolv $LIBS)
 
146
 fi
 
147
@@ -163,7 +164,7 @@
 
148
 --disable-ext-env          disable search in environment for substitution variable,,
 
149
        enableval=yes)
 
150
 if test x$enable_ext_env = xyes; then
 
151
-       AC_DEFINE(ENABLE_EXT_ENV, 1)
 
152
+       AC_DEFINE(ENABLE_EXT_ENV, 1, [leave this alone])
 
153
 fi
 
154
 
 
155
 #
 
156
@@ -173,7 +174,7 @@
 
157
 --disable-mount-locking          disable use of locking when spawning mount command,,
 
158
        enableval=yes)
 
159
 if test x$enable_mount_locking = xyes -o x$enableval = xyes; then
 
160
-       AC_DEFINE(ENABLE_MOUNT_LOCKING, 1)
 
161
+       AC_DEFINE(ENABLE_MOUNT_LOCKING, 1, [disable mount table locking -- use this if your maps contain recursive mounts -- EXPERIMENTAL])
 
162
 fi
 
163
 
 
164
 #
 
165
diff -Naur .B/include/config.h.in .A/include/config.h.in
 
166
--- .B/include/config.h.in      2007-01-07 21:36:36.000000000 +0000
 
167
+++ .A/include/config.h.in      2007-01-07 21:36:36.000000000 +0000
 
168
@@ -1,29 +1,80 @@
 
169
-#ident "$Id: config.h.in,v 1.4 2004/02/03 15:23:21 raven Exp $"
 
170
-/* -*- c -*-
 
171
- *
 
172
- * config.h.in: Pattern file for autofs to be filled in by configure
 
173
- *
 
174
- */
 
175
+/* include/config.h.in.  Generated from configure.in by autoheader.  */
 
176
 
 
177
-/* Program paths */
 
178
+/* leave this alone */
 
179
+#undef ENABLE_EXT_ENV
 
180
+
 
181
+/* disable mount table locking -- use this if your maps contain recursive
 
182
+   mounts -- EXPERIMENTAL */
 
183
+#undef ENABLE_MOUNT_LOCKING
 
184
+
 
185
+/* define if you have E2FSCK */
 
186
+#undef HAVE_E2FSCK
 
187
+
 
188
+/* define if you have E3FSCK */
 
189
+#undef HAVE_E3FSCK
 
190
+
 
191
+/* Define to 1 if you have the <inttypes.h> header file. */
 
192
+#undef HAVE_INTTYPES_H
 
193
+
 
194
+/* Define to 1 if you have the <memory.h> header file. */
 
195
+#undef HAVE_MEMORY_H
 
196
+
 
197
+/* define if you have MOUNT */
 
198
 #undef HAVE_MOUNT
 
199
-#undef PATH_MOUNT
 
200
 
 
201
+/* define if the mount command supports the -s option */
 
202
+#undef HAVE_SLOPPY_MOUNT
 
203
+
 
204
+/* Define to 1 if you have the <stdint.h> header file. */
 
205
+#undef HAVE_STDINT_H
 
206
+
 
207
+/* Define to 1 if you have the <stdlib.h> header file. */
 
208
+#undef HAVE_STDLIB_H
 
209
+
 
210
+/* Define to 1 if you have the <strings.h> header file. */
 
211
+#undef HAVE_STRINGS_H
 
212
+
 
213
+/* Define to 1 if you have the <string.h> header file. */
 
214
+#undef HAVE_STRING_H
 
215
+
 
216
+/* Define to 1 if you have the <sys/stat.h> header file. */
 
217
+#undef HAVE_SYS_STAT_H
 
218
+
 
219
+/* Define to 1 if you have the <sys/types.h> header file. */
 
220
+#undef HAVE_SYS_TYPES_H
 
221
+
 
222
+/* define if you have UMOUNT */
 
223
 #undef HAVE_UMOUNT
 
224
-#undef PATH_UMOUNT
 
225
 
 
226
-#undef HAVE_SMBMOUNT
 
227
-#undef PATH_SMBMOUNT
 
228
+/* Define to 1 if you have the <unistd.h> header file. */
 
229
+#undef HAVE_UNISTD_H
 
230
 
 
231
-#undef HAVE_E2FSCK
 
232
+/* Define to the address where bug reports for this package should be sent. */
 
233
+#undef PACKAGE_BUGREPORT
 
234
+
 
235
+/* Define to the full name of this package. */
 
236
+#undef PACKAGE_NAME
 
237
+
 
238
+/* Define to the full name and version of this package. */
 
239
+#undef PACKAGE_STRING
 
240
+
 
241
+/* Define to the one symbol short name of this package. */
 
242
+#undef PACKAGE_TARNAME
 
243
+
 
244
+/* Define to the version of this package. */
 
245
+#undef PACKAGE_VERSION
 
246
+
 
247
+/* define if you have E2FSCK */
 
248
 #undef PATH_E2FSCK
 
249
 
 
250
-#undef HAVE_E3FSCK
 
251
+/* define if you have E3FSCK */
 
252
 #undef PATH_E3FSCK
 
253
 
 
254
-/* Define this option if mount(8) supports the -s (sloppy) option */
 
255
-#undef HAVE_SLOPPY_MOUNT
 
256
+/* define if you have MOUNT */
 
257
+#undef PATH_MOUNT
 
258
 
 
259
-#undef ENABLE_EXT_ENV
 
260
+/* define if you have UMOUNT */
 
261
+#undef PATH_UMOUNT
 
262
 
 
263
-#undef ENABLE_MOUNT_LOCKING
 
264
+/* Define to 1 if you have the ANSI C header files. */
 
265
+#undef STDC_HEADERS