~ubuntu-branches/debian/wheezy/autofs/wheezy

« back to all changes in this revision

Viewing changes to debian/patches/076_ldap_deprecated

  • Committer: Bazaar Package Importer
  • Author(s): Steve Langasek
  • Date: 2008-03-08 01:36:09 UTC
  • mfrom: (1.1.3 upstream)
  • Revision ID: james.westby@ubuntu.com-20080308013609-cvs4f2ecoyoism02
Tags: 4.1.4+debian-2.1
* Non-maintainer upload.
* High-urgency upload for RC bugfix.
* Add -DLDAP_DEPRECATED to CFLAGS, to fix compatibility with OpenLDAP
  2.4 on 64-bit architectures.  Closes: #463419.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
 
2
 
This patch defines the LDAP_DEPRICATED macro to the compile flags.
3
 
 
4
 
This prevents a SIGSEGV when using the depricated LDAP calls on x86_64
5
 
archictecture. A word of warning - as far as I know this should function
6
 
ok with recent versions of openldap but I don't know if it will behave
7
 
as expected on older versions, so use with caution.
8
 
 
9
 
diff -Nurp autofs-4.1.4.orig/aclocal.m4 autofs-4.1.4/aclocal.m4
10
 
--- autofs-4.1.4.orig/aclocal.m4        2003-09-29 16:22:35.000000000 +0800
11
 
+++ autofs-4.1.4/aclocal.m4     2006-01-25 11:06:23.000000000 +0800
12
 
@@ -9,8 +9,8 @@ dnl ------------------------------------
13
 
 AC_DEFUN(AF_PATH_INCLUDE,
14
 
 [AC_PATH_PROGS($1,$2,$3,$4)
15
 
 if test -n "$$1"; then
16
 
-  AC_DEFINE(HAVE_$1)
17
 
-  AC_DEFINE_UNQUOTED(PATH_$1, "$$1")
18
 
+  AC_DEFINE(HAVE_$1,1,[define if you have $1])
19
 
+  AC_DEFINE_UNQUOTED(PATH_$1, "$$1", [define if you have $1])
20
 
   HAVE_$1=1
21
 
 else
22
 
   HAVE_$1=0
23
 
@@ -28,7 +28,7 @@ AC_DEFUN(AF_SLOPPY_MOUNT,
24
 
 [if test -n "$MOUNT" ; then
25
 
   AC_MSG_CHECKING([if mount accepts the -s option])
26
 
   if "$MOUNT" -s > /dev/null 2>&1 ; then
27
 
-    AC_DEFINE(HAVE_SLOPPY_MOUNT)
28
 
+    AC_DEFINE(HAVE_SLOPPY_MOUNT, 1, [define if the mount command supports the -s option])
29
 
     AC_MSG_RESULT(yes)
30
 
   else
31
 
     AC_MSG_RESULT(no)
32
 
diff -Nurp autofs-4.1.4.orig/configure autofs-4.1.4/configure
33
 
--- autofs-4.1.4.orig/configure 2006-01-25 11:04:56.000000000 +0800
34
 
+++ autofs-4.1.4/configure      2006-01-25 11:06:41.000000000 +0800
35
 
@@ -1359,11 +1359,13 @@ done
36
 
 test -n "$MOUNT" || MOUNT="/bin/mount"
37
 
 
38
 
 if test -n "$MOUNT"; then
39
 
-  cat >>confdefs.h <<\_ACEOF
40
 
+
41
 
+cat >>confdefs.h <<\_ACEOF
42
 
 #define HAVE_MOUNT 1
43
 
 _ACEOF
44
 
 
45
 
-  cat >>confdefs.h <<_ACEOF
46
 
+
47
 
+cat >>confdefs.h <<_ACEOF
48
 
 #define PATH_MOUNT "$MOUNT"
49
 
 _ACEOF
50
 
 
51
 
@@ -1418,11 +1420,13 @@ done
52
 
 test -n "$UMOUNT" || UMOUNT="/bin/umount"
53
 
 
54
 
 if test -n "$UMOUNT"; then
55
 
-  cat >>confdefs.h <<\_ACEOF
56
 
+
57
 
+cat >>confdefs.h <<\_ACEOF
58
 
 #define HAVE_UMOUNT 1
59
 
 _ACEOF
60
 
 
61
 
-  cat >>confdefs.h <<_ACEOF
62
 
+
63
 
+cat >>confdefs.h <<_ACEOF
64
 
 #define PATH_UMOUNT "$UMOUNT"
65
 
 _ACEOF
66
 
 
67
 
@@ -1476,11 +1480,13 @@ fi
68
 
 done
69
 
 
70
 
 if test -n "$E2FSCK"; then
71
 
-  cat >>confdefs.h <<\_ACEOF
72
 
+
73
 
+cat >>confdefs.h <<\_ACEOF
74
 
 #define HAVE_E2FSCK 1
75
 
 _ACEOF
76
 
 
77
 
-  cat >>confdefs.h <<_ACEOF
78
 
+
79
 
+cat >>confdefs.h <<_ACEOF
80
 
 #define PATH_E2FSCK "$E2FSCK"
81
 
 _ACEOF
82
 
 
83
 
@@ -1534,11 +1540,13 @@ fi
84
 
 done
85
 
 
86
 
 if test -n "$E3FSCK"; then
87
 
-  cat >>confdefs.h <<\_ACEOF
88
 
+
89
 
+cat >>confdefs.h <<\_ACEOF
90
 
 #define HAVE_E3FSCK 1
91
 
 _ACEOF
92
 
 
93
 
-  cat >>confdefs.h <<_ACEOF
94
 
+
95
 
+cat >>confdefs.h <<_ACEOF
96
 
 #define PATH_E3FSCK "$E3FSCK"
97
 
 _ACEOF
98
 
 
99
 
@@ -1556,7 +1564,8 @@ if test -n "$MOUNT" ; then
100
 
   echo "$as_me:$LINENO: checking if mount accepts the -s option" >&5
101
 
 echo $ECHO_N "checking if mount accepts the -s option... $ECHO_C" >&6
102
 
   if "$MOUNT" -s > /dev/null 2>&1 ; then
103
 
-    cat >>confdefs.h <<\_ACEOF
104
 
+
105
 
+cat >>confdefs.h <<\_ACEOF
106
 
 #define HAVE_SLOPPY_MOUNT 1
107
 
 _ACEOF
108
 
 
109
 
@@ -3403,6 +3412,7 @@ if test "${with_openldap+set}" = set; th
110
 
 fi;
111
 
 if test -z "$HAVE_LDAP"; then
112
 
        HAVE_LDAP=0
113
 
+       LDAP_FLAGS="$LDAP_FLAGS -DLDAP_DEPRECATED=1"
114
 
        echo "$as_me:$LINENO: checking for ldap_init in -lldap" >&5
115
 
 echo $ECHO_N "checking for ldap_init in -lldap... $ECHO_C" >&6
116
 
 if test "${ac_cv_lib_ldap_ldap_init+set}" = set; then
117
 
@@ -4302,7 +4312,8 @@ else
118
 
   enableval=yes
119
 
 fi;
120
 
 if test x$enable_ext_env = xyes; then
121
 
-       cat >>confdefs.h <<\_ACEOF
122
 
+
123
 
+cat >>confdefs.h <<\_ACEOF
124
 
 #define ENABLE_EXT_ENV 1
125
 
 _ACEOF
126
 
 
127
 
@@ -4319,7 +4330,8 @@ else
128
 
   enableval=yes
129
 
 fi;
130
 
 if test x$enable_mount_locking = xyes -o x$enableval = xyes; then
131
 
-       cat >>confdefs.h <<\_ACEOF
132
 
+
133
 
+cat >>confdefs.h <<\_ACEOF
134
 
 #define ENABLE_MOUNT_LOCKING 1
135
 
 _ACEOF
136
 
 
137
 
diff -Nurp autofs-4.1.4.orig/configure.in autofs-4.1.4/configure.in
138
 
--- autofs-4.1.4.orig/configure.in      2006-01-25 11:04:56.000000000 +0800
139
 
+++ autofs-4.1.4/configure.in   2006-01-25 11:06:23.000000000 +0800
140
 
@@ -118,6 +118,7 @@ AC_ARG_WITH(openldap,
141
 
 )
142
 
 if test -z "$HAVE_LDAP"; then
143
 
        HAVE_LDAP=0
144
 
+       LDAP_FLAGS="$LDAP_FLAGS -DLDAP_DEPRECATED=1"
145
 
        AC_CHECK_LIB(ldap, ldap_init, HAVE_LDAP=1 LIBLDAP="$LIBLDAP -lldap -llber -lresolv", ,
146
 
                     -llber -lresolv $LIBS)
147
 
 fi
148
 
@@ -163,7 +164,7 @@ AC_ARG_ENABLE(ext-env,
149
 
 --disable-ext-env          disable search in environment for substitution variable,,
150
 
        enableval=yes)
151
 
 if test x$enable_ext_env = xyes; then
152
 
-       AC_DEFINE(ENABLE_EXT_ENV, 1)
153
 
+       AC_DEFINE(ENABLE_EXT_ENV, 1, [leave this alone])
154
 
 fi
155
 
 
156
 
 #
157
 
@@ -173,7 +174,7 @@ AC_ARG_ENABLE(mount-locking,
158
 
 --disable-mount-locking          disable use of locking when spawning mount command,,
159
 
        enableval=yes)
160
 
 if test x$enable_mount_locking = xyes -o x$enableval = xyes; then
161
 
-       AC_DEFINE(ENABLE_MOUNT_LOCKING, 1)
162
 
+       AC_DEFINE(ENABLE_MOUNT_LOCKING, 1, [disable mount table locking -- use this if your maps contain recursive mounts -- EXPERIMENTAL])
163
 
 fi
164
 
 
165
 
 #
166
 
diff -Nurp autofs-4.1.4.orig/include/config.h.in autofs-4.1.4/include/config.h.in
167
 
--- autofs-4.1.4.orig/include/config.h.in       2006-01-25 11:04:56.000000000 +0800
168
 
+++ autofs-4.1.4/include/config.h.in    2006-01-25 11:06:43.000000000 +0800
169
 
@@ -1,29 +1,80 @@
170
 
-#ident "$Id: config.h.in,v 1.4 2004/02/03 15:23:21 raven Exp $"
171
 
-/* -*- c -*-
172
 
- *
173
 
- * config.h.in: Pattern file for autofs to be filled in by configure
174
 
- *
175
 
- */
176
 
+/* include/config.h.in.  Generated from configure.in by autoheader.  */
177
 
 
178
 
-/* Program paths */
179
 
+/* leave this alone */
180
 
+#undef ENABLE_EXT_ENV
181
 
+
182
 
+/* disable mount table locking -- use this if your maps contain recursive
183
 
+   mounts -- EXPERIMENTAL */
184
 
+#undef ENABLE_MOUNT_LOCKING
185
 
+
186
 
+/* define if you have E2FSCK */
187
 
+#undef HAVE_E2FSCK
188
 
+
189
 
+/* define if you have E3FSCK */
190
 
+#undef HAVE_E3FSCK
191
 
+
192
 
+/* Define to 1 if you have the <inttypes.h> header file. */
193
 
+#undef HAVE_INTTYPES_H
194
 
+
195
 
+/* Define to 1 if you have the <memory.h> header file. */
196
 
+#undef HAVE_MEMORY_H
197
 
+
198
 
+/* define if you have MOUNT */
199
 
 #undef HAVE_MOUNT
200
 
-#undef PATH_MOUNT
201
 
 
202
 
+/* define if the mount command supports the -s option */
203
 
+#undef HAVE_SLOPPY_MOUNT
204
 
+
205
 
+/* Define to 1 if you have the <stdint.h> header file. */
206
 
+#undef HAVE_STDINT_H
207
 
+
208
 
+/* Define to 1 if you have the <stdlib.h> header file. */
209
 
+#undef HAVE_STDLIB_H
210
 
+
211
 
+/* Define to 1 if you have the <strings.h> header file. */
212
 
+#undef HAVE_STRINGS_H
213
 
+
214
 
+/* Define to 1 if you have the <string.h> header file. */
215
 
+#undef HAVE_STRING_H
216
 
+
217
 
+/* Define to 1 if you have the <sys/stat.h> header file. */
218
 
+#undef HAVE_SYS_STAT_H
219
 
+
220
 
+/* Define to 1 if you have the <sys/types.h> header file. */
221
 
+#undef HAVE_SYS_TYPES_H
222
 
+
223
 
+/* define if you have UMOUNT */
224
 
 #undef HAVE_UMOUNT
225
 
-#undef PATH_UMOUNT
226
 
 
227
 
-#undef HAVE_SMBMOUNT
228
 
-#undef PATH_SMBMOUNT
229
 
+/* Define to 1 if you have the <unistd.h> header file. */
230
 
+#undef HAVE_UNISTD_H
231
 
 
232
 
-#undef HAVE_E2FSCK
233
 
+/* Define to the address where bug reports for this package should be sent. */
234
 
+#undef PACKAGE_BUGREPORT
235
 
+
236
 
+/* Define to the full name of this package. */
237
 
+#undef PACKAGE_NAME
238
 
+
239
 
+/* Define to the full name and version of this package. */
240
 
+#undef PACKAGE_STRING
241
 
+
242
 
+/* Define to the one symbol short name of this package. */
243
 
+#undef PACKAGE_TARNAME
244
 
+
245
 
+/* Define to the version of this package. */
246
 
+#undef PACKAGE_VERSION
247
 
+
248
 
+/* define if you have E2FSCK */
249
 
 #undef PATH_E2FSCK
250
 
 
251
 
-#undef HAVE_E3FSCK
252
 
+/* define if you have E3FSCK */
253
 
 #undef PATH_E3FSCK
254
 
 
255
 
-/* Define this option if mount(8) supports the -s (sloppy) option */
256
 
-#undef HAVE_SLOPPY_MOUNT
257
 
+/* define if you have MOUNT */
258
 
+#undef PATH_MOUNT
259
 
 
260
 
-#undef ENABLE_EXT_ENV
261
 
+/* define if you have UMOUNT */
262
 
+#undef PATH_UMOUNT
263
 
 
264
 
-#undef ENABLE_MOUNT_LOCKING
265
 
+/* Define to 1 if you have the ANSI C header files. */
266
 
+#undef STDC_HEADERS