~ubuntu-branches/ubuntu/hardy/evolution-data-server/hardy-updates

« back to all changes in this revision

Viewing changes to debian/patches/80_from_bugzilla_fix_reference_counting.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastien Bacher
  • Date: 2007-11-13 10:59:20 UTC
  • mfrom: (1.1.38 upstream)
  • Revision ID: james.westby@ubuntu.com-20071113105920-nb6w14udvgx0ghi3
Tags: 2.21.2-0ubuntu1
* New upstream version:
  Bug Fixes:
  - #318842: Task lists should be sorted (LP: #23912)
  - #345135: Disable SSLv2 compatible HELLO on SSL stream when 
    SSLv2 is disabled
  - #359267: Not all memos are showed in calendar view
  - #430420: Returned size <= 0 is an error
  - #460649: Meeting UI Needs To Show Color Of Selected Calendar Source
  - #487229: Use GKeyFile instead of gnome-config to access stored passwords
  - #488156: Minimize use of the WITH_GNOME_KEYRING macro
  - #492130: ESourceSelector uses pointers to ESource
  - #494304: Fix leak
  Updated Translations
  New in 2.21.1:
  - Support for Google Calendar
  Bug Fixes:
  - #203480: (Novell Bugzilla) Compiler warning fix 
    for usage ofunintialized variable
  - #231178: New symbol 'set-label' defined and added corresponding callback
  - #271777: Keep character's case as user types
  - #417999: Don't use deprecated GTK+ symbols
  - #420167: e-d-s now exits with gnome-session
  - #469657: Better use of GHashTable
  - #474000: Use GLib's Base64 API instead of Camel's
  - #475487: When creating the default contact, print errors to the console
  - #475493: Use G_DEFINE_TYPE
  - #475494: Use G_LOCK instead of a static mutex for clearer code
  - #478404: Reset the id to zero
  - #483301: Remove an unused variable
  - #487270: Fix typo in documentation
  - #488173: Remove __FUNCTION__, which is a gcc-ism
  - #488351: Fix an addressbook error on a fresh install
  Other Contributors:
  - Protect against a NULL subject string. 
* debian/*.preinst:
  - On upgrades from Gutsy, remove the symlinks introduced in Gutsy. They
    break upgrades all over, and current cdbs just symlinks individual files.
* Sync with Debian
* debian/control:
  - evolution-data-server Breaks evolution (<< 2.9), 
    evolution-exchange (<= 2.8.1-0ubuntu1),
    evolution-jescs (<= 2.8.2-0ubuntu3), 
    evolution-scalix (<= 10.0.0.357-0ubuntu6)
  - updated maintainer to desktop team
* debian/rules:
  - don't specify the paths for nspr and nss since the package is built 
    with firefox
  - don't build documentation, it's distributed in the upstream tarball

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: addressbook/libebook/e-book.c
2
 
===================================================================
3
 
--- addressbook/libebook/e-book.c       (revision 8106)
4
 
+++ addressbook/libebook/e-book.c       (working copy)
5
 
@@ -119,9 +119,6 @@
6
 
 } EBookLoadState;
7
 
 
8
 
 struct _EBookPrivate {
9
 
-       GList *book_factories;
10
 
-       GList *iter;
11
 
-
12
 
        /* cached capabilites */
13
 
        char *cap;
14
 
        gboolean cap_queried;
15
 
@@ -3188,6 +3185,7 @@
16
 
 
17
 
                CORBA_exception_free (&ev);
18
 
 
19
 
+               book->priv->corba_book = NULL;
20
 
                e_book_listener_stop (book->priv->listener);
21
 
                bonobo_object_unref (BONOBO_OBJECT (book->priv->listener));
22
 
 
23
 
@@ -4001,9 +3999,6 @@
24
 
        EBook             *book = E_BOOK (object);
25
 
 
26
 
        if (book->priv) {
27
 
-               CORBA_Environment  ev;
28
 
-               GList *l;
29
 
-
30
 
                if (book->priv->comp_listener) {
31
 
                        g_signal_handler_disconnect (book->priv->comp_listener, book->priv->died_signal);
32
 
                        g_object_unref (book->priv->comp_listener);
33
 
@@ -4013,21 +4008,19 @@
34
 
                if (book->priv->load_state == E_BOOK_SOURCE_LOADED)
35
 
                        e_book_unload_uri (book, NULL);
36
 
 
37
 
-               CORBA_exception_init (&ev);
38
 
+               if (book->priv->corba_book) {
39
 
+                       CORBA_Environment  ev;
40
 
 
41
 
-               for (l = book->priv->book_factories; l; l = l->next) {
42
 
-                       CORBA_Object_release ((CORBA_Object)l->data, &ev);
43
 
-                       if (ev._major != CORBA_NO_EXCEPTION) {
44
 
-                               g_warning ("EBook: Exception while releasing BookFactory\n");
45
 
-
46
 
-                               CORBA_exception_free (&ev);
47
 
-                               CORBA_exception_init (&ev);
48
 
-                       }
49
 
+                       CORBA_exception_init (&ev);
50
 
+                       bonobo_object_release_unref  (book->priv->corba_book, &ev);
51
 
+                       if (ev._major != CORBA_NO_EXCEPTION)
52
 
+                               g_warning ("%s: Exception releasing remote book interface!\n", __FUNCTION__);
53
 
+                       CORBA_exception_free (&ev);
54
 
                }
55
 
-               
56
 
-               CORBA_exception_free (&ev);
57
 
 
58
 
                if (book->priv->listener) {
59
 
+                       e_book_listener_stop (book->priv->listener);
60
 
+
61
 
                        /* GLib bug compatibility */
62
 
                        if (g_signal_handler_is_connected (book->priv->listener, book->priv->listener_signal))
63
 
                                g_signal_handler_disconnect (book->priv->listener, book->priv->listener_signal);
64
 
Index: calendar/backends/contacts/e-cal-backend-contacts.c
65
 
===================================================================
66
 
--- calendar/backends/contacts/e-cal-backend-contacts.c (revision 8106)
67
 
+++ calendar/backends/contacts/e-cal-backend-contacts.c (working copy)
68
 
@@ -141,7 +141,7 @@
69
 
         ContactRecord *cr = g_new0 (ContactRecord, 1);
70
 
        char *comp_str;
71
 
         
72
 
-        cr->cbc = cbc;
73
 
+        cr->cbc = g_object_ref (cbc);
74
 
         cr->contact = contact;
75
 
         cr->comp_birthday = create_birthday (cbc, contact);
76
 
         cr->comp_anniversary = create_anniversary (cbc, contact);
77
 
@@ -196,7 +196,8 @@
78
 
                g_free (comp_str);
79
 
                g_object_unref (G_OBJECT (cr->comp_anniversary));
80
 
        }
81
 
-        
82
 
+
83
 
+       g_object_unref (cr->cbc);
84
 
         g_free (cr);
85
 
 }
86
 
 
87
 
@@ -212,7 +213,7 @@
88
 
 {
89
 
         ContactRecordCB *cb_data = g_new (ContactRecordCB, 1);
90
 
 
91
 
-        cb_data->cbc = cbc;
92
 
+        cb_data->cbc = g_object_ref (cbc);
93
 
         cb_data->sexp = sexp;
94
 
         cb_data->result = NULL;
95