~ubuntu-branches/ubuntu/hardy/suitesparse/hardy

« back to all changes in this revision

Viewing changes to debian/patches/12-CHOLMOD_Lib_Makefile.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Rafael Laboissiere, Rafael Laboissiere, Ondrej Certik
  • Date: 2008-02-21 14:46:50 UTC
  • mfrom: (1.1.2 upstream) (5.1.1 hardy)
  • Revision ID: james.westby@ubuntu.com-20080221144650-tgeppgj0t7s759i8
Tags: 3.1.0-3
[ Rafael Laboissiere ]
* Upload to unstable

[ Ondrej Certik ]
* XS-DM-Upload-Allowed: yes field added
* Ondrej Certik added to uploaders

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 12-CHOLMOD_Lib_Makefile.dpatch by Daniel Rus Morales <danirus@tol-project.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Build shared version of CHOLMOD library.
 
6
 
 
7
@DPATCH@
 
8
diff -u upstrm/CHOLMOD/Lib/Makefile debsrc/CHOLMOD/Lib/Makefile
 
9
--- upstrm/CHOLMOD/Lib/Makefile 2007-05-05 16:36:56.000000000 +0200
 
10
+++ debsrc/CHOLMOD/Lib/Makefile 2007-12-15 19:11:20.000000000 +0100
 
11
@@ -10,7 +10,7 @@
 
12
 
 
13
 C = $(CC) $(CFLAGS) $(CHOLMOD_CONFIG)
 
14
 
 
15
-all: libcholmod.a
 
16
+all: libcholmod.a libcholmod.so.3.1.0
 
17
 
 
18
 library: libcholmod.a
 
19
 
 
20
@@ -21,6 +21,9 @@
 
21
 
 
22
 clean:
 
23
        - $(RM) $(CLEAN)
 
24
+       -$(RM) *.oo
 
25
+       -$(RM) *.a
 
26
+       -$(RM) *.so*
 
27
 
 
28
 #-------------------------------------------------------------------------------
 
29
 # ../Include/ directory contains all include files:
 
30
@@ -49,29 +52,39 @@
 
31
        cholmod_copy.o cholmod_dense.o cholmod_error.o cholmod_factor.o \
 
32
        cholmod_memory.o cholmod_sparse.o \
 
33
        cholmod_transpose.o cholmod_triplet.o
 
34
+CORE_SL = $(subst .o,.oo,$(CORE))
 
35
 
 
36
 CHECK = cholmod_check.o cholmod_read.o cholmod_write.o
 
37
+CHECK_SL = $(subst .o,.oo,$(CHECK))
 
38
 
 
39
 CHOLESKY = cholmod_amd.o cholmod_analyze.o cholmod_colamd.o \
 
40
        cholmod_etree.o cholmod_factorize.o cholmod_postorder.o \
 
41
        cholmod_rcond.o cholmod_resymbol.o cholmod_rowcolcounts.o \
 
42
        cholmod_rowfac.o cholmod_solve.o cholmod_spsolve.o
 
43
+CHOLESKY_SL = $(subst .o,.oo,$(CHOLESKY))
 
44
 
 
45
 MATRIXOPS = cholmod_drop.o cholmod_horzcat.o cholmod_norm.o \
 
46
        cholmod_scale.o cholmod_sdmult.o cholmod_ssmult.o \
 
47
        cholmod_submatrix.o cholmod_vertcat.o cholmod_symmetry.o
 
48
+MATRIXOPS_SL = $(subst .o,.oo,$(MATRIXOPS))
 
49
 
 
50
 PARTITION = cholmod_ccolamd.o cholmod_csymamd.o \
 
51
        cholmod_metis.o cholmod_nesdis.o cholmod_camd.o
 
52
+PARTITION_SL = $(subst .o,.oo,$(PARTITION))
 
53
 
 
54
 MODIFY = cholmod_rowadd.o cholmod_rowdel.o cholmod_updown.o
 
55
+MODIFY_SL = $(subst .o,.oo,$(MODIFY))
 
56
 
 
57
 SUPERNODAL = cholmod_super_numeric.o cholmod_super_solve.o \
 
58
        cholmod_super_symbolic.o
 
59
+SUPERNODAL_SL = $(subst .o,.oo,$(SUPERNODAL))
 
60
 
 
61
 DI = $(CORE) $(CHECK) $(CHOLESKY) $(MATRIXOPS) $(MODIFY) $(SUPERNODAL) \
 
62
        $(PARTITION)
 
63
 
 
64
+DI_SL = $(CORE_SL) $(CHECK_SL) $(CHOLESKY_SL) $(MATRIXOPS_SL) $(MODIFY_SL) \
 
65
+       $(SUPERNODAL_SL) $(PARTITION_SL)
 
66
+
 
67
 #-------------------------------------------------------------------------------
 
68
 # CHOLMOD library modules (long, double)
 
69
 #-------------------------------------------------------------------------------
 
70
@@ -81,39 +94,53 @@
 
71
        cholmod_l_copy.o cholmod_l_dense.o cholmod_l_error.o \
 
72
        cholmod_l_factor.o cholmod_l_memory.o \
 
73
        cholmod_l_sparse.o cholmod_l_transpose.o cholmod_l_triplet.o
 
74
+LCORE_SL = $(subst .o,.oo,$(LCORE))
 
75
 
 
76
 LCHECK = cholmod_l_check.o cholmod_l_read.o cholmod_l_write.o
 
77
+LCHECK_SL = $(subst .o,.oo,$(LCHECK))
 
78
 
 
79
 LCHOLESKY = cholmod_l_amd.o cholmod_l_analyze.o cholmod_l_colamd.o \
 
80
        cholmod_l_etree.o cholmod_l_factorize.o cholmod_l_postorder.o \
 
81
        cholmod_l_rcond.o cholmod_l_resymbol.o cholmod_l_rowcolcounts.o \
 
82
        cholmod_l_rowfac.o cholmod_l_solve.o cholmod_l_spsolve.o
 
83
+LCHOLESKY_SL = $(subst .o,.oo,$(LCHOLESKY))
 
84
 
 
85
 LMATRIXOPS = cholmod_l_drop.o cholmod_l_horzcat.o cholmod_l_norm.o \
 
86
        cholmod_l_scale.o cholmod_l_sdmult.o cholmod_l_ssmult.o \
 
87
        cholmod_l_submatrix.o cholmod_l_vertcat.o cholmod_l_symmetry.o
 
88
+LMATRIXOPS_SL = $(subst .o,.oo,$(LMATRIXOPS))
 
89
 
 
90
 LPARTITION = cholmod_l_ccolamd.o cholmod_l_csymamd.o \
 
91
        cholmod_l_metis.o cholmod_l_nesdis.o cholmod_l_camd.o
 
92
+LPARTITION_SL = $(subst .o,.oo,$(LPARTITION))
 
93
 
 
94
 LMODIFY = cholmod_l_rowadd.o cholmod_l_rowdel.o cholmod_l_updown.o
 
95
+LMODIFY_SL = $(subst .o,.oo,$(LMODIFY))
 
96
 
 
97
 LSUPERNODAL = cholmod_l_super_numeric.o cholmod_l_super_solve.o \
 
98
        cholmod_l_super_symbolic.o
 
99
+LSUPERNODAL_SL = $(subst .o,.oo,$(LSUPERNODAL))
 
100
 
 
101
 DL = $(LCORE) $(LCHECK) $(LCHOLESKY) $(LMATRIXOPS) $(LMODIFY) $(LSUPERNODAL) \
 
102
        $(LPARTITION)
 
103
+DL_SL = $(LCORE_SL) $(LCHECK_SL) $(LCHOLESKY_SL) $(LMATRIXOPS_SL) \
 
104
+       $(LMODIFY_SL) $(LSUPERNODAL_SL) $(LPARTITION_SL)
 
105
 
 
106
 #-------------------------------------------------------------------------------
 
107
 
 
108
 # to compile just the double/int version, use OBJ = $(DI)
 
109
 OBJ = $(DI) $(DL)
 
110
+OBJ_SL = $(DI_SL) $(DL_SL)
 
111
 
 
112
 libcholmod.a: $(OBJ)
 
113
        $(AR) libcholmod.a $(OBJ)
 
114
        $(RANLIB) libcholmod.a
 
115
 
 
116
-$(OBJ): $(INC)
 
117
+libcholmod.so.3.1.0: $(OBJ_SL)
 
118
+       $(CC) -shared $^ -lblas -llapack ../../AMD/Lib/libamd.so ../../CAMD/Lib/libcamd.so ../../COLAMD/Lib/libcolamd.so ../../CCOLAMD/Lib/libccolamd.so -lm  -Wl,-soname -Wl,$@ -o $@
 
119
+       ln -s $@ libcholmod.so
 
120
+
 
121
+$(OBJ) $(OBJ_SL): $(INC)
 
122
 
 
123
 I = -I../../AMD/Include -I../../AMD/Source -I../../COLAMD/Include \
 
124
        -I$(METIS_PATH)/Lib -I../../CCOLAMD/Include -I../../CAMD/Include \
 
125
@@ -125,23 +153,35 @@
 
126
 
 
127
 cholmod_check.o: ../Check/cholmod_check.c
 
128
        $(C) -c $(I) $<
 
129
+cholmod_check.oo: ../Check/cholmod_check.c
 
130
+       $(C) -fPIC -c $(I) $< -o $@
 
131
 
 
132
 cholmod_read.o: ../Check/cholmod_read.c
 
133
        $(C) -c $(I) $<
 
134
+cholmod_read.oo: ../Check/cholmod_read.c
 
135
+       $(C) -fPIC -c $(I) $< -o $@
 
136
 
 
137
 cholmod_write.o: ../Check/cholmod_write.c
 
138
        $(C) -c $(I) $<
 
139
+cholmod_write.oo: ../Check/cholmod_write.c
 
140
+       $(C) -fPIC -c $(I) $< -o $@
 
141
 
 
142
 #-------------------------------------------------------------------------------
 
143
 
 
144
 cholmod_l_check.o: ../Check/cholmod_check.c
 
145
        $(C) -DDLONG -c $(I) $< -o $@
 
146
+cholmod_l_check.oo: ../Check/cholmod_check.c
 
147
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
148
 
 
149
 cholmod_l_read.o: ../Check/cholmod_read.c
 
150
        $(C) -DDLONG -c $(I) $< -o $@
 
151
+cholmod_l_read.oo: ../Check/cholmod_read.c
 
152
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
153
 
 
154
 cholmod_l_write.o: ../Check/cholmod_write.c
 
155
        $(C) -DDLONG -c $(I) $< -o $@
 
156
+cholmod_l_write.oo: ../Check/cholmod_write.c
 
157
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
158
 
 
159
 
 
160
 #-------------------------------------------------------------------------------
 
161
@@ -150,92 +190,149 @@
 
162
 
 
163
 cholmod_common.o: ../Core/cholmod_common.c
 
164
        $(C) -c $(I) $<
 
165
+cholmod_common.oo: ../Core/cholmod_common.c
 
166
+       $(C) -fPIC -c $(I) $< -o $@
 
167
 
 
168
 cholmod_dense.o: ../Core/cholmod_dense.c ../Core/t_cholmod_dense.c
 
169
        $(C) -c $(I) $<
 
170
+cholmod_dense.oo: ../Core/cholmod_dense.c ../Core/t_cholmod_dense.c
 
171
+       $(C) -fPIC -c $(I) $< -o $@
 
172
 
 
173
 cholmod_factor.o: ../Core/cholmod_factor.c
 
174
        $(C) -c $(I) $<
 
175
+cholmod_factor.oo: ../Core/cholmod_factor.c
 
176
+       $(C) -fPIC -c $(I) $< -o $@
 
177
 
 
178
 cholmod_change_factor.o: ../Core/cholmod_change_factor.c \
 
179
        ../Core/t_cholmod_change_factor.c
 
180
        $(C) -c $(I) $<
 
181
+cholmod_change_factor.oo: ../Core/cholmod_change_factor.c \
 
182
+       ../Core/t_cholmod_change_factor.c
 
183
+       $(C) -fPIC -c $(I) $< -o $@
 
184
 
 
185
 cholmod_memory.o: ../Core/cholmod_memory.c
 
186
        $(C) -c $(I) $<
 
187
+cholmod_memory.oo: ../Core/cholmod_memory.c
 
188
+       $(C) -fPIC -c $(I) $< -o $@
 
189
 
 
190
 cholmod_sparse.o: ../Core/cholmod_sparse.c
 
191
        $(C) -c $(I) $<
 
192
+cholmod_sparse.oo: ../Core/cholmod_sparse.c
 
193
+       $(C) -fPIC -c $(I) $< -o $@
 
194
 
 
195
 cholmod_complex.o: ../Core/cholmod_complex.c
 
196
        $(C) -c $(I) $<
 
197
+cholmod_complex.oo: ../Core/cholmod_complex.c
 
198
+       $(C) -fPIC -c $(I) $< -o $@
 
199
 
 
200
 cholmod_transpose.o: ../Core/cholmod_transpose.c ../Core/t_cholmod_transpose.c
 
201
        $(C) -c $(I) $<
 
202
+cholmod_transpose.oo: ../Core/cholmod_transpose.c ../Core/t_cholmod_transpose.c
 
203
+       $(C) -fPIC -c $(I) $< -o $@
 
204
 
 
205
 cholmod_band.o: ../Core/cholmod_band.c
 
206
        $(C) -c $(I) $<
 
207
+cholmod_band.oo: ../Core/cholmod_band.c
 
208
+       $(C) -fPIC -c $(I) $< -o $@
 
209
 
 
210
 cholmod_copy.o: ../Core/cholmod_copy.c
 
211
        $(C) -c $(I) $<
 
212
+cholmod_copy.oo: ../Core/cholmod_copy.c
 
213
+       $(C) -fPIC -c $(I) $< -o $@
 
214
 
 
215
 cholmod_triplet.o: ../Core/cholmod_triplet.c ../Core/t_cholmod_triplet.c
 
216
        $(C) -c $(I) $<
 
217
+cholmod_triplet.oo: ../Core/cholmod_triplet.c ../Core/t_cholmod_triplet.c
 
218
+       $(C) -fPIC -c $(I) $< -o $@
 
219
 
 
220
 cholmod_error.o: ../Core/cholmod_error.c
 
221
        $(C) -c $(I) $<
 
222
+cholmod_error.oo: ../Core/cholmod_error.c
 
223
+       $(C) -fPIC -c $(I) $< -o $@
 
224
 
 
225
 cholmod_aat.o: ../Core/cholmod_aat.c
 
226
        $(C) -c $(I) $<
 
227
+cholmod_aat.oo: ../Core/cholmod_aat.c
 
228
+       $(C) -fPIC -c $(I) $< -o $@
 
229
 
 
230
 cholmod_add.o: ../Core/cholmod_add.c
 
231
        $(C) -c $(I) $<
 
232
+cholmod_add.oo: ../Core/cholmod_add.c
 
233
+       $(C) -fPIC -c $(I) $< -o $@
 
234
 
 
235
 #-------------------------------------------------------------------------------
 
236
 
 
237
 cholmod_l_common.o: ../Core/cholmod_common.c
 
238
        $(C) -DDLONG -c $(I) $< -o $@
 
239
+cholmod_l_common.oo: ../Core/cholmod_common.c
 
240
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
241
 
 
242
 cholmod_l_dense.o: ../Core/cholmod_dense.c ../Core/t_cholmod_dense.c
 
243
        $(C) -DDLONG -c $(I) $< -o $@
 
244
+cholmod_l_dense.oo: ../Core/cholmod_dense.c ../Core/t_cholmod_dense.c
 
245
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
246
 
 
247
 cholmod_l_factor.o: ../Core/cholmod_factor.c
 
248
        $(C) -DDLONG -c $(I) $< -o $@
 
249
+cholmod_l_factor.oo: ../Core/cholmod_factor.c
 
250
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
251
 
 
252
 cholmod_l_change_factor.o: ../Core/cholmod_change_factor.c \
 
253
        ../Core/t_cholmod_change_factor.c
 
254
        $(C) -DDLONG -c $(I) $< -o $@
 
255
+cholmod_l_change_factor.oo: ../Core/cholmod_change_factor.c \
 
256
+       ../Core/t_cholmod_change_factor.c
 
257
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
258
 
 
259
 cholmod_l_memory.o: ../Core/cholmod_memory.c
 
260
        $(C) -DDLONG -c $(I) $< -o $@
 
261
+cholmod_l_memory.oo: ../Core/cholmod_memory.c
 
262
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
263
 
 
264
 cholmod_l_sparse.o: ../Core/cholmod_sparse.c
 
265
        $(C) -DDLONG -c $(I) $< -o $@
 
266
+cholmod_l_sparse.oo: ../Core/cholmod_sparse.c
 
267
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
268
 
 
269
 cholmod_l_complex.o: ../Core/cholmod_complex.c
 
270
        $(C) -DDLONG -c $(I) $< -o $@
 
271
+cholmod_l_complex.oo: ../Core/cholmod_complex.c
 
272
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
273
 
 
274
 cholmod_l_transpose.o: ../Core/cholmod_transpose.c ../Core/t_cholmod_transpose.c
 
275
        $(C) -DDLONG -c $(I) $< -o $@
 
276
+cholmod_l_transpose.oo: ../Core/cholmod_transpose.c ../Core/t_cholmod_transpose.c
 
277
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
278
 
 
279
 cholmod_l_band.o: ../Core/cholmod_band.c
 
280
        $(C) -DDLONG -c $(I) $< -o $@
 
281
+cholmod_l_band.oo: ../Core/cholmod_band.c
 
282
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
283
 
 
284
 cholmod_l_copy.o: ../Core/cholmod_copy.c
 
285
        $(C) -DDLONG -c $(I) $< -o $@
 
286
+cholmod_l_copy.oo: ../Core/cholmod_copy.c
 
287
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
288
 
 
289
 cholmod_l_triplet.o: ../Core/cholmod_triplet.c ../Core/t_cholmod_triplet.c
 
290
        $(C) -DDLONG -c $(I) $< -o $@
 
291
+cholmod_l_triplet.oo: ../Core/cholmod_triplet.c ../Core/t_cholmod_triplet.c
 
292
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
293
 
 
294
 cholmod_l_error.o: ../Core/cholmod_error.c
 
295
        $(C) -DDLONG -c $(I) $< -o $@
 
296
+cholmod_l_error.oo: ../Core/cholmod_error.c
 
297
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
298
 
 
299
 cholmod_l_aat.o: ../Core/cholmod_aat.c
 
300
        $(C) -DDLONG -c $(I) $< -o $@
 
301
+cholmod_l_aat.oo: ../Core/cholmod_aat.c
 
302
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
303
 
 
304
 cholmod_l_add.o: ../Core/cholmod_add.c
 
305
        $(C) -DDLONG -c $(I) $< -o $@
 
306
-
 
307
+cholmod_l_add.oo: ../Core/cholmod_add.c
 
308
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
309
 
 
310
 #-------------------------------------------------------------------------------
 
311
 # Cholesky Module:
 
312
@@ -243,79 +340,129 @@
 
313
 
 
314
 cholmod_amd.o: ../Cholesky/cholmod_amd.c
 
315
        $(C) -c $(I) $<
 
316
+cholmod_amd.oo: ../Cholesky/cholmod_amd.c
 
317
+       $(C) -fPIC -c $(I) $< -o $@
 
318
 
 
319
 cholmod_analyze.o: ../Cholesky/cholmod_analyze.c
 
320
        $(C) -c $(I) $<
 
321
+cholmod_analyze.oo: ../Cholesky/cholmod_analyze.c
 
322
+       $(C) -fPIC -c $(I) $< -o $@
 
323
 
 
324
 cholmod_colamd.o: ../Cholesky/cholmod_colamd.c
 
325
        $(C) -c $(I) $<
 
326
+cholmod_colamd.oo: ../Cholesky/cholmod_colamd.c
 
327
+       $(C) -fPIC -c $(I) $< -o $@
 
328
 
 
329
 cholmod_etree.o: ../Cholesky/cholmod_etree.c
 
330
        $(C) -c $(I) $<
 
331
+cholmod_etree.oo: ../Cholesky/cholmod_etree.c
 
332
+       $(C) -fPIC -c $(I) $< -o $@
 
333
 
 
334
 cholmod_factorize.o: ../Cholesky/cholmod_factorize.c
 
335
        $(C) -c $(I) $<
 
336
+cholmod_factorize.oo: ../Cholesky/cholmod_factorize.c
 
337
+       $(C) -fPIC -c $(I) $< -o $@
 
338
 
 
339
 cholmod_postorder.o: ../Cholesky/cholmod_postorder.c
 
340
        $(C) -c $(I) $<
 
341
+cholmod_postorder.oo: ../Cholesky/cholmod_postorder.c
 
342
+       $(C) -fPIC -c $(I) $< -o $@
 
343
 
 
344
 cholmod_rcond.o: ../Cholesky/cholmod_rcond.c
 
345
        $(C) -c $(I) $<
 
346
+cholmod_rcond.oo: ../Cholesky/cholmod_rcond.c
 
347
+       $(C) -fPIC -c $(I) $< -o $@
 
348
 
 
349
 cholmod_resymbol.o: ../Cholesky/cholmod_resymbol.c
 
350
        $(C) -c $(I) $<
 
351
+cholmod_resymbol.oo: ../Cholesky/cholmod_resymbol.c
 
352
+       $(C) -fPIC -c $(I) $< -o $@
 
353
 
 
354
 cholmod_rowcolcounts.o: ../Cholesky/cholmod_rowcolcounts.c
 
355
        $(C) -c $(I) $<
 
356
+cholmod_rowcolcounts.oo: ../Cholesky/cholmod_rowcolcounts.c
 
357
+       $(C) -fPIC -c $(I) $< -o $@
 
358
 
 
359
 cholmod_solve.o: ../Cholesky/cholmod_solve.c ../Cholesky/t_cholmod_lsolve.c \
 
360
        ../Cholesky/t_cholmod_ltsolve.c ../Cholesky/t_cholmod_solve.c
 
361
        $(C) -c $(I) $<
 
362
+cholmod_solve.oo: ../Cholesky/cholmod_solve.c ../Cholesky/t_cholmod_lsolve.c \
 
363
+       ../Cholesky/t_cholmod_ltsolve.c ../Cholesky/t_cholmod_solve.c
 
364
+       $(C) -fPIC -c $(I) $< -o $@
 
365
 
 
366
 cholmod_spsolve.o: ../Cholesky/cholmod_spsolve.c
 
367
        $(C) -c $(I) $<
 
368
+cholmod_spsolve.oo: ../Cholesky/cholmod_spsolve.c
 
369
+       $(C) -fPIC -c $(I) $< -o $@
 
370
 
 
371
 cholmod_rowfac.o: ../Cholesky/cholmod_rowfac.c ../Cholesky/t_cholmod_rowfac.c
 
372
        $(C) -c $(I) $<
 
373
+cholmod_rowfac.oo: ../Cholesky/cholmod_rowfac.c ../Cholesky/t_cholmod_rowfac.c
 
374
+       $(C) -fPIC -c $(I) $< -o $@
 
375
 
 
376
 #-------------------------------------------------------------------------------
 
377
 
 
378
 cholmod_l_amd.o: ../Cholesky/cholmod_amd.c
 
379
        $(C) -DDLONG -c $(I) $< -o $@
 
380
+cholmod_l_amd.oo: ../Cholesky/cholmod_amd.c
 
381
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
382
 
 
383
 cholmod_l_analyze.o: ../Cholesky/cholmod_analyze.c
 
384
        $(C) -DDLONG -c $(I) $< -o $@
 
385
+cholmod_l_analyze.oo: ../Cholesky/cholmod_analyze.c
 
386
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
387
 
 
388
 cholmod_l_colamd.o: ../Cholesky/cholmod_colamd.c
 
389
        $(C) -DDLONG -c $(I) $< -o $@
 
390
+cholmod_l_colamd.oo: ../Cholesky/cholmod_colamd.c
 
391
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
392
 
 
393
 cholmod_l_etree.o: ../Cholesky/cholmod_etree.c
 
394
        $(C) -DDLONG -c $(I) $< -o $@
 
395
+cholmod_l_etree.oo: ../Cholesky/cholmod_etree.c
 
396
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
397
 
 
398
 cholmod_l_factorize.o: ../Cholesky/cholmod_factorize.c
 
399
        $(C) -DDLONG -c $(I) $< -o $@
 
400
+cholmod_l_factorize.oo: ../Cholesky/cholmod_factorize.c
 
401
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
402
 
 
403
 cholmod_l_postorder.o: ../Cholesky/cholmod_postorder.c
 
404
        $(C) -DDLONG -c $(I) $< -o $@
 
405
+cholmod_l_postorder.oo: ../Cholesky/cholmod_postorder.c
 
406
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
407
 
 
408
 cholmod_l_rcond.o: ../Cholesky/cholmod_rcond.c
 
409
        $(C) -DDLONG -c $(I) $< -o $@
 
410
+cholmod_l_rcond.oo: ../Cholesky/cholmod_rcond.c
 
411
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
412
 
 
413
 cholmod_l_resymbol.o: ../Cholesky/cholmod_resymbol.c
 
414
        $(C) -DDLONG -c $(I) $< -o $@
 
415
+cholmod_l_resymbol.oo: ../Cholesky/cholmod_resymbol.c
 
416
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
417
 
 
418
 cholmod_l_rowcolcounts.o: ../Cholesky/cholmod_rowcolcounts.c
 
419
        $(C) -DDLONG -c $(I) $< -o $@
 
420
+cholmod_l_rowcolcounts.oo: ../Cholesky/cholmod_rowcolcounts.c
 
421
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
422
 
 
423
 cholmod_l_solve.o: ../Cholesky/cholmod_solve.c ../Cholesky/t_cholmod_lsolve.c \
 
424
        ../Cholesky/t_cholmod_ltsolve.c ../Cholesky/t_cholmod_solve.c
 
425
        $(C) -DDLONG -c $(I) $< -o $@
 
426
+cholmod_l_solve.oo: ../Cholesky/cholmod_solve.c ../Cholesky/t_cholmod_lsolve.c \
 
427
+       ../Cholesky/t_cholmod_ltsolve.c ../Cholesky/t_cholmod_solve.c
 
428
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
429
 
 
430
 cholmod_l_spsolve.o: ../Cholesky/cholmod_spsolve.c
 
431
        $(C) -DDLONG -c $(I) $< -o $@
 
432
+cholmod_l_spsolve.oo: ../Cholesky/cholmod_spsolve.c
 
433
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
434
 
 
435
 cholmod_l_rowfac.o: ../Cholesky/cholmod_rowfac.c ../Cholesky/t_cholmod_rowfac.c
 
436
        $(C) -DDLONG -c $(I) $< -o $@
 
437
+cholmod_l_rowfac.oo: ../Cholesky/cholmod_rowfac.c ../Cholesky/t_cholmod_rowfac.c
 
438
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
439
 
 
440
 #-------------------------------------------------------------------------------
 
441
 # Partition Module:
 
442
@@ -323,35 +470,55 @@
 
443
 
 
444
 cholmod_ccolamd.o: ../Partition/cholmod_ccolamd.c
 
445
        $(C) -c $(I) $<
 
446
+cholmod_ccolamd.oo: ../Partition/cholmod_ccolamd.c
 
447
+       $(C) -fPIC -c $(I) $< -o $@
 
448
 
 
449
 cholmod_csymamd.o: ../Partition/cholmod_csymamd.c
 
450
        $(C) -c $(I) $<
 
451
+cholmod_csymamd.oo: ../Partition/cholmod_csymamd.c
 
452
+       $(C) -fPIC -c $(I) $< -o $@
 
453
 
 
454
 cholmod_camd.o: ../Partition/cholmod_camd.c
 
455
        $(C) -c $(I) $<
 
456
+cholmod_camd.oo: ../Partition/cholmod_camd.c
 
457
+       $(C) -fPIC -c $(I) $< -o $@
 
458
 
 
459
 cholmod_metis.o: ../Partition/cholmod_metis.c
 
460
        $(C) -c $(I) $<
 
461
+cholmod_metis.oo: ../Partition/cholmod_metis.c
 
462
+       $(C) -fPIC -c $(I) $< -o $@
 
463
 
 
464
 cholmod_nesdis.o: ../Partition/cholmod_nesdis.c
 
465
        $(C) -c $(I) $<
 
466
+cholmod_nesdis.oo: ../Partition/cholmod_nesdis.c
 
467
+       $(C) -fPIC -c $(I) $< -o $@
 
468
 
 
469
 #-------------------------------------------------------------------------------
 
470
 
 
471
 cholmod_l_ccolamd.o: ../Partition/cholmod_ccolamd.c
 
472
        $(C) -DDLONG -c $(I) $< -o $@
 
473
+cholmod_l_ccolamd.oo: ../Partition/cholmod_ccolamd.c
 
474
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
475
 
 
476
 cholmod_l_csymamd.o: ../Partition/cholmod_csymamd.c
 
477
        $(C) -DDLONG -c $(I) $< -o $@
 
478
+cholmod_l_csymamd.oo: ../Partition/cholmod_csymamd.c
 
479
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
480
 
 
481
 cholmod_l_camd.o: ../Partition/cholmod_camd.c
 
482
        $(C) -DDLONG -c $(I) $< -o $@
 
483
+cholmod_l_camd.oo: ../Partition/cholmod_camd.c
 
484
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
485
 
 
486
 cholmod_l_metis.o: ../Partition/cholmod_metis.c
 
487
        $(C) -DDLONG -c $(I) $< -o $@
 
488
+cholmod_l_metis.oo: ../Partition/cholmod_metis.c
 
489
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
490
 
 
491
 cholmod_l_nesdis.o: ../Partition/cholmod_nesdis.c
 
492
        $(C) -DDLONG -c $(I) $< -o $@
 
493
+cholmod_l_nesdis.oo: ../Partition/cholmod_nesdis.c
 
494
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
495
 
 
496
 
 
497
 #-------------------------------------------------------------------------------
 
498
@@ -360,61 +527,99 @@
 
499
 
 
500
 cholmod_horzcat.o: ../MatrixOps/cholmod_horzcat.c
 
501
        $(C) -c $(I) $<
 
502
+cholmod_horzcat.oo: ../MatrixOps/cholmod_horzcat.c
 
503
+       $(C) -fPIC -c $(I) $< -o $@
 
504
 
 
505
 cholmod_norm.o: ../MatrixOps/cholmod_norm.c
 
506
        $(C) -c $(I) $<
 
507
+cholmod_norm.oo: ../MatrixOps/cholmod_norm.c
 
508
+       $(C) -fPIC -c $(I) $< -o $@
 
509
 
 
510
 cholmod_scale.o: ../MatrixOps/cholmod_scale.c
 
511
        $(C) -c $(I) $<
 
512
+cholmod_scale.oo: ../MatrixOps/cholmod_scale.c
 
513
+       $(C) -fPIC -c $(I) $< -o $@
 
514
 
 
515
 cholmod_drop.o: ../MatrixOps/cholmod_drop.c
 
516
        $(C) -c $(I) $<
 
517
+cholmod_drop.oo: ../MatrixOps/cholmod_drop.c
 
518
+       $(C) -fPIC -c $(I) $< -o $@
 
519
 
 
520
 cholmod_sdmult.o: ../MatrixOps/cholmod_sdmult.c \
 
521
        ../MatrixOps/t_cholmod_sdmult.c
 
522
        $(C) -c $(I) $<
 
523
+cholmod_sdmult.oo: ../MatrixOps/cholmod_sdmult.c \
 
524
+       ../MatrixOps/t_cholmod_sdmult.c
 
525
+       $(C) -fPIC -c $(I) $< -o $@
 
526
 
 
527
 cholmod_ssmult.o: ../MatrixOps/cholmod_ssmult.c
 
528
        $(C) -c $(I) $<
 
529
+cholmod_ssmult.oo: ../MatrixOps/cholmod_ssmult.c
 
530
+       $(C) -fPIC -c $(I) $< -o $@
 
531
 
 
532
 cholmod_submatrix.o: ../MatrixOps/cholmod_submatrix.c
 
533
        $(C) -c $(I) $<
 
534
+cholmod_submatrix.oo: ../MatrixOps/cholmod_submatrix.c
 
535
+       $(C) -fPIC -c $(I) $< -o $@
 
536
 
 
537
 cholmod_vertcat.o: ../MatrixOps/cholmod_vertcat.c
 
538
        $(C) -c $(I) $<
 
539
+cholmod_vertcat.oo: ../MatrixOps/cholmod_vertcat.c
 
540
+       $(C) -fPIC -c $(I) $< -o $@
 
541
 
 
542
 cholmod_symmetry.o: ../MatrixOps/cholmod_symmetry.c
 
543
        $(C) -c $(I) $<
 
544
+cholmod_symmetry.oo: ../MatrixOps/cholmod_symmetry.c
 
545
+       $(C) -fPIC -c $(I) $< -o $@
 
546
 
 
547
 #-------------------------------------------------------------------------------
 
548
 
 
549
 cholmod_l_horzcat.o: ../MatrixOps/cholmod_horzcat.c
 
550
        $(C) -DDLONG -c $(I) $< -o $@
 
551
+cholmod_l_horzcat.oo: ../MatrixOps/cholmod_horzcat.c
 
552
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
553
 
 
554
 cholmod_l_norm.o: ../MatrixOps/cholmod_norm.c
 
555
        $(C) -DDLONG -c $(I) $< -o $@
 
556
+cholmod_l_norm.oo: ../MatrixOps/cholmod_norm.c
 
557
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
558
 
 
559
 cholmod_l_scale.o: ../MatrixOps/cholmod_scale.c
 
560
        $(C) -DDLONG -c $(I) $< -o $@
 
561
+cholmod_l_scale.oo: ../MatrixOps/cholmod_scale.c
 
562
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
563
 
 
564
 cholmod_l_drop.o: ../MatrixOps/cholmod_drop.c
 
565
        $(C) -DDLONG -c $(I) $< -o $@
 
566
+cholmod_l_drop.oo: ../MatrixOps/cholmod_drop.c
 
567
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
568
 
 
569
 cholmod_l_sdmult.o: ../MatrixOps/cholmod_sdmult.c \
 
570
        ../MatrixOps/t_cholmod_sdmult.c
 
571
        $(C) -DDLONG -c $(I) $< -o $@
 
572
+cholmod_l_sdmult.oo: ../MatrixOps/cholmod_sdmult.c \
 
573
+       ../MatrixOps/t_cholmod_sdmult.c
 
574
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
575
 
 
576
 cholmod_l_ssmult.o: ../MatrixOps/cholmod_ssmult.c
 
577
        $(C) -DDLONG -c $(I) $< -o $@
 
578
+cholmod_l_ssmult.oo: ../MatrixOps/cholmod_ssmult.c
 
579
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
580
 
 
581
 cholmod_l_submatrix.o: ../MatrixOps/cholmod_submatrix.c
 
582
        $(C) -DDLONG -c $(I) $< -o $@
 
583
+cholmod_l_submatrix.oo: ../MatrixOps/cholmod_submatrix.c
 
584
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
585
 
 
586
 cholmod_l_vertcat.o: ../MatrixOps/cholmod_vertcat.c
 
587
        $(C) -DDLONG -c $(I) $< -o $@
 
588
+cholmod_l_vertcat.oo: ../MatrixOps/cholmod_vertcat.c
 
589
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
590
 
 
591
 cholmod_l_symmetry.o: ../MatrixOps/cholmod_symmetry.c
 
592
        $(C) -DDLONG -c $(I) $< -o $@
 
593
+cholmod_l_symmetry.oo: ../MatrixOps/cholmod_symmetry.c
 
594
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
595
 
 
596
 #-------------------------------------------------------------------------------
 
597
 # Modify Module:
 
598
@@ -422,25 +627,39 @@
 
599
 
 
600
 cholmod_rowadd.o: ../Modify/cholmod_rowadd.c
 
601
        $(C) -c $(I) $<
 
602
+cholmod_rowadd.oo: ../Modify/cholmod_rowadd.c
 
603
+       $(C) -fPIC -c $(I) $< -o $@
 
604
 
 
605
 cholmod_rowdel.o: ../Modify/cholmod_rowdel.c
 
606
        $(C) -c $(I) $<
 
607
+cholmod_rowdel.oo: ../Modify/cholmod_rowdel.c
 
608
+       $(C) -fPIC -c $(I) $< -o $@
 
609
 
 
610
 cholmod_updown.o: ../Modify/cholmod_updown.c \
 
611
        ../Modify/t_cholmod_updown.c ../Modify/t_cholmod_updown_numkr.c
 
612
        $(C) -c $(I) $<
 
613
+cholmod_updown.oo: ../Modify/cholmod_updown.c \
 
614
+       ../Modify/t_cholmod_updown.c ../Modify/t_cholmod_updown_numkr.c
 
615
+       $(C) -fPIC -c $(I) $< -o $@
 
616
 
 
617
 #-------------------------------------------------------------------------------
 
618
 
 
619
 cholmod_l_rowadd.o: ../Modify/cholmod_rowadd.c
 
620
        $(C) -DDLONG -c $(I) $< -o $@
 
621
+cholmod_l_rowadd.oo: ../Modify/cholmod_rowadd.c
 
622
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
623
 
 
624
 cholmod_l_rowdel.o: ../Modify/cholmod_rowdel.c
 
625
        $(C) -DDLONG -c $(I) $< -o $@
 
626
+cholmod_l_rowdel.oo: ../Modify/cholmod_rowdel.c
 
627
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
628
 
 
629
 cholmod_l_updown.o: ../Modify/cholmod_updown.c \
 
630
        ../Modify/t_cholmod_updown.c ../Modify/t_cholmod_updown_numkr.c
 
631
        $(C) -DDLONG -c $(I) $< -o $@
 
632
+cholmod_l_updown.oo: ../Modify/cholmod_updown.c \
 
633
+       ../Modify/t_cholmod_updown.c ../Modify/t_cholmod_updown_numkr.c
 
634
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
635
 
 
636
 
 
637
 #-------------------------------------------------------------------------------
 
638
@@ -450,23 +669,39 @@
 
639
 cholmod_super_numeric.o: ../Supernodal/cholmod_super_numeric.c \
 
640
        ../Supernodal/t_cholmod_super_numeric.c
 
641
        $(C) -c $(I) $<
 
642
+cholmod_super_numeric.oo: ../Supernodal/cholmod_super_numeric.c \
 
643
+       ../Supernodal/t_cholmod_super_numeric.c
 
644
+       $(C) -fPIC -c $(I) $< -o $@
 
645
 
 
646
 cholmod_super_symbolic.o: ../Supernodal/cholmod_super_symbolic.c
 
647
        $(C) -c $(I) $<
 
648
+cholmod_super_symbolic.oo: ../Supernodal/cholmod_super_symbolic.c
 
649
+       $(C) -fPIC -c $(I) $< -o $@
 
650
 
 
651
 cholmod_super_solve.o: ../Supernodal/cholmod_super_solve.c \
 
652
        ../Supernodal/t_cholmod_super_solve.c
 
653
        $(C) -c $(I) $<
 
654
+cholmod_super_solve.oo: ../Supernodal/cholmod_super_solve.c \
 
655
+       ../Supernodal/t_cholmod_super_solve.c
 
656
+       $(C) -fPIC -c $(I) $< -o $@
 
657
 
 
658
 #-------------------------------------------------------------------------------
 
659
 
 
660
 cholmod_l_super_numeric.o: ../Supernodal/cholmod_super_numeric.c \
 
661
        ../Supernodal/t_cholmod_super_numeric.c
 
662
        $(C) -DDLONG -c $(I) $< -o $@
 
663
+cholmod_l_super_numeric.oo: ../Supernodal/cholmod_super_numeric.c \
 
664
+       ../Supernodal/t_cholmod_super_numeric.c
 
665
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
666
 
 
667
 cholmod_l_super_symbolic.o: ../Supernodal/cholmod_super_symbolic.c
 
668
        $(C) -DDLONG -c $(I) $< -o $@
 
669
+cholmod_l_super_symbolic.oo: ../Supernodal/cholmod_super_symbolic.c
 
670
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@
 
671
 
 
672
 cholmod_l_super_solve.o: ../Supernodal/cholmod_super_solve.c \
 
673
        ../Supernodal/t_cholmod_super_solve.c
 
674
        $(C) -DDLONG -c $(I) $< -o $@
 
675
+cholmod_l_super_solve.oo: ../Supernodal/cholmod_super_solve.c \
 
676
+       ../Supernodal/t_cholmod_super_solve.c
 
677
+       $(C) -fPIC -DDLONG -c $(I) $< -o $@