~ubuntu-branches/ubuntu/hardy/suitesparse/hardy

« back to all changes in this revision

Viewing changes to debian/patches/13-UFconfig_UFconfig.mk.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Rafael Laboissiere, Rafael Laboissiere, Ondrej Certik
  • Date: 2008-02-21 14:46:50 UTC
  • mfrom: (1.1.2 upstream) (5.1.1 hardy)
  • Revision ID: james.westby@ubuntu.com-20080221144650-tgeppgj0t7s759i8
Tags: 3.1.0-3
[ Rafael Laboissiere ]
* Upload to unstable

[ Ondrej Certik ]
* XS-DM-Upload-Allowed: yes field added
* Ondrej Certik added to uploaders

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 13-UFconfig_UFconfig.mk.dpatch by Daniel Rus Morales <danirus@tol-project.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Customizing CFLAGS.
 
6
 
 
7
@DPATCH@
 
8
diff -u upstrm/UFconfig/UFconfig.mk debsrc/UFconfig/UFconfig.mk
 
9
--- upstrm/UFconfig/UFconfig.mk 2007-10-24 15:55:44.000000000 +0200
 
10
+++ debsrc/UFconfig/UFconfig.mk 2007-12-15 17:53:21.000000000 +0100
 
11
@@ -85,7 +85,7 @@
 
12
 # BLAS = -lgoto -lgfortran -lgfortranbegin
 
13
 
 
14
 # This is probably slow ... it might connect to the Standard Reference BLAS:
 
15
-BLAS = -lblas -lgfortran -lgfortranbegin
 
16
-LAPACK = -llapack
 
17
+BLAS = -lblas
 
18
+LAPACK = -llapackgf-3
 
19
 
 
20
 # The BLAS might not contain xerbla, an error-handling routine for LAPACK and
 
21
@@ -114,13 +114,13 @@
 
22
 # The path is relative to where it is used, in CHOLMOD/Lib, CHOLMOD/MATLAB, etc.
 
23
 # You may wish to use an absolute path.  METIS is optional.  Compile
 
24
 # CHOLMOD with -DNPARTITION if you do not wish to use METIS.
 
25
-METIS_PATH = ../../metis-4.0
 
26
-METIS = ../../metis-4.0/libmetis.a
 
27
+#METIS_PATH = ../../metis-4.0
 
28
+#METIS = ../../metis-4.0/libmetis.a
 
29
 
 
30
 # If you use CHOLMOD_CONFIG = -DNPARTITION then you must use the following
 
31
 # options:
 
32
-# METIS_PATH =
 
33
-# METIS =
 
34
+METIS_PATH =
 
35
+METIS =
 
36
 
 
37
 #------------------------------------------------------------------------------
 
38
 # UMFPACK configuration:
 
39
@@ -176,7 +176,7 @@
 
40
 # -DNSUNPERF       for Solaris only.  If defined, do not use the Sun
 
41
 #                      Performance Library
 
42
 
 
43
-CHOLMOD_CONFIG =
 
44
+CHOLMOD_CONFIG = -I/usr/include/mpi -DNPARTITION
 
45
 
 
46
 #------------------------------------------------------------------------------
 
47
 # Linux
 
48
@@ -184,7 +184,7 @@
 
49
 
 
50
 # Using default compilers:
 
51
 # CC = gcc
 
52
-CFLAGS = -O3
 
53
+# CFLAGS = -O3
 
54
 
 
55
 # alternatives:
 
56
 # CFLAGS = -g -fexceptions \
 
57
@@ -193,7 +193,7 @@
 
58
 # CFLAGS = -O3 -fexceptions \
 
59
        -Wall -W -Werror -Wshadow -Wmissing-prototypes -Wstrict-prototypes \
 
60
        -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi
 
61
-# CFLAGS = -O3 -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE
 
62
+CFLAGS = -O3 -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE
 
63
 # CFLAGS = -O3
 
64
 
 
65
 # consider: