~ubuntu-branches/ubuntu/jaunty/libvirt/jaunty-updates

« back to all changes in this revision

Viewing changes to debian/patches/0005-qemu-fix-parallel-serial-mode-tcp-and-unix.patch

  • Committer: Bazaar Package Importer
  • Author(s): Soren Hansen
  • Date: 2009-01-08 23:01:16 UTC
  • mfrom: (1.1.8 upstream) (3.1.7 sid)
  • Revision ID: james.westby@ubuntu.com-20090108230116-niu4xzgypapywhmx
Tags: 0.5.1-4ubuntu1
* Merge with Debian experimental.
  - debian/control:
    + Don't build-depend on QEmu.
    + Add "XS-Debian-" prefix to Debian's Vcs headers.
    + Bump bridge-utils, dnsmasq-base, netcat-openbsd, and iptables
      to Depends of libvirt-bin.
    + s/interract/interact/g
    + Add versioned Conflicts/Replaces to libvirt0 for libvirt0-dbg,
      since we used to ship them as such.
  - Rename libvirt group to libvirtd.
  - 0005-delayed_iff_up_bridge.patch: Don't try to bring up the bridge
    before at least one interface has been added to it.
  - dont_clobber_existing_bridges.patch: Assign the name of the virtual
    bridge dynamically to avoid interfering with existing bridges.
  - better_default_uri_virsh.patch: Default to qemu:///system if the
    user has write access to the libvirt socket, otherwise
    qemu:///session.
  - We call libxen-dev libxen3-dev, so change all references.
* Included (but did not enable) opennebula patch (since it's not in
  the archive yet).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 42e1e104ca11ce85c8ca8094ac11a26ceb94f070 Mon Sep 17 00:00:00 2001
 
2
From: =?utf-8?q?Guido=20G=C3=BCnther?= <agx@sigxcpu.org>
 
3
Date: Thu, 11 Dec 2008 12:02:50 +0100
 
4
Subject: [PATCH] qemu: fix parallel/serial mode "tcp" and "unix"
 
5
 
 
6
According to
 
7
 http://bellard.org/qemu/qemu-doc.html
 
8
the required option is 'server' not 'listen'. Use nowait so kvm/qemu doesn't
 
9
timeout during monitor startup as it waits for an incoming connection.
 
10
 
 
11
Closes: #507608
 
12
---
 
13
 src/qemu_conf.c                                    |    6 +++---
 
14
 .../qemuxml2argv-parallel-tcp.args                 |    2 +-
 
15
 .../qemuxml2argv-serial-tcp-telnet.args            |    2 +-
 
16
 3 files changed, 5 insertions(+), 5 deletions(-)
 
17
 
 
18
diff --git a/src/qemu_conf.c b/src/qemu_conf.c
 
19
index e6c378f..e890480 100644
 
20
--- a/src/qemu_conf.c
 
21
+++ b/src/qemu_conf.c
 
22
@@ -676,13 +676,13 @@ static int qemudBuildCommandLineChrDevStr(virDomainChrDefPtr dev,
 
23
             if (snprintf(buf, buflen, "telnet:%s:%s%s",
 
24
                          dev->data.tcp.host,
 
25
                          dev->data.tcp.service,
 
26
-                         dev->data.tcp.listen ? ",server" : "") >= buflen)
 
27
+                         dev->data.tcp.listen ? ",server,nowait" : "") >= buflen)
 
28
                 return -1;
 
29
         } else {
 
30
             if (snprintf(buf, buflen, "tcp:%s:%s%s",
 
31
                          dev->data.tcp.host,
 
32
                          dev->data.tcp.service,
 
33
-                         dev->data.tcp.listen ? ",listen" : "") >= buflen)
 
34
+                         dev->data.tcp.listen ? ",server,nowait" : "") >= buflen)
 
35
                 return -1;
 
36
         }
 
37
         break;
 
38
@@ -690,7 +690,7 @@ static int qemudBuildCommandLineChrDevStr(virDomainChrDefPtr dev,
 
39
     case VIR_DOMAIN_CHR_TYPE_UNIX:
 
40
         if (snprintf(buf, buflen, "unix:%s%s",
 
41
                      dev->data.nix.path,
 
42
-                     dev->data.nix.listen ? ",listen" : "") >= buflen)
 
43
+                     dev->data.nix.listen ? ",server,nowait" : "") >= buflen)
 
44
             return -1;
 
45
         break;
 
46
     }
 
47
diff --git a/tests/qemuxml2argvdata/qemuxml2argv-parallel-tcp.args b/tests/qemuxml2argvdata/qemuxml2argv-parallel-tcp.args
 
48
index 1a08bbb..e9bbc71 100644
 
49
--- a/tests/qemuxml2argvdata/qemuxml2argv-parallel-tcp.args
 
50
+++ b/tests/qemuxml2argvdata/qemuxml2argv-parallel-tcp.args
 
51
@@ -1 +1 @@
 
52
-LC_ALL=C PATH=/bin HOME=/home/test USER=test LOGNAME=test /usr/bin/qemu -S -M pc -m 214 -smp 1 -nographic -monitor pty -no-acpi -boot c -hda /dev/HostVG/QEMUGuest1 -net none -serial none -parallel tcp:127.0.0.1:9999,listen -usb
 
53
+LC_ALL=C PATH=/bin HOME=/home/test USER=test LOGNAME=test /usr/bin/qemu -S -M pc -m 214 -smp 1 -nographic -monitor pty -no-acpi -boot c -hda /dev/HostVG/QEMUGuest1 -net none -serial none -parallel tcp:127.0.0.1:9999,server,nowait -usb
 
54
diff --git a/tests/qemuxml2argvdata/qemuxml2argv-serial-tcp-telnet.args b/tests/qemuxml2argvdata/qemuxml2argv-serial-tcp-telnet.args
 
55
index f2d1f17..ad37de4 100644
 
56
--- a/tests/qemuxml2argvdata/qemuxml2argv-serial-tcp-telnet.args
 
57
+++ b/tests/qemuxml2argvdata/qemuxml2argv-serial-tcp-telnet.args
 
58
@@ -1 +1 @@
 
59
-LC_ALL=C PATH=/bin HOME=/home/test USER=test LOGNAME=test /usr/bin/qemu -S -M pc -m 214 -smp 1 -nographic -monitor pty -no-acpi -boot c -hda /dev/HostVG/QEMUGuest1 -net none -serial telnet:127.0.0.1:9999,server -parallel none -usb
 
60
+LC_ALL=C PATH=/bin HOME=/home/test USER=test LOGNAME=test /usr/bin/qemu -S -M pc -m 214 -smp 1 -nographic -monitor pty -no-acpi -boot c -hda /dev/HostVG/QEMUGuest1 -net none -serial telnet:127.0.0.1:9999,server,nowait -parallel none -usb
 
61
-- 
 
62
1.6.0.3
 
63