~ubuntu-branches/ubuntu/karmic/calibre/karmic

« back to all changes in this revision

Viewing changes to debian/patches/remove_postinstall.patch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2009-07-30 12:49:41 UTC
  • mfrom: (1.3.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20090730124941-qjdsmri25zt8zocn
Tags: 0.6.3+dfsg-0ubuntu1
* New upstream release. Please see http://calibre.kovidgoyal.net/new_in_6/
  for the list of new features and changes.
* remove_postinstall.patch: Update for new version.
* build_debug.patch: Does not apply any more, disable for now. Might not be
  necessary any more.
* debian/copyright: Fix reference to versionless GPL.
* debian/rules: Drop obsolete dh_desktop call.
* debian/rules: Add workaround for weird Python 2.6 setuptools behaviour of
  putting compiled .so files into src/calibre/plugins/calibre/plugins
  instead of src/calibre/plugins.
* debian/rules: Drop hal fdi moving, new upstream version does not use hal
  any more. Drop hal dependency, too.
* debian/rules: Install udev rules into /lib/udev/rules.d.
* Add debian/calibre.preinst: Remove unmodified
  /etc/udev/rules.d/95-calibre.rules on upgrade.
* debian/control: Bump Python dependencies to 2.6, since upstream needs
  it now.

Show diffs side-by-side

added added

removed removed

Lines of Context:
6
6
#  - Disable setup_desktop_integration, since this uses the xdg tools.
7
7
#    This totally does not work for package build time, we use static
8
8
#    files in debian/local/ instead.
9
 
Index: calibre-0.5.13+dfsg/setup.py
 
9
Index: calibre-0.6.3+dfsg/setup.py
10
10
===================================================================
11
 
--- calibre-0.5.13+dfsg.orig/setup.py   2009-05-21 17:38:21.000000000 +0200
12
 
+++ calibre-0.5.13+dfsg/setup.py        2009-05-26 09:21:55.000000000 +0200
 
11
--- calibre-0.6.3+dfsg.orig/setup.py    2009-07-30 00:59:00.000000000 +0200
 
12
+++ calibre-0.6.3+dfsg/setup.py 2009-07-30 10:37:05.000000000 +0200
13
13
@@ -55,8 +55,6 @@
14
14
                         upload_to_pypi, stage3, stage2, stage1, upload, \
15
 
                         upload_rss
 
15
                         upload_rss, betas
16
16
 
17
17
-    entry_points['console_scripts'].append(
18
18
-                            'calibre_postinstall = calibre.linux:post_install')
19
19
     optional = []
20
20
 
21
 
 
22
 
@@ -198,6 +196,3 @@
 
21
     if iswindows:
 
22
@@ -220,6 +218,3 @@
23
23
 
24
24
     if 'develop' in ' '.join(sys.argv) and islinux:
25
25
         subprocess.check_call('calibre_postinstall --do-not-reload-udev-hal', shell=True)
26
26
-    if 'install' in sys.argv and islinux:
27
27
-        subprocess.check_call('calibre_postinstall', shell=True)
28
28
-
29
 
Index: calibre-0.5.13+dfsg/src/calibre/linux.py
 
29
Index: calibre-0.6.3+dfsg/src/calibre/linux.py
30
30
===================================================================
31
 
--- calibre-0.5.13+dfsg.orig/src/calibre/linux.py       2009-05-21 17:38:21.000000000 +0200
32
 
+++ calibre-0.5.13+dfsg/src/calibre/linux.py    2009-05-26 09:21:40.000000000 +0200
33
 
@@ -444,7 +444,6 @@
 
31
--- calibre-0.6.3+dfsg.orig/src/calibre/linux.py        2009-07-30 00:59:00.000000000 +0200
 
32
+++ calibre-0.6.3+dfsg/src/calibre/linux.py     2009-07-30 10:38:02.000000000 +0200
 
33
@@ -311,7 +311,6 @@
34
34
     global use_destdir
35
35
     use_destdir = opts.destdir
36
36
     manifest = []
38
38
     if opts.no_root or os.geteuid() == 0:
39
39
         manifest += install_man_pages(opts.fatal_errors, use_destdir)
40
40
         manifest += setup_udev_rules(opts.group_file, not opts.dont_reload, opts.fatal_errors)
41
 
@@ -462,13 +461,6 @@
 
41
@@ -329,15 +328,6 @@
42
42
     if opts.save_manifest_to:
43
43
         open(opts.save_manifest_to, 'wb').write('\n'.join(manifest)+'\n')
44
44
 
47
47
-        os.chdir(config_dir)
48
48
-        for f in os.listdir('.'):
49
49
-            if os.stat(f).st_uid == 0:
50
 
-                os.unlink(f)
 
50
-                os.rmdir(f) if os.path.isdir(f) else os.unlink(f)
 
51
-    if os.stat(config_dir).st_uid == 0:
 
52
-        os.rmdir(config_dir)
51
53
-
52
54
 def binary_install():
53
55
     manifest = os.path.join(getattr(sys, 'frozen_path'), 'manifest')