~ubuntu-branches/ubuntu/karmic/cgiirc/karmic-updates

« back to all changes in this revision

Viewing changes to debian/patches/50_reconnect-link.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Damián Viano
  • Date: 2006-09-30 00:15:44 UTC
  • mfrom: (2.1.2 edgy)
  • Revision ID: james.westby@ubuntu.com-20060930001544-t2jjhvc00rnikdw0
Tags: 0.5.9-2
* Fix postinst by moving chgrp and chmod to build-time
* Cleanup debian/rules

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## reconnect-link.dpatch by Pabs <pabs@zip.to>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Provide link to reconnect to cgiirc after a /quit
6
 
## DP: See http://bugs.debian.org/268794
7
 
 
8
 
 
9
 
diff -urNad /home/pabs/code/cgiirc-0.5.4/formats/dark cgiirc-0.5.4/formats/dark
10
 
--- /home/pabs/code/cgiirc-0.5.4/formats/dark   2004-08-29 15:22:05.000000000 +0800
11
 
+++ cgiirc-0.5.4/formats/dark   2004-08-29 15:22:05.000000000 +0800
12
 
@@ -106,6 +106,7 @@
13
 
 error nickinuse = {prefix-server} Nickname $0 is already in use, type /nick newnick to use another.
14
 
 
15
 
 irc close = {prefix-error} Disconnected from IRC
16
 
+reconnect = {prefix-error} Reconnect to CGI:IRC
17
 
 
18
 
 bg = 00
19
 
 fg = 01
20
 
diff -urNad /home/pabs/code/cgiirc-0.5.4/formats/default cgiirc-0.5.4/formats/default
21
 
--- /home/pabs/code/cgiirc-0.5.4/formats/default        2004-08-29 15:22:05.000000000 +0800
22
 
+++ cgiirc-0.5.4/formats/default        2004-08-29 15:22:05.000000000 +0800
23
 
@@ -107,6 +107,7 @@
24
 
 error nickinuse = {prefix-server} Nickname $0 is already in use, type /nick newnick to use another.
25
 
 
26
 
 irc close = {prefix-error} Disconnected from IRC
27
 
+reconnect = {prefix-error} Reconnect to CGI:IRC
28
 
 
29
 
 
30
 
 bg = 00
31
 
diff -urNad /home/pabs/code/cgiirc-0.5.4/formats/gothic cgiirc-0.5.4/formats/gothic
32
 
--- /home/pabs/code/cgiirc-0.5.4/formats/gothic 2004-08-29 15:22:05.000000000 +0800
33
 
+++ cgiirc-0.5.4/formats/gothic 2004-08-29 15:22:05.000000000 +0800
34
 
@@ -106,6 +106,7 @@
35
 
 error nickinuse = {prefix-server} Nickname $0 is already in use, type /nick newnick to use another.
36
 
 
37
 
 irc close = {prefix-error} Disconnected from IRC
38
 
+reconnect = {prefix-error} Reconnect to CGI:IRC
39
 
 
40
 
 bg = 01
41
 
 fg = 00
42
 
diff -urNad /home/pabs/code/cgiirc-0.5.4/formats/mirc cgiirc-0.5.4/formats/mirc
43
 
--- /home/pabs/code/cgiirc-0.5.4/formats/mirc   2004-08-29 15:22:05.000000000 +0800
44
 
+++ cgiirc-0.5.4/formats/mirc   2004-08-29 15:22:05.000000000 +0800
45
 
@@ -109,7 +109,7 @@
46
 
 error nickinuse = {prefix-server} Nickname $0 is already in use, type /nick newnick to use another.
47
 
 
48
 
 irc close = {prefix-error} Disconnected from IRC
49
 
-
50
 
+reconnect = {prefix-error} Reconnect to CGI:IRC
51
 
 
52
 
 bg = 00
53
 
 fg = 01
54
 
diff -urNad /home/pabs/code/cgiirc-0.5.4/formats/russian cgiirc-0.5.4/formats/russian
55
 
--- /home/pabs/code/cgiirc-0.5.4/formats/russian        2004-08-29 15:22:05.000000000 +0800
56
 
+++ cgiirc-0.5.4/formats/russian        2004-08-29 15:22:05.000000000 +0800
57
 
@@ -107,6 +107,7 @@
58
 
 error nickinuse = {prefix-server} ��� $0 ��� ������������, �������� /nick �����_��� ��� ����� ����.
59
 
 
60
 
 irc close = {prefix-error} ������ ����� � IRC
61
 
+reconnect = {prefix-error} Reconnect to CGI:IRC
62
 
 
63
 
 bg = 00
64
 
 fg = 01
65
 
diff -urNad /home/pabs/code/cgiirc-0.5.4/nph-irc.cgi cgiirc-0.5.4/nph-irc.cgi
66
 
--- /home/pabs/code/cgiirc-0.5.4/nph-irc.cgi    2004-08-29 15:22:05.000000000 +0800
67
 
+++ cgiirc-0.5.4/nph-irc.cgi    2004-08-29 15:22:05.000000000 +0800
68
 
@@ -874,6 +874,11 @@
69
 
    net_send($ircfh, "QUIT :$message\r\n");
70
 
    format_out('irc close', { target => '-all', activity => 1 });
71
 
 
72
 
+   my $info = { target => '-all', activity => 1 };
73
 
+   my $reconnect = format_colourhtml(format_parse($format->{'reconnect'}, $info));
74
 
+   my $url = defined $config->{form_redirect} ? $config->{form_redirect} : 'irc.cgi';
75
 
+   interface_lineout($info, "<a href=\"$url\" target=\"_top\">$reconnect</a>");
76
 
+
77
 
    flushoutput();
78
 
 
79
 
    $interface->end if ref $interface;