~ubuntu-branches/ubuntu/lucid/lastfm/lucid

« back to all changes in this revision

Viewing changes to debian/patches/alsa-uses-qdebug.diff

  • Committer: Bazaar Package Importer
  • Author(s): Devid Filoni
  • Date: 2008-07-14 16:46:20 UTC
  • mfrom: (1.1.7 upstream) (3.1.1 lenny)
  • Revision ID: james.westby@ubuntu.com-20080714164620-67hoz9fs177wpgmr
Tags: 1:1.5.1.31879.dfsg-1ubuntu1
* Merge from Debian unstable (LP: #248100), remaining changes:
  - debian/rules: add dh_icons call
  + debian/control:
    - switch iceweasel to firefox in Recommends field
    - modify debhelper version to >= 5.0.51~
    - modify Maintainer to Ubuntu MOTU Developers

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- a/src/output/alsa-playback/alsaaudio.cpp
 
2
+++ b/src/output/alsa-playback/alsaaudio.cpp
 
3
@@ -27,7 +27,12 @@
 
4
  ***************************************************************************/
 
5
 
 
6
 #include "alsaaudio.h"
 
7
+#ifdef QT_NO_DEBUG
 
8
+#include <QDebug>
 
9
+#define Q_DEBUG_BLOCK qDebug()
 
10
+#else
 
11
 #include "logger.h"
 
12
+#endif
 
13
 #include <qendian.h>
 
14
 
 
15
 //no debug