~ubuntu-branches/ubuntu/lucid/openssl/lucid-proposed

« back to all changes in this revision

Viewing changes to debian/patches/disable-sslv2.patch

  • Committer: Bazaar Package Importer
  • Author(s): Nicolas Valcárcel Scerpella (Canonical)
  • Date: 2009-12-06 20:16:24 UTC
  • mfrom: (11.1.9 sid)
  • Revision ID: james.westby@ubuntu.com-20091206201624-u126qjpqm2n2uuhu
Tags: 0.9.8k-7ubuntu1
* Merge from debian unstable, remaining changes (LP: #493392):
  - Link using -Bsymbolic-functions
  - Add support for lpia
  - Disable SSLv2 during compile
  - Ship documentation in openssl-doc, suggested by the package.
  - Use a different priority for libssl0.9.8/restart-services
    depending on whether a desktop, or server dist-upgrade is being
    performed.
  - Display a system restart required notification bubble on libssl0.9.8
    upgrade.
  - Replace duplicate files in the doc directory with symlinks.
  - Move runtime libraries to /lib, for the benefit of wpasupplicant
* Strip the patches out of the source into quilt patches
* Disable CVE-2009-3555.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: openssl-merge/Makefile
 
2
===================================================================
 
3
--- openssl-merge.orig/Makefile 2009-12-07 14:40:22.613469436 -0500
 
4
+++ openssl-merge/Makefile      2009-12-07 14:40:22.623473221 -0500
 
5
@@ -13,8 +13,8 @@
 
6
 SHLIB_MINOR=9.8
 
7
 SHLIB_EXT=.so.$(SHLIB_MAJOR).$(SHLIB_MINOR)
 
8
 PLATFORM=debian-amd64
 
9
-OPTIONS=--prefix=/usr --openssldir=/usr/lib/ssl enable-zlib enable-tlsext no-camellia no-capieng no-cms no-gmp no-idea no-jpake no-krb5 no-mdc2 no-montasm no-rc5 no-rfc3779 no-seed no-shared no-zlib-dynamic
 
10
-CONFIGURE_ARGS=--prefix=/usr --openssldir=/usr/lib/ssl no-idea no-mdc2 no-rc5 zlib enable-tlsext debian-amd64
 
11
+OPTIONS=--prefix=/usr --openssldir=/usr/lib/ssl enable-zlib enable-tlsext no-camellia no-capieng no-cms no-gmp no-idea no-jpake no-krb5 no-mdc2 no-montasm no-rc5 no-rfc3779 no-seed no-shared no-sslv2 no-zlib-dynamic
 
12
+CONFIGURE_ARGS=--prefix=/usr --openssldir=/usr/lib/ssl no-idea no-mdc2 no-rc5 zlib enable-tlsext no-sslv2 debian-amd64
 
13
 SHLIB_TARGET=linux-shared
 
14
 
 
15
 # HERE indicates where this Makefile lives.  This can be used to indicate
 
16
@@ -61,7 +61,7 @@
 
17
 
 
18
 CC= gcc
 
19
 CFLAG= -DZLIB -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -m64 -DL_ENDIAN -DTERMIO -O3 -Wa,--noexecstack -g -Wall -DMD32_REG_T=int -DOPENSSL_BN_ASM_MONT -DSHA1_ASM -DSHA256_ASM -DSHA512_ASM -DMD5_ASM -DAES_ASM
 
20
-DEPFLAG= -DOPENSSL_NO_CAMELLIA -DOPENSSL_NO_CAPIENG -DOPENSSL_NO_CMS -DOPENSSL_NO_GMP -DOPENSSL_NO_IDEA -DOPENSSL_NO_JPAKE -DOPENSSL_NO_MDC2 -DOPENSSL_NO_RC5 -DOPENSSL_NO_RFC3779 -DOPENSSL_NO_SEED
 
21
+DEPFLAG= -DOPENSSL_NO_CAMELLIA -DOPENSSL_NO_CAPIENG -DOPENSSL_NO_CMS -DOPENSSL_NO_GMP -DOPENSSL_NO_IDEA -DOPENSSL_NO_JPAKE -DOPENSSL_NO_MDC2 -DOPENSSL_NO_RC5 -DOPENSSL_NO_RFC3779 -DOPENSSL_NO_SEED -DOPENSSL_NO_SSLV2
 
22
 PEX_LIBS= 
 
23
 EX_LIBS= -ldl -Wl,-Bsymbolic-functions -lz
 
24
 EXE_EXT= 
 
25
Index: openssl-merge/crypto/opensslconf.h
 
26
===================================================================
 
27
--- openssl-merge.orig/crypto/opensslconf.h     2009-12-07 14:40:29.073465676 -0500
 
28
+++ openssl-merge/crypto/opensslconf.h  2009-12-07 14:39:48.171015508 -0500
 
29
@@ -38,6 +38,9 @@
 
30
 #ifndef OPENSSL_NO_SEED
 
31
 # define OPENSSL_NO_SEED
 
32
 #endif
 
33
+#ifndef OPENSSL_NO_SSLV2
 
34
+# define OPENSSL_NO_SSLV2
 
35
+#endif
 
36
 
 
37
 #endif /* OPENSSL_DOING_MAKEDEPEND */
 
38
 
 
39
@@ -86,6 +89,9 @@
 
40
 # if defined(OPENSSL_NO_SEED) && !defined(NO_SEED)
 
41
 #  define NO_SEED
 
42
 # endif
 
43
+# if defined(OPENSSL_NO_SSLV2) && !defined(NO_SSLV2)
 
44
+#  define NO_SSLV2
 
45
+# endif
 
46
 #endif
 
47
 
 
48
 #define OPENSSL_CPUID_OBJ