~ubuntu-branches/ubuntu/lucid/openssl/lucid-proposed

« back to all changes in this revision

Viewing changes to debian/patches/pkg-config.patch

  • Committer: Bazaar Package Importer
  • Author(s): Nicolas Valcárcel Scerpella (Canonical)
  • Date: 2009-12-06 20:16:24 UTC
  • mfrom: (11.1.9 sid)
  • Revision ID: james.westby@ubuntu.com-20091206201624-u126qjpqm2n2uuhu
Tags: 0.9.8k-7ubuntu1
* Merge from debian unstable, remaining changes (LP: #493392):
  - Link using -Bsymbolic-functions
  - Add support for lpia
  - Disable SSLv2 during compile
  - Ship documentation in openssl-doc, suggested by the package.
  - Use a different priority for libssl0.9.8/restart-services
    depending on whether a desktop, or server dist-upgrade is being
    performed.
  - Display a system restart required notification bubble on libssl0.9.8
    upgrade.
  - Replace duplicate files in the doc directory with symlinks.
  - Move runtime libraries to /lib, for the benefit of wpasupplicant
* Strip the patches out of the source into quilt patches
* Disable CVE-2009-3555.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: openssl-0.9.8k/Makefile.org
 
2
===================================================================
 
3
--- openssl-0.9.8k.orig/Makefile.org    2009-07-19 11:34:56.000000000 +0200
 
4
+++ openssl-0.9.8k/Makefile.org 2009-07-19 11:36:02.000000000 +0200
 
5
@@ -444,7 +444,8 @@
 
6
            echo 'Description: OpenSSL cryptography library'; \
 
7
            echo 'Version: '$(VERSION); \
 
8
            echo 'Requires: '; \
 
9
-           echo 'Libs: -L$${libdir} -lcrypto $(EX_LIBS)'; \
 
10
+           echo 'Libs: -L$${libdir} -lcrypto'; \
 
11
+           echo 'Libs.private: $(EX_LIBS)'; \
 
12
            echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > libcrypto.pc
 
13
 
 
14
 libssl.pc: Makefile
 
15
@@ -457,7 +458,8 @@
 
16
            echo 'Description: Secure Sockets Layer and cryptography libraries'; \
 
17
            echo 'Version: '$(VERSION); \
 
18
            echo 'Requires: '; \
 
19
-           echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
 
20
+           echo 'Libs: -L$${libdir} -lssl'; \
 
21
+           echo 'Libs.private: -lcrypto $(EX_LIBS)'; \
 
22
            echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > libssl.pc
 
23
 
 
24
 openssl.pc: Makefile
 
25
@@ -470,7 +472,8 @@
 
26
            echo 'Description: Secure Sockets Layer and cryptography libraries and tools'; \
 
27
            echo 'Version: '$(VERSION); \
 
28
            echo 'Requires: '; \
 
29
-           echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
 
30
+           echo 'Libs: -L$${libdir} -lssl -lcrypto'; \
 
31
+           echo 'Libs.private: $(EX_LIBS)'; \
 
32
            echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > openssl.pc
 
33
 
 
34
 Makefile: Makefile.org Configure config