~ubuntu-branches/ubuntu/maverick/python3.1/maverick

« back to all changes in this revision

Viewing changes to debian/patches/patchlevel.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Matthias Klose
  • Date: 2009-03-23 00:01:27 UTC
  • Revision ID: james.westby@ubuntu.com-20090323000127-mr2oo53y4j8vpldi
Tags: 3.1~a1+20090322-1
* Python 3.1 alpha1 release.
* Update to the trunk, 20090322.
* Update installation schemes: LP: #338395.
  - When the --prefix option is used for setup.py install, Use the
    `unix_prefix' scheme.
  - Use the `deb_system' scheme if --install-layout=deb is specified.
  - Use the the `unix_local' scheme if neither --install-layout=deb
    nor --prefix is specified.
* Use the information in /etc/lsb-release for platform.dist(). LP: #196526.
* pydoc: Fix detection of local documentation files.
* Build a shared library configured --with-pydebug. LP: #322580.
* Fix some lintian warnings.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh -e
 
2
 
 
3
# DP: Set HeadURL and PY_PATCHLEVEL_REVISION.
 
4
 
 
5
dir=
 
6
if [ $# -eq 3 -a "$2" = '-d' ]; then
 
7
    pdir="-d $3"
 
8
    dir="$3/"
 
9
elif [ $# -ne 1 ]; then
 
10
    echo >&2 "usage: `basename $0`: -patch|-unpatch [-d <srcdir>]"
 
11
    exit 1
 
12
fi
 
13
case "$1" in
 
14
    -patch)
 
15
        patch $pdir -f --no-backup-if-mismatch -p0 < $0
 
16
        #cd ${dir}gcc && autoconf
 
17
        ;;
 
18
    -unpatch)
 
19
        patch $pdir -f --no-backup-if-mismatch -R -p0 < $0
 
20
        #rm ${dir}gcc/configure
 
21
        ;;
 
22
    *)
 
23
        echo >&2 "usage: `basename $0`: -patch|-unpatch [-d <srcdir>]"
 
24
        exit 1
 
25
esac
 
26
exit 0
 
27
 
 
28
--- Python/sysmodule.c~ 2006-10-29 11:48:50.000000000 +0100
 
29
+++ Python/sysmodule.c  2006-10-29 12:26:53.000000000 +0100
 
30
@@ -960,7 +960,7 @@
 
31
 
 
32
 /* Subversion branch and revision management */
 
33
 static const char _patchlevel_revision[] = PY_PATCHLEVEL_REVISION;
 
34
-static const char headurl[] = "$HeadURL: svn+ssh://pythondev@svn.python.org/python/tags/r25/Python/sysmodule.c $";
 
35
+static const char headurl[] = "$HeadURL: svn+ssh://pythondev@svn.python.org/python/branches/release25-maint/Python/sysmodule.c $";
 
36
 static int svn_initialized;
 
37
 static char patchlevel_revision[50]; /* Just the number */
 
38
 static char branch[50];
 
39
--- Include/patchlevel.h~       2006-09-18 08:51:50.000000000 +0200
 
40
+++ Include/patchlevel.h        2006-10-29 12:33:07.000000000 +0100
 
41
@@ -29,7 +29,7 @@
 
42
 #define PY_VERSION             "2.5"
 
43
 
 
44
 /* Subversion Revision number of this file (not of the repository) */
 
45
-#define PY_PATCHLEVEL_REVISION  "$Revision: 54692 $"
 
46
+#define PY_PATCHLEVEL_REVISION  "$Revision: 54692 $"
 
47
 
 
48
 /* Version as a single 4-byte hex number, e.g. 0x010502B2 == 1.5.2b2.
 
49
    Use this for numeric comparisons, e.g. #if PY_VERSION_HEX >= ... */