~ubuntu-branches/ubuntu/maverick/python3.1/maverick

« back to all changes in this revision

Viewing changes to debian/patches/setup-modules.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Matthias Klose
  • Date: 2009-03-23 00:01:27 UTC
  • Revision ID: james.westby@ubuntu.com-20090323000127-mr2oo53y4j8vpldi
Tags: 3.1~a1+20090322-1
* Python 3.1 alpha1 release.
* Update to the trunk, 20090322.
* Update installation schemes: LP: #338395.
  - When the --prefix option is used for setup.py install, Use the
    `unix_prefix' scheme.
  - Use the `deb_system' scheme if --install-layout=deb is specified.
  - Use the the `unix_local' scheme if neither --install-layout=deb
    nor --prefix is specified.
* Use the information in /etc/lsb-release for platform.dist(). LP: #196526.
* pydoc: Fix detection of local documentation files.
* Build a shared library configured --with-pydebug. LP: #322580.
* Fix some lintian warnings.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh -e
 
2
 
 
3
# DP: Modules/Setup.dist: patches to build some extensions staically
 
4
 
 
5
dir=
 
6
if [ $# -eq 3 -a "$2" = '-d' ]; then
 
7
    pdir="-d $3"
 
8
    dir="$3/"
 
9
elif [ $# -ne 1 ]; then
 
10
    echo >&2 "usage: `basename $0`: -patch|-unpatch [-d <srcdir>]"
 
11
    exit 1
 
12
fi
 
13
case "$1" in
 
14
    -patch)
 
15
        patch $pdir -f --no-backup-if-mismatch -p0 < $0
 
16
        ;;
 
17
    -unpatch)
 
18
        patch $pdir -f --no-backup-if-mismatch -R -p0 < $0
 
19
        ;;
 
20
    *)
 
21
        echo >&2 "usage: `basename $0`: -patch|-unpatch [-d <srcdir>]"
 
22
        exit 1
 
23
esac
 
24
exit 0
 
25
 
 
26
--- Modules/_elementtree.c.orig 2009-03-22 23:07:51.000000000 +0000
 
27
+++ Modules/_elementtree.c      2009-03-22 23:08:12.000000000 +0000
 
28
@@ -1838,7 +1838,10 @@
 
29
 static struct PyExpat_CAPI* expat_capi;
 
30
 #define EXPAT(func) (expat_capi->func)
 
31
 #else
 
32
-#define EXPAT(func) (XML_##func)
 
33
+#define EXPAT(func) (PyExpat_XML_##func)
 
34
+#define PyExpat_XML_GetErrorLineNumber   PyExpat_XML_GetCurrentLineNumber
 
35
+#define PyExpat_XML_GetErrorColumnNumber PyExpat_XML_GetCurrentColumnNumber
 
36
+#define PyExpat_XML_GetErrorByteIndex    PyExpat_XML_GetCurrentByteIndex
 
37
 #endif
 
38
 
 
39
 typedef struct {
 
40
--- Modules/Setup.dist.orig     2009-03-22 23:07:51.000000000 +0000
 
41
+++ Modules/Setup.dist  2009-03-22 23:09:29.000000000 +0000
 
42
@@ -164,7 +164,7 @@
 
43
 #_collections _collectionsmodule.c # Container types
 
44
 #itertools itertoolsmodule.c   # Functions creating iterators for efficient looping 
 
45
 #atexit atexitmodule.c      # Register functions to be run at interpreter-shutdown
 
46
-#_elementtree -I$(srcdir)/Modules/expat -DHAVE_EXPAT_CONFIG_H -DUSE_PYEXPAT_CAPI _elementtree.c        # elementtree accelerator
 
47
+#_elementtree -I$(srcdir)/Modules/expat -DHAVE_EXPAT_CONFIG_H _elementtree.c   # elementtree accelerator
 
48
 #_pickle _pickle.c     # pickle accelerator
 
49
 #datetime datetimemodule.c     # date/time type
 
50
 #_bisect _bisectmodule.c       # Bisection algorithms
 
51
@@ -341,6 +341,7 @@
 
52
 #DBLIB=$(DB)/lib
 
53
 #_bsddb _bsddb.c -I$(DBINC) -L$(DBLIB) -ldb-$(DBLIBVER)
 
54
 
 
55
+#_ctypes _ctypes/_ctypes.c _ctypes/callbacks.c _ctypes/callproc.c _ctypes/stgdict.c _ctypes/cfield.c _ctypes/malloc_closure.c -Wl,-Bstatic -lffi -Wl,-Bdynamic
 
56
 
 
57
 # Helper module for various ascii-encoders
 
58
 #binascii binascii.c
 
59
@@ -382,7 +383,7 @@
 
60
 #
 
61
 # More information on Expat can be found at www.libexpat.org.
 
62
 #
 
63
-#pyexpat expat/xmlparse.c expat/xmlrole.c expat/xmltok.c pyexpat.c -I$(srcdir)/Modules/expat -DHAVE_EXPAT_CONFIG_H -DUSE_PYEXPAT_CAPI
 
64
+#pyexpat expat/xmlparse.c expat/xmlrole.c expat/xmltok.c pyexpat.c -I$(srcdir)/Modules/expat -DHAVE_EXPAT_CONFIG_H
 
65
 
 
66
 # Hye-Shik Chang's CJKCodecs
 
67