~ubuntu-branches/ubuntu/maverick/python3.1/maverick

« back to all changes in this revision

Viewing changes to debian/patches/webbrowser.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Matthias Klose
  • Date: 2009-03-23 00:01:27 UTC
  • Revision ID: james.westby@ubuntu.com-20090323000127-mr2oo53y4j8vpldi
Tags: 3.1~a1+20090322-1
* Python 3.1 alpha1 release.
* Update to the trunk, 20090322.
* Update installation schemes: LP: #338395.
  - When the --prefix option is used for setup.py install, Use the
    `unix_prefix' scheme.
  - Use the `deb_system' scheme if --install-layout=deb is specified.
  - Use the the `unix_local' scheme if neither --install-layout=deb
    nor --prefix is specified.
* Use the information in /etc/lsb-release for platform.dist(). LP: #196526.
* pydoc: Fix detection of local documentation files.
* Build a shared library configured --with-pydebug. LP: #322580.
* Fix some lintian warnings.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh -e
 
2
 
 
3
# DP: Recognize other browsers: www-browser, x-www-browser, iceweasel, iceape.
 
4
 
 
5
dir=
 
6
if [ $# -eq 3 -a "$2" = '-d' ]; then
 
7
    pdir="-d $3"
 
8
    dir="$3/"
 
9
elif [ $# -ne 1 ]; then
 
10
    echo >&2 "usage: `basename $0`: -patch|-unpatch [-d <srcdir>]"
 
11
    exit 1
 
12
fi
 
13
case "$1" in
 
14
    -patch)
 
15
        patch $pdir -f --no-backup-if-mismatch -p0 < $0
 
16
        ;;
 
17
    -unpatch)
 
18
        patch $pdir -f --no-backup-if-mismatch -R -p0 < $0
 
19
        ;;
 
20
    *)
 
21
        echo >&2 "usage: `basename $0`: -patch|-unpatch [-d <srcdir>]"
 
22
        exit 1
 
23
esac
 
24
exit 0
 
25
 
 
26
--- Lib/webbrowser.py~  2007-07-04 15:50:53.000000000 +0200
 
27
+++ Lib/webbrowser.py   2007-08-31 16:11:12.000000000 +0200
 
28
@@ -453,9 +453,13 @@
 
29
     if "KDE_FULL_SESSION" in os.environ and _iscommand("kfmclient"):
 
30
         register("kfmclient", Konqueror, Konqueror("kfmclient"))
 
31
 
 
32
+    if _iscommand("x-www-browser"):
 
33
+        register("x-www-browser", None, BackgroundBrowser("x-www-browser"))
 
34
+
 
35
     # The Mozilla/Netscape browsers
 
36
     for browser in ("mozilla-firefox", "firefox",
 
37
                     "mozilla-firebird", "firebird",
 
38
+                    "iceweasel", "iceape",
 
39
                     "seamonkey", "mozilla", "netscape"):
 
40
         if _iscommand(browser):
 
41
             register(browser, None, Mozilla(browser))
 
42
@@ -493,6 +497,8 @@
 
43
 
 
44
 # Also try console browsers
 
45
 if os.environ.get("TERM"):
 
46
+    if _iscommand("www-browser"):
 
47
+        register("www-browser", None, GenericBrowser("www-browser"))
 
48
     # The Links/elinks browsers <http://artax.karlin.mff.cuni.cz/~mikulas/links/>
 
49
     if _iscommand("links"):
 
50
         register("links", None, GenericBrowser("links"))