~ubuntu-branches/ubuntu/natty/lirc/natty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/hauppauge-tv-card.patch

  • Committer: Bazaar Package Importer
  • Author(s): Mario Limonciello
  • Date: 2010-04-02 15:06:19 UTC
  • mfrom: (1.2.10 upstream)
  • Revision ID: james.westby@ubuntu.com-20100402150619-y1z8c1yqv621a11o
Tags: 0.8.7~pre2-0ubuntu1
* Update to 0.8.7~pre2
  - Fixes issues with lirc on maverick. (LP: #620498)
* Add lirc-in-kernel-ioctls.patch to use ioctls from the kernel for drivers.
* Drop patches upstream now:
  - debian/patches/appleir_repeat_issue.patch
  - debian/patches/hauppauge-tv-card.patch
  - debian/patches/lirc-i2c-2.6.patch
  - debian/patches/lirc_dev-2.6.33.patch
* Add updated-driver-names.patch 
* Refresh patches:
  - debian/patches/02_Makefile.in
  - debian/patches/13-warning-cleanup
* Update extra transmitter and remote databases to not reference atiusb.
* debian/control:
  - Update branches to be owned by ~mythbuntu-dev
* Disable in-kernel-support when starting lircd, and re-enable when
  stopping.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Hauppauge TV Card is detected as Leadtek IR
2
 
Origin: upstream, http://lirc.cvs.sourceforge.net/viewvc/lirc/lirc/drivers/lirc_i2c/lirc_i2c.c?r1=1.71&r2=1.72
3
 
Bug-Ubuntu: https://launchpad.net/bugs/550369
4
 
 
5
 
--- a/drivers/lirc_i2c/lirc_i2c.c       2009/12/15 05:37:00     1.71
6
 
+++ b/drivers/lirc_i2c/lirc_i2c.c       2009/12/28 15:29:03     1.72
7
 
@@ -492,20 +492,23 @@
8
 
                ir->l.add_to_buf = add_to_buf_pv951;
9
 
                break;
10
 
        case 0x71:
11
 
-#ifdef I2C_HW_B_CX2341X
12
 
-               if (adap->id == (I2C_ALGO_BIT | I2C_HW_B_BT848) ||
13
 
-                   adap->id == (I2C_ALGO_BIT | I2C_HW_B_CX2341X)) {
14
 
-#else
15
 
-               if (adap->id == (I2C_ALGO_BIT | I2C_HW_B_BT848)) {
16
 
+
17
 
+
18
 
+
19
 
+#ifdef I2C_HW_B_CX2388x
20
 
+               /* Leadtek Winfast PVR2000 or Hauppauge HVR-1300 */
21
 
+               if (adap->id == (I2C_ALGO_BIT | I2C_HW_B_CX2388x))
22
 
+                       strlcpy(ir->c.name, "Hauppauge HVR1300", I2C_NAME_SIZE);
23
 
+               else
24
 
 #endif
25
 
+               {
26
 
                        /*
27
 
                         * The PVR150 IR receiver uses the same protocol as
28
 
                         * other Hauppauge cards, but the data flow is
29
 
                         * different, so we need to deal with it by its own.
30
 
                         */
31
 
                        strlcpy(ir->c.name, "Hauppauge PVR150", I2C_NAME_SIZE);
32
 
-               } else /* I2C_HW_B_CX2388x */
33
 
-                       strlcpy(ir->c.name, "Hauppauge HVR1300", I2C_NAME_SIZE);
34
 
+               }
35
 
                ir->l.code_length = 13;
36
 
                ir->l.add_to_buf = add_to_buf_haup_pvr150;
37
 
                break;
38
 
@@ -516,19 +519,18 @@
39
 
                break;
40
 
        case 0x18:
41
 
        case 0x1a:
42
 
-#ifdef I2C_HW_B_CX2341X
43
 
-               if (adap->id == (I2C_ALGO_BIT | I2C_HW_B_BT848) ||
44
 
-                   adap->id == (I2C_ALGO_BIT | I2C_HW_B_CX2341X)) {
45
 
+#ifdef I2C_HW_B_CX2388x
46
 
+               if (adap->id == (I2C_ALGO_BIT | I2C_HW_B_CX2388x)) {
47
 
+                       strlcpy(ir->c.name, "Leadtek IR", I2C_NAME_SIZE);
48
 
+                       ir->l.code_length = 8;
49
 
+                       ir->l.add_to_buf = add_to_buf_pvr2000;
50
 
+               } else {
51
 
 #else
52
 
-               if (adap->id == (I2C_ALGO_BIT | I2C_HW_B_BT848)) {
53
 
+               {
54
 
 #endif
55
 
                        strlcpy(ir->c.name, "Hauppauge IR", I2C_NAME_SIZE);
56
 
                        ir->l.code_length = 13;
57
 
                        ir->l.add_to_buf = add_to_buf_haup;
58
 
-               } else { /* I2C_HW_B_CX2388x */
59
 
-                       strlcpy(ir->c.name, "Leadtek IR", I2C_NAME_SIZE);
60
 
-                       ir->l.code_length = 8;
61
 
-                       ir->l.add_to_buf = add_to_buf_pvr2000;
62
 
                }
63
 
                break;
64
 
        case 0x30: