~ubuntu-branches/ubuntu/natty/lirc/natty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/lirc-i2c-2.6.patch

  • Committer: Bazaar Package Importer
  • Author(s): Mario Limonciello
  • Date: 2010-04-02 15:06:19 UTC
  • mfrom: (1.2.10 upstream)
  • Revision ID: james.westby@ubuntu.com-20100402150619-y1z8c1yqv621a11o
Tags: 0.8.7~pre2-0ubuntu1
* Update to 0.8.7~pre2
  - Fixes issues with lirc on maverick. (LP: #620498)
* Add lirc-in-kernel-ioctls.patch to use ioctls from the kernel for drivers.
* Drop patches upstream now:
  - debian/patches/appleir_repeat_issue.patch
  - debian/patches/hauppauge-tv-card.patch
  - debian/patches/lirc-i2c-2.6.patch
  - debian/patches/lirc_dev-2.6.33.patch
* Add updated-driver-names.patch 
* Refresh patches:
  - debian/patches/02_Makefile.in
  - debian/patches/13-warning-cleanup
* Update extra transmitter and remote databases to not reference atiusb.
* debian/control:
  - Update branches to be owned by ~mythbuntu-dev
* Disable in-kernel-support when starting lircd, and re-enable when
  stopping.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
## Description: Fixes building lirc-i2c on 2.6.32
2
 
## Origin/Author: Jarod Wilson
3
 
## Bug: https://bugs.edge.launchpad.net/ubuntu/+source/lirc/+bug/513042
4
 
Index: lirc/drivers/lirc_i2c/lirc_i2c.c
5
 
===================================================================
6
 
--- lirc.orig/drivers/lirc_i2c/lirc_i2c.c       2010-03-27 23:28:53.276235463 -0500
7
 
+++ lirc/drivers/lirc_i2c/lirc_i2c.c    2010-03-27 23:28:46.927258425 -0500
8
 
@@ -1,4 +1,4 @@
9
 
-/*      $Id: lirc_i2c.c,v 1.70 2009/08/30 16:59:53 jarodwilson Exp $      */
10
 
+/*      $Id: lirc_i2c.c,v 1.71 2009/12/15 05:37:00 jarodwilson Exp $      */
11
 
 
12
 
 /*
13
 
  * lirc_i2c.c
14
 
@@ -399,8 +399,8 @@
15
 
                .name   = "i2c ir driver",
16
 
        },
17
 
 #endif
18
 
-       .id             = I2C_DRIVERID_EXP3, /* FIXME */
19
 
 #if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 31)
20
 
+       .id             = I2C_DRIVERID_EXP3, /* FIXME */
21
 
        .attach_adapter = ir_probe,
22
 
        .detach_client  = ir_remove,
23
 
 #else