~ubuntu-branches/ubuntu/natty/ntop/natty

« back to all changes in this revision

Viewing changes to debian/patches/fix-wget-during-build.patch

  • Committer: Bazaar Package Importer
  • Author(s): Ludovico Cavedon, Jordan Metzmeier, Ludovico Cavedon
  • Date: 2010-12-15 20:06:19 UTC
  • mfrom: (5.1.5 sid)
  • Revision ID: james.westby@ubuntu.com-20101215200619-0ojz3iak95ihibun
Tags: 3:4.0.3+dfsg1-1
[ Jordan Metzmeier ]
* New upstream release (Closes: #522042)
* Move data files to /usr/share/ntop (Closes: #595450).
* Package architecture independent data in a separate ntop-data package.
* Use debhelper 7.
* Update Standards-Version to 3.9.1.
* Depend on python-mako.
* Do not include ntop.txt in binary packages as it is a copy of the man
  page.
* Do not include NEWS, as it is outdated.
* Switch to package source version 3.0 (quilt).
* Add password creation to debconf
* Changed init script to fix localization problems (thanks to Alejandro
  Varas <alej0varas@gmail.com>, LP: #257466)
* Remove manual update-rc.d calls from postrm and postinst. debhelper adds
  this for us.
* Add pre-depends on adduser for postinst script.
* Fix errors in the manpages: fix-manpage-errors.patch.
* Added fixes for matching active interfaces.
* Added a watch file.

[ Ludovico Cavedon ]
* Remove direct changes to upstream tree, and move them into specific patch
  files:
  - fix-manpage-errors.patch: fix typos in ntop.8.
  - dot-path.patch: fix path of /usr/bin/dot executable
* Add patches:
  - reduce-autogen-purged-files.patch: prevent agutogen.sh from reamoving
  too many files during cleanup.
  - Add build-without-ntop-darwin.patch, to fix compilation without
  ntop_darwin.c.
* No longer add faq.html, as it is not distributed in the upstream tarball.
* Use ${source:Version} in control file. Have ntop-data recommend
  ntop.
* Rename dirs to ntop.dirs and keep only empty directories that need
  to be created.
* Remove var/lib from ntop.install file, as it is empty (keeping it in
  ntop.dirs).
* Update po files.
* Breaks and Replaces instead of Conflitcs for ntop-data.
* Use a longer package description.
* Remove useless configure options from debian/rules.
* Move private shared libraries libraries in /usr/lib/ntop.
* Add change-plugin-dir.patch for adjusting plugin directory.
* Remove development files.
* Use system library for MochiKit.js.
* Rewrite DEP5 copyright file.
* Repackage upstream tarball in order to remove non-DFSG-compliant code. Add
  get-orig-source.sh script and get-orig-source target in debian/rules.
* Add explanation to README.Debian why geolocation is no longer working.
* Add avoid-copy-maxmind-db.patch to prevent copying of Geo*.dat
  files.
* Remove old unused patches.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Desription: do not download data files from the internet when building.
 
2
Author: Jordan Metzmeier <jordan@linuxgen.com>
 
3
Index: ntop/Makefile.am
 
4
===================================================================
 
5
--- ntop.orig/Makefile.am       2010-12-09 23:24:13.122729218 -0800
 
6
+++ ntop/Makefile.am    2010-12-09 23:24:17.065699319 -0800
 
7
@@ -372,28 +372,7 @@
 
8
 dnvt:
 
9
        @echo ""
 
10
        @echo ""
 
11
-       @echo -n "Preparing "
 
12
-       @if test -f oui.txt; then \
 
13
-         rm -rf oui.txt; \
 
14
-       fi
 
15
-       @if test -f oui.txt.gz.old; then \
 
16
-         rm -rf oui.txt.gz.old; \
 
17
-       fi;
 
18
-       @mv oui.txt.gz oui.txt.gz.old
 
19
-       @echo "(old oui.txt.gz file is now oui.txt.gz.old)"
 
20
-       @echo ""
 
21
-       @wget -c http://standards.ieee.org/regauth/oui/oui.txt
 
22
-       @gzip oui.txt
 
23
-       @echo ""
 
24
-       @echo ""
 
25
-       @echo -n "Old file lines were: "
 
26
-       @gunzip -c oui.txt.gz.old | wc -l
 
27
-       @echo -n "New file lines are:  "
 
28
-       @gunzip -c oui.txt.gz | wc -l
 
29
-       @echo ""
 
30
-       @echo ""
 
31
-       @echo "New file is:"
 
32
-       @ls -l oui.txt.gz
 
33
+       @echo -n "Nothing to do here "
 
34
 
 
35
 # download the Novell SAP Protocol information table
 
36
 #dnsapt:
 
37
@@ -403,43 +382,8 @@
 
38
 dnetter:
 
39
        @echo ""
 
40
        @echo ""
 
41
-       @echo "Preparing "
 
42
-       @echo ""
 
43
-
 
44
-       @if test -f $(ETTER_PASSIVE).old; then \
 
45
-         echo "...Deleting prior file, $(ETTER_PASSIVE).old..."; \
 
46
-         rm -rf $(ETTER_PASSIVE).old; \
 
47
-       fi;
 
48
-       @if test -f $(ETTER_PASSIVE); then \
 
49
-         echo "...Moving current $(ETTER_PASSIVE) to $(ETTER_PASSIVE).old"; \
 
50
-         mv $(ETTER_PASSIVE) $(ETTER_PASSIVE).old; \
 
51
-       fi;
 
52
-       @for file in $(ETTER_PASSIVE) $(ETTER_PASSIVE).gz \
 
53
-               $(ETTER_PASSIVE_FILE) $(ETTER_PASSIVE_FILE).gz; do \
 
54
-          if test -f $$file; then \
 
55
-            echo "...Deleting prior file, $$file..."; \
 
56
-             rm -rf $$file; \
 
57
-          fi; \
 
58
-        done
 
59
-       @echo ""
 
60
-       @echo "...Downloading new file..."
 
61
-       @wget -O $(ETTER_PASSIVE_FILE) \
 
62
-               $(ETTER_PASSIVE_DOWNLOAD_FROM)/$(ETTER_PASSIVE_FILE)?$(ETTER_PASSIVE_DOWNLOAD_PARMS)
 
63
-       @echo ""
 
64
-       @echo "gziping downloaded file..."
 
65
-       @gzip $(ETTER_PASSIVE_FILE)
 
66
-       @echo ""
 
67
-       @echo ""
 
68
-       @if test -f $(ETTER_PASSIVE).old; then \
 
69
-         echo -n "Old file lines were: "; \
 
70
-         gunzip -c $(ETTER_PASSIVE).old | wc -l; \
 
71
-       fi;
 
72
-       @echo -n "New file lines are:  "
 
73
-       @gunzip -c $(ETTER_PASSIVE) | wc -l
 
74
-       @echo ""
 
75
+       @echo "Nothing to do here "
 
76
        @echo ""
 
77
-       @echo "New file is:"
 
78
-       @ls -l $(ETTER_PASSIVE)
 
79
 
 
80
 # ntop census
 
81
 census-fail:
 
82
Index: ntop/autogen.sh
 
83
===================================================================
 
84
--- ntop.orig/autogen.sh        2010-12-09 23:24:13.138699544 -0800
 
85
+++ ntop/autogen.sh     2010-12-09 23:24:17.065699319 -0800
 
86
@@ -202,16 +202,6 @@
 
87
   GNU_OR_DIE=0
 
88
 }
 
89
 
 
90
-WGET=`find_command 'wget*'`
 
91
-($WGET --version) < /dev/null > /dev/null 2>&1 ||
 
92
-{
 
93
-  echo
 
94
-  echo "You must have wget installed to compile $progname."
 
95
-  echo "Download the appropriate package for your distribution, or get the"
 
96
-  echo "source tarball from ftp://ftp.gnu.org/pub/gnu/wget"
 
97
-  GNU_OR_DIE=0
 
98
-}
 
99
-
 
100
 if test "$GNU_OR_DIE" -eq 0; then
 
101
   exit 1
 
102
 fi
 
103
Index: ntop/configure.in
 
104
===================================================================
 
105
--- ntop.orig/configure.in      2010-12-09 23:24:13.146708593 -0800
 
106
+++ ntop/configure.in   2010-12-09 23:24:17.093712450 -0800
 
107
@@ -1830,7 +1830,7 @@
 
108
    if test -f "3rd_party/GeoLiteCity.dat.gz"; then
 
109
      cp 3rd_party/GeoLiteCity.dat.gz .
 
110
    else
 
111
-     wget http://www.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
 
112
+       echo 'GeoLiteCity.dat.gz: file not found'
 
113
    fi
 
114
 
 
115
    gunzip GeoLiteCity.dat.gz
 
116
@@ -1844,7 +1844,7 @@
 
117
    if test -f "3rd_party/GeoIPASNum.dat.gz"; then
 
118
      cp 3rd_party/GeoIPASNum.dat.gz .
 
119
    else
 
120
-     wget http://www.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz
 
121
+       echo 'GeoIPASNum.dat.gz: file not found'
 
122
    fi
 
123
 
 
124
    gunzip GeoIPASNum.dat.gz