~ubuntu-branches/ubuntu/natty/ntop/natty

« back to all changes in this revision

Viewing changes to debian/patches/ntop-3.2-snmp_plugin_ipv6.diff

  • Committer: Bazaar Package Importer
  • Author(s): Ludovico Cavedon, Jordan Metzmeier, Ludovico Cavedon
  • Date: 2010-12-15 20:06:19 UTC
  • mfrom: (5.1.5 sid)
  • Revision ID: james.westby@ubuntu.com-20101215200619-0ojz3iak95ihibun
Tags: 3:4.0.3+dfsg1-1
[ Jordan Metzmeier ]
* New upstream release (Closes: #522042)
* Move data files to /usr/share/ntop (Closes: #595450).
* Package architecture independent data in a separate ntop-data package.
* Use debhelper 7.
* Update Standards-Version to 3.9.1.
* Depend on python-mako.
* Do not include ntop.txt in binary packages as it is a copy of the man
  page.
* Do not include NEWS, as it is outdated.
* Switch to package source version 3.0 (quilt).
* Add password creation to debconf
* Changed init script to fix localization problems (thanks to Alejandro
  Varas <alej0varas@gmail.com>, LP: #257466)
* Remove manual update-rc.d calls from postrm and postinst. debhelper adds
  this for us.
* Add pre-depends on adduser for postinst script.
* Fix errors in the manpages: fix-manpage-errors.patch.
* Added fixes for matching active interfaces.
* Added a watch file.

[ Ludovico Cavedon ]
* Remove direct changes to upstream tree, and move them into specific patch
  files:
  - fix-manpage-errors.patch: fix typos in ntop.8.
  - dot-path.patch: fix path of /usr/bin/dot executable
* Add patches:
  - reduce-autogen-purged-files.patch: prevent agutogen.sh from reamoving
  too many files during cleanup.
  - Add build-without-ntop-darwin.patch, to fix compilation without
  ntop_darwin.c.
* No longer add faq.html, as it is not distributed in the upstream tarball.
* Use ${source:Version} in control file. Have ntop-data recommend
  ntop.
* Rename dirs to ntop.dirs and keep only empty directories that need
  to be created.
* Remove var/lib from ntop.install file, as it is empty (keeping it in
  ntop.dirs).
* Update po files.
* Breaks and Replaces instead of Conflitcs for ntop-data.
* Use a longer package description.
* Remove useless configure options from debian/rules.
* Move private shared libraries libraries in /usr/lib/ntop.
* Add change-plugin-dir.patch for adjusting plugin directory.
* Remove development files.
* Use system library for MochiKit.js.
* Rewrite DEP5 copyright file.
* Repackage upstream tarball in order to remove non-DFSG-compliant code. Add
  get-orig-source.sh script and get-orig-source target in debian/rules.
* Add explanation to README.Debian why geolocation is no longer working.
* Add avoid-copy-maxmind-db.patch to prevent copying of Geo*.dat
  files.
* Remove old unused patches.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- plugins/snmpPlugin.c.orig   2006-02-05 14:31:57.000000000 +0300
2
 
+++ plugins/snmpPlugin.c        2006-02-05 14:32:04.000000000 +0300
3
 
@@ -201,7 +201,9 @@
4
 
 
5
 
 static oid* encodeEth(HostTraffic* el);
6
 
 static oid* encodeIpv4(HostTraffic* el);
7
 
+#ifdef INET6
8
 
 static oid* encodeIpv6(HostTraffic* el);
9
 
+#endif
10
 
 static oid* encodeFc(HostTraffic* el);
11
 
 #endif /* HAVE_SNMP */
12
 
 
13
 
@@ -467,7 +469,8 @@
14
 
       addrput (AF_INET, &(serial->value.ipSerial.ipAddress), &mod_value);
15
 
 
16
 
       break;
17
 
-
18
 
+      
19
 
+#ifdef INET6
20
 
     case SERIAL_IPV6:
21
 
       if (octet_data_length != 16)
22
 
        return -1;
23
 
@@ -484,6 +487,7 @@
24
 
       addrput (AF_INET, &(serial->value.ipSerial.ipAddress), &mod_value);
25
 
 
26
 
       break;
27
 
+#endif
28
 
 
29
 
     case SERIAL_FC:
30
 
       return -1;
31
 
@@ -601,9 +605,11 @@
32
 
   case SERIAL_IPV4:
33
 
     tmp = encodeIpv4(el);
34
 
     break;
35
 
+#ifdef INET6
36
 
   case SERIAL_IPV6:
37
 
     tmp = encodeIpv6(el);
38
 
     break;
39
 
+#endif
40
 
   case SERIAL_FC:
41
 
     tmp = encodeFc(el);
42
 
     break;
43
 
@@ -693,6 +699,7 @@
44
 
   return tmpoid;
45
 
 }
46
 
 
47
 
+#ifdef INET6
48
 
 static oid* encodeIpv6(HostTraffic* el){
49
 
   oid* tmpoid = malloc(sizeof(oid)*17);
50
 
   int i,j;
51
 
@@ -708,6 +715,7 @@
52
 
   }
53
 
   return tmpoid;
54
 
 }
55
 
+#endif
56
 
 
57
 
 static oid* encodeEth(HostTraffic* el){
58
 
   oid* tmpoid = malloc(sizeof(oid)*7);
59
 
@@ -850,10 +858,12 @@
60
 
              cp = (char *)&traffic->hostSerial.value.ipSerial.ipAddress.Ip4Address.s_addr;
61
 
              size = 4;
62
 
              break;
63
 
+#ifdef INET6
64
 
            case SERIAL_IPV6:
65
 
              cp =(char *)&traffic->hostSerial.value.ipSerial.ipAddress.Ip6Address.s6_addr;
66
 
              size = 16;
67
 
              break;
68
 
+#endif
69
 
            case SERIAL_FC:
70
 
              /*TODO*/
71
 
              size = LEN_FC_ADDRESS_DISPLAY;