~ubuntu-branches/ubuntu/oneiric/boinc-app-seti/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/003_dont_use_own_jpeglib.patch

  • Committer: Bazaar Package Importer
  • Author(s): Frank S. Thomas, Steffen Moeller, Frank S. Thomas
  • Date: 2008-01-23 21:27:23 UTC
  • mfrom: (2.1.3 hardy)
  • Revision ID: james.westby@ubuntu.com-20080123212723-3c05zp04f8m1vk5s
Tags: 5.13+cvs20060510-4
[ Steffen Moeller ]
* debian/rules: Wrote get-orig-source target that downloads the latest
  nightly tarball.

[ Frank S. Thomas ]
* debian/control.in:
  - Bumped Standards-Version from 3.7.2 to 3.7.3, no changes required.
  - Changed my maintainer address to fst@debian.org.
* debian/rules: Remove --disable-dependency-tracking from configure's
  arguments, because it breaks some handwritten rules in client/Makefile.am
  which require that $(DEPDIR) exists.
* Bumped debhelper compat level from V5 to V6 since this is the current
  recommended level and raised the build dependency to "debhelper (>= 6)".
* debian/patches/: Added 201_missing_header_for_gcc4.3.patch in order to
  fix a FTBFS with recent GCC 4.3 snapshots. Thanks to Martin Michlmayr
  <tbm@cyrius.com> for the bug report. (closes: #462051)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
The commented SAH_CHECK_JPEGLIB in configure.ac prevents that setiathome
 
2
will be linked against libjpeg. If the package should be configured with
 
3
"--enable-graphics" this needs to be uncommented.
 
4
 
 
5
Index: boinc-app-seti-5.13+cvs20060510/Makefile.am
 
6
===================================================================
 
7
--- boinc-app-seti-5.13+cvs20060510.orig/Makefile.am    2005-10-26 20:23:03.000000000 +0200
 
8
+++ boinc-app-seti-5.13+cvs20060510/Makefile.am 2007-07-19 14:10:04.000000000 +0200
 
9
@@ -28,7 +28,7 @@
 
10
 endif
 
11
 
 
12
 
 
13
-SUBDIRS = $(JPEGDIR) $(IMDIR) $(GLUTDIR) $(CLIENT_SUBDIRS) $(SERVER_SUBDIRS)
 
14
+SUBDIRS = $(IMDIR) $(GLUTDIR) $(CLIENT_SUBDIRS) $(SERVER_SUBDIRS)
 
15
 
 
16
 dist-hook:
 
17
        rm -rf `find $(distdir) -name .backup -prune -o -name '*~' -o -name CVS`
 
18
Index: boinc-app-seti-5.13+cvs20060510/configure.ac
 
19
===================================================================
 
20
--- boinc-app-seti-5.13+cvs20060510.orig/configure.ac   2007-07-19 14:10:04.000000000 +0200
 
21
+++ boinc-app-seti-5.13+cvs20060510/configure.ac        2007-07-19 14:10:41.000000000 +0200
 
22
@@ -195,7 +195,7 @@
 
23
     AC_DEFINE([HAVE_LIBSOCKET],[1],[Define to 1 if you have the socket library]))
 
24
 SAH_CHECK_LIB([z], [uncompress], 
 
25
     AC_DEFINE([HAVE_LIBZ],[1],[Define to 1 if you have the z library]))
 
26
-SAH_CHECK_JPEGLIB
 
27
+#SAH_CHECK_JPEGLIB
 
28
 SAH_CHECK_LIB([stdc++],[sscanf],
 
29
     AC_DEFINE([HAVE_LIBSTDC__],[1],[Define to 1 if you have the stdc++ library]))
 
30
 SAH_CHECK_LIB([gcc_eh],[_Unwind_Resume], 
 
31
@@ -315,6 +315,7 @@
 
32
 AH_TEMPLATE([HAVE_STD_TRANSFORM],[Define to 1 if transform is in namespace std::])
 
33
 SAH_FUNCS_IN_NAMESPACE([['min(0,0)'] ['max(0,0)'] ['transform((char *)0,(char *)0,(char *)0,(int(*)(int))malloc)']],std)
 
34
 
 
35
+AM_CONDITIONAL(USE_MY_LIBJPEG, [false])
 
36
 AM_CONDITIONAL(USE_MY_IMAGELIBS, [false])
 
37
 AM_CONDITIONAL(USE_MY_GLUT, [false])
 
38
 AM_CONDITIONAL(ENABLE_SERVER, [test "${enable_server}" = yes])
 
39
@@ -360,7 +361,6 @@
 
40
 ])
 
41
 
 
42
 AC_CONFIG_FILES([Makefile
 
43
-                 jpeglib/Makefile
 
44
                  client/Makefile
 
45
                 tools/Makefile
 
46
                  db/Makefile