~ubuntu-branches/ubuntu/oneiric/boinc-app-seti/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/004_include_new_str_util.h.patch

  • Committer: Bazaar Package Importer
  • Author(s): Frank S. Thomas, Steffen Moeller, Frank S. Thomas
  • Date: 2008-01-23 21:27:23 UTC
  • mfrom: (2.1.3 hardy)
  • Revision ID: james.westby@ubuntu.com-20080123212723-3c05zp04f8m1vk5s
Tags: 5.13+cvs20060510-4
[ Steffen Moeller ]
* debian/rules: Wrote get-orig-source target that downloads the latest
  nightly tarball.

[ Frank S. Thomas ]
* debian/control.in:
  - Bumped Standards-Version from 3.7.2 to 3.7.3, no changes required.
  - Changed my maintainer address to fst@debian.org.
* debian/rules: Remove --disable-dependency-tracking from configure's
  arguments, because it breaks some handwritten rules in client/Makefile.am
  which require that $(DEPDIR) exists.
* Bumped debhelper compat level from V5 to V6 since this is the current
  recommended level and raised the build dependency to "debhelper (>= 6)".
* debian/patches/: Added 201_missing_header_for_gcc4.3.patch in order to
  fix a FTBFS with recent GCC 4.3 snapshots. Thanks to Martin Michlmayr
  <tbm@cyrius.com> for the bug report. (closes: #462051)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
In BOINC 5.10 the functions strlcpy() and strlcat() that were previously
 
2
declared in lib/util.h have been moved to the new lib/str_util.h header.
 
3
Therefore we need to include this header in the following source files.
 
4
Note that boinc-dev (>= 5.10.8-1) is needed to build boinc-app-seti with
 
5
this patch applied.
 
6
 
 
7
Index: boinc-app-seti-5.13+cvs20060510/client/timecvt.cpp
 
8
===================================================================
 
9
--- boinc-app-seti-5.13+cvs20060510.orig/client/timecvt.cpp     2006-01-12 02:51:17.000000000 +0100
 
10
+++ boinc-app-seti-5.13+cvs20060510/client/timecvt.cpp  2007-07-19 08:40:24.000000000 +0200
 
11
@@ -49,6 +49,7 @@
 
12
 
 
13
 #include "util.h"
 
14
 #include "s_util.h"
 
15
+#include "str_util.h"
 
16
 #include "timecvt.h"
 
17
 
 
18
 void timecvt_start() {}
 
19
Index: boinc-app-seti-5.13+cvs20060510/db/xml_util.cpp
 
20
===================================================================
 
21
--- boinc-app-seti-5.13+cvs20060510.orig/db/xml_util.cpp        2006-05-04 23:45:46.000000000 +0200
 
22
+++ boinc-app-seti-5.13+cvs20060510/db/xml_util.cpp     2007-07-19 08:40:24.000000000 +0200
 
23
@@ -88,6 +88,7 @@
 
24
 #include <cstdio>
 
25
 
 
26
 #include "std_fixes.h"
 
27
+#include "str_util.h"
 
28
 #include "util.h"
 
29
 #include "xml_util.h"
 
30
 
 
31
Index: boinc-app-seti-5.13+cvs20060510/client/sah_gfx.cpp
 
32
===================================================================
 
33
--- boinc-app-seti-5.13+cvs20060510.orig/client/sah_gfx.cpp     2007-07-19 08:45:13.000000000 +0200
 
34
+++ boinc-app-seti-5.13+cvs20060510/client/sah_gfx.cpp  2007-07-19 08:45:52.000000000 +0200
 
35
@@ -122,6 +122,7 @@
 
36
 #endif
 
37
 
 
38
 #include "util.h"
 
39
+#include "str_util.h"
 
40
 #include "boinc_api.h"
 
41
 #include "graphics_api.h"
 
42
 #ifdef DYNAMIC_GRAPHICS