~ubuntu-branches/ubuntu/oneiric/boinc-app-seti/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/01_build-fixes.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Frank S. Thomas, Steffen Moeller, Frank S. Thomas
  • Date: 2008-01-23 21:27:23 UTC
  • mfrom: (2.1.3 hardy)
  • Revision ID: james.westby@ubuntu.com-20080123212723-3c05zp04f8m1vk5s
Tags: 5.13+cvs20060510-4
[ Steffen Moeller ]
* debian/rules: Wrote get-orig-source target that downloads the latest
  nightly tarball.

[ Frank S. Thomas ]
* debian/control.in:
  - Bumped Standards-Version from 3.7.2 to 3.7.3, no changes required.
  - Changed my maintainer address to fst@debian.org.
* debian/rules: Remove --disable-dependency-tracking from configure's
  arguments, because it breaks some handwritten rules in client/Makefile.am
  which require that $(DEPDIR) exists.
* Bumped debhelper compat level from V5 to V6 since this is the current
  recommended level and raised the build dependency to "debhelper (>= 6)".
* debian/patches/: Added 201_missing_header_for_gcc4.3.patch in order to
  fix a FTBFS with recent GCC 4.3 snapshots. Thanks to Martin Michlmayr
  <tbm@cyrius.com> for the bug report. (closes: #462051)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 01_build-fixes.dpatch by Frank S. Thomas <frank@thomas-alfeld.de>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: No description.
6
 
 
7
 
@DPATCH@
8
 
diff -urNad boinc-app-seti-5.13+cvs20060510~/client/Makefile.am boinc-app-seti-5.13+cvs20060510/client/Makefile.am
9
 
--- boinc-app-seti-5.13+cvs20060510~/client/Makefile.am 2006-04-07 03:38:17.000000000 +0200
10
 
+++ boinc-app-seti-5.13+cvs20060510/client/Makefile.am  2006-05-17 13:37:56.000000000 +0200
11
 
@@ -90,11 +90,11 @@
12
 
 seti_boinc_LDADD = $(CLIENT_LD_ADD) 
13
 
 seti_boinc_LINK = $(CXX) -o $@
14
 
 
15
 
-if LINUX
16
 
+#if LINUX
17
 
 # too much optimization on main.cpp breaks the client for some reason
18
 
-seti_boinc-main.o:
19
 
-       if $(CXX) --include ../config.h -DDYNAMIC_GRAPHICS=1 $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(DEFS) -DTEXT_UI -DNDEBUG -DCLIENT  -I$(top_srcdir)/db $(BOINC_CFLAGS) $(PTHREAD_CFLAGS) -O2 -Wall -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -c -o $@ $<; then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; fi
20
 
-endif
21
 
+#seti_boinc-main.o:
22
 
+#      if $(CXX) --include ../config.h -DDYNAMIC_GRAPHICS=1 $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(DEFS) -DTEXT_UI -DNDEBUG -DCLIENT  -I$(top_srcdir)/db $(BOINC_CFLAGS) $(PTHREAD_CFLAGS) -O2 -Wall -MT $@ -MD -MP -MF "$(DEPDIR)/$*.Tpo" -c -o $@ $<; then mv -f "$(DEPDIR)/$*.Tpo" "$(DEPDIR)/$*.Po"; else rm -f "$(DEPDIR)/$*.Tpo"; exit 1; fi
23
 
+#endif
24
 
 
25
 
 
26
 
 if ENABLE_GUI
27
 
diff -urNad boinc-app-seti-5.13+cvs20060510~/db/sqlblob.h boinc-app-seti-5.13+cvs20060510/db/sqlblob.h
28
 
--- boinc-app-seti-5.13+cvs20060510~/db/sqlblob.h       2005-12-01 01:01:01.000000000 +0100
29
 
+++ boinc-app-seti-5.13+cvs20060510/db/sqlblob.h        2006-05-17 13:37:56.000000000 +0200
30
 
@@ -75,7 +75,7 @@
31
 
      fflush(stderr);
32
 
 #endif
33
 
    }
34
 
-   b.mem=new std::vector<T>(xml_decode_string(buf.c_str()+start,end-start,enc_string));
35
 
+   b.mem=new std::vector<T>(xml_decode_string<T>(buf.c_str()+start,end-start,enc_string));
36
 
 #ifdef DEBUG_ALLOCATIONS
37
 
    fprintf(stderr,"sqlblob: allocated a vector at 0x%p\n",b.mem);
38
 
    fflush(stderr);
39
 
diff -urNad boinc-app-seti-5.13+cvs20060510~/db/xml_util.h boinc-app-seti-5.13+cvs20060510/db/xml_util.h
40
 
--- boinc-app-seti-5.13+cvs20060510~/db/xml_util.h      2005-12-01 01:01:01.000000000 +0100
41
 
+++ boinc-app-seti-5.13+cvs20060510/db/xml_util.h       2006-05-17 13:37:57.000000000 +0200
42
 
@@ -220,9 +220,9 @@
43
 
 
44
 
 // decode an XML character string.  Return a the decoded string in a vector
45
 
 // (null not necessarily a terminator).
46
 
-//template <typename T>
47
 
-//vector<T> xml_decode_string(const char *input, size_t length=0,
48
 
-//    const char *encoding="x_xml_entity");
49
 
+template <typename T>
50
 
+std::vector<T> xml_decode_string(const char *input, size_t length=0,
51
 
+    const char *encoding="x_xml_entity");
52
 
 
53
 
 // do the same thing, but get the length and encoding type from the
54
 
 // xml tag properties.