~ubuntu-branches/ubuntu/precise/mutt/precise

« back to all changes in this revision

Viewing changes to debian/patches/features/sensible_browser_position

  • Committer: Bazaar Package Importer
  • Author(s): أحمد المحمودي (Ahmed El-Mahmoudy)
  • Date: 2009-06-27 23:52:24 UTC
  • mfrom: (2.1.3 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090627235224-z52j0hm6cpknxrk1
Tags: 1.5.20-2ubuntu1
Merge from debian unstable (LP: #392997), remaining changes:
debian/control: Recommend default-mta instead of exim4.

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
    http://lists.df7cb.de/mutt/message/20050309.162127.a244a894.en.html
6
6
 
7
7
== END PATCH
8
 
--- a/menu.c
9
 
+++ b/menu.c
 
8
Index: mutt/menu.c
 
9
===================================================================
 
10
--- mutt.orig/menu.c    2009-06-25 12:35:36.000000000 +0200
 
11
+++ mutt/menu.c 2009-06-25 12:36:19.000000000 +0200
10
12
@@ -853,8 +853,17 @@
11
13
 
12
14
 int mutt_menuLoop (MUTTMENU *menu)
34
36
        return (i);
35
37
     }
36
38
   }
37
 
--- a/browser.c
38
 
+++ b/browser.c
39
 
@@ -56,6 +56,7 @@
 
39
Index: mutt/browser.c
 
40
===================================================================
 
41
--- mutt.orig/browser.c 2009-06-25 12:35:37.000000000 +0200
 
42
+++ mutt/browser.c      2009-06-25 12:36:19.000000000 +0200
 
43
@@ -55,6 +55,7 @@
40
44
   int num;
41
45
 } FOLDER;
42
46
 
44
48
 static char LastDir[_POSIX_PATH_MAX] = "";
45
49
 static char LastDirBackup[_POSIX_PATH_MAX] = "";
46
50
 
47
 
@@ -526,9 +527,13 @@
 
51
@@ -519,9 +520,13 @@
48
52
   menu->tagged = 0;
49
53
   
50
54
   if (buffy)
58
62
     strfcpy (path, LastDir, sizeof (path));
59
63
     mutt_pretty_mailbox (path, sizeof (path));
60
64
 #ifdef USE_IMAP
61
 
@@ -537,8 +542,22 @@
 
65
@@ -530,8 +535,22 @@
62
66
              path, NONULL (Mask.pattern));
63
67
   else
64
68
 #endif
83
87
   }
84
88
   menu->redraw = REDRAW_FULL;
85
89
 }
86
 
@@ -721,7 +740,6 @@
 
90
@@ -714,7 +733,6 @@
87
91
 #endif
88
92
            )
89
93
          {
91
95
 
92
96
            /* save the old directory */
93
97
            strfcpy (OldLastDir, LastDir, sizeof (OldLastDir));
94
 
--- a/mutt_menu.h
95
 
+++ b/mutt_menu.h
 
98
Index: mutt/mutt_menu.h
 
99
===================================================================
 
100
--- mutt.orig/mutt_menu.h       2009-06-25 12:35:44.000000000 +0200
 
101
+++ mutt/mutt_menu.h    2009-06-25 12:36:19.000000000 +0200
96
102
@@ -49,6 +49,7 @@
97
103
   int offset;  /* which screen row to start the index */
98
104
   int pagelen; /* number of entries per screen */