~ubuntu-branches/ubuntu/precise/mutt/precise

« back to all changes in this revision

Viewing changes to debian/patches/features/trash-folder

  • Committer: Bazaar Package Importer
  • Author(s): أحمد المحمودي (Ahmed El-Mahmoudy)
  • Date: 2009-06-27 23:52:24 UTC
  • mfrom: (2.1.3 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090627235224-z52j0hm6cpknxrk1
Tags: 1.5.20-2ubuntu1
Merge from debian unstable (LP: #392997), remaining changes:
debian/control: Recommend default-mta instead of exim4.

Show diffs side-by-side

added added

removed removed

Lines of Context:
46
46
  - Fixed indentation of "appended" in mutt.h.
47
47
 
48
48
== END PATCH
49
 
--- a/commands.c
50
 
+++ b/commands.c
 
49
Index: mutt/commands.c
 
50
===================================================================
 
51
--- mutt.orig/commands.c        2009-06-25 12:35:37.000000000 +0200
 
52
+++ mutt/commands.c     2009-06-25 12:35:48.000000000 +0200
51
53
@@ -716,6 +716,7 @@
52
54
     if (option (OPTDELETEUNTAG))
53
55
       mutt_set_flag (Context, h, M_TAG, 0);
56
58
   
57
59
   return 0;
58
60
 }
59
 
--- a/flags.c
60
 
+++ b/flags.c
 
61
Index: mutt/flags.c
 
62
===================================================================
 
63
--- mutt.orig/flags.c   2009-06-25 12:35:37.000000000 +0200
 
64
+++ mutt/flags.c        2009-06-25 12:35:48.000000000 +0200
61
65
@@ -65,7 +65,13 @@
62
66
       {
63
67
        h->deleted = 0;
91
95
     case M_NEW:
92
96
 
93
97
       if (!mutt_bit_isset(ctx->rights,M_ACL_SEEN))
94
 
--- a/globals.h
95
 
+++ b/globals.h
 
98
Index: mutt/globals.h
 
99
===================================================================
 
100
--- mutt.orig/globals.h 2009-06-25 12:35:44.000000000 +0200
 
101
+++ mutt/globals.h      2009-06-25 12:35:48.000000000 +0200
96
102
@@ -139,6 +139,7 @@
97
103
 WHERE char *Status;
98
104
 WHERE char *Tempdir;
101
107
 WHERE char *Username;
102
108
 WHERE char *Visual;
103
109
 WHERE char *XtermTitle;
104
 
--- a/imap/message.c
105
 
+++ b/imap/message.c
 
110
Index: mutt/imap/message.c
 
111
===================================================================
 
112
--- mutt.orig/imap/message.c    2009-06-25 12:35:37.000000000 +0200
 
113
+++ mutt/imap/message.c 2009-06-25 12:35:48.000000000 +0200
106
114
@@ -867,6 +867,7 @@
107
115
         if (ctx->hdrs[n]->tagged)
108
116
         {
119
127
       if (option (OPTDELETEUNTAG))
120
128
         mutt_set_flag (ctx, h, M_TAG, 0);
121
129
     }
122
 
--- a/init.h
123
 
+++ b/init.h
124
 
@@ -3190,6 +3190,16 @@
 
130
Index: mutt/init.h
 
131
===================================================================
 
132
--- mutt.orig/init.h    2009-06-25 12:35:44.000000000 +0200
 
133
+++ mutt/init.h 2009-06-25 12:35:48.000000000 +0200
 
134
@@ -3180,6 +3180,16 @@
125
135
   ** by \fIyou\fP.  The sixth character is used to indicate when a mail
126
136
   ** was sent to a mailing-list you subscribe to.
127
137
   */
138
148
 #ifdef USE_SOCKET
139
149
   { "tunnel",            DT_STR, R_NONE, UL &Tunnel, UL 0 },
140
150
   /*
141
 
--- a/mutt.h
142
 
+++ b/mutt.h
 
151
Index: mutt/mutt.h
 
152
===================================================================
 
153
--- mutt.orig/mutt.h    2009-06-25 12:35:44.000000000 +0200
 
154
+++ mutt/mutt.h 2009-06-25 12:35:48.000000000 +0200
143
155
@@ -187,6 +187,7 @@
144
156
   M_DELETE,
145
157
   M_UNDELETE,
148
160
   M_FLAG,
149
161
   M_TAG,
150
162
   M_UNTAG,
151
 
@@ -703,6 +704,7 @@
 
163
@@ -702,6 +703,7 @@
152
164
   unsigned int mime : 1;               /* has a MIME-Version header? */
153
165
   unsigned int flagged : 1;            /* marked important? */
154
166
   unsigned int tagged : 1;
156
168
   unsigned int deleted : 1;
157
169
   unsigned int changed : 1;
158
170
   unsigned int attach_del : 1;                 /* has an attachment marked for deletion */
159
 
@@ -875,6 +877,7 @@
 
171
@@ -874,6 +876,7 @@
160
172
   int new;                     /* how many new messages? */
161
173
   int unread;                  /* how many unread messages? */
162
174
   int deleted;                 /* how many deleted messages */
164
176
   int flagged;                 /* how many flagged messages */
165
177
   int msgnotreadyet;           /* which msg "new" in pager, -1 if none */
166
178
 
167
 
--- a/muttlib.c
168
 
+++ b/muttlib.c
 
179
Index: mutt/muttlib.c
 
180
===================================================================
 
181
--- mutt.orig/muttlib.c 2009-06-25 12:35:37.000000000 +0200
 
182
+++ mutt/muttlib.c      2009-06-25 12:35:48.000000000 +0200
169
183
@@ -1460,7 +1460,9 @@
170
184
 
171
185
   if (magic > 0 && !mx_access (s, W_OK))
177
191
     {
178
192
       snprintf (tmp, sizeof (tmp), _("Append messages to %s?"), s);
179
193
       if ((rc = mutt_yesorno (tmp, M_YES)) == M_NO)
180
 
--- a/mx.c
181
 
+++ b/mx.c
 
194
Index: mutt/mx.c
 
195
===================================================================
 
196
--- mutt.orig/mx.c      2009-06-25 12:35:37.000000000 +0200
 
197
+++ mutt/mx.c   2009-06-25 12:35:48.000000000 +0200
182
198
@@ -773,6 +773,53 @@
183
199
   return rc;
184
200
 }
264
280
+  {
265
281
+    if (trash_append (ctx) == -1)
266
282
+      return -1;
267
 
+  } 
 
283
+  }
268
284
+
269
285
 #ifdef USE_IMAP
270
286
   if (ctx->magic == M_IMAP)
271
287
     rc = imap_sync_mailbox (ctx, purge, index_hint);
272
 
--- a/postpone.c
273
 
+++ b/postpone.c
 
288
Index: mutt/postpone.c
 
289
===================================================================
 
290
--- mutt.orig/postpone.c        2009-06-25 12:35:37.000000000 +0200
 
291
+++ mutt/postpone.c     2009-06-25 12:35:48.000000000 +0200
274
292
@@ -276,6 +276,9 @@
275
293
   /* finished with this message, so delete it. */
276
294
   mutt_set_flag (PostContext, h, M_DELETE, 1);