~ubuntu-branches/ubuntu/precise/mutt/precise

« back to all changes in this revision

Viewing changes to debian/patches/features/xtitles

  • Committer: Bazaar Package Importer
  • Author(s): أحمد المحمودي (Ahmed El-Mahmoudy)
  • Date: 2009-06-27 23:52:24 UTC
  • mfrom: (2.1.3 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090627235224-z52j0hm6cpknxrk1
Tags: 1.5.20-2ubuntu1
Merge from debian unstable (LP: #392997), remaining changes:
debian/control: Recommend default-mta instead of exim4.

Show diffs side-by-side

added added

removed removed

Lines of Context:
10
10
    (cleaner code, no functional change, evades conflict with sidebar patch)
11
11
 
12
12
== END PATCH
13
 
--- a/curs_main.c
14
 
+++ b/curs_main.c
 
13
Index: mutt/curs_main.c
 
14
===================================================================
 
15
--- mutt.orig/curs_main.c       2009-06-25 12:35:37.000000000 +0200
 
16
+++ mutt/curs_main.c    2009-06-25 12:35:44.000000000 +0200
15
17
@@ -110,6 +110,19 @@
16
18
 
17
19
 extern size_t UngetCount;
46
48
       }
47
49
 
48
50
       menu->redraw = 0;
49
 
--- a/globals.h
50
 
+++ b/globals.h
 
51
Index: mutt/globals.h
 
52
===================================================================
 
53
--- mutt.orig/globals.h 2009-06-25 12:35:37.000000000 +0200
 
54
+++ mutt/globals.h      2009-06-25 12:35:44.000000000 +0200
51
55
@@ -141,6 +141,8 @@
52
56
 WHERE char *Tochars;
53
57
 WHERE char *Username;
57
61
 
58
62
 WHERE char *CurrentFolder;
59
63
 WHERE char *LastFolder;
60
 
--- a/init.c
61
 
+++ b/init.c
 
64
Index: mutt/init.c
 
65
===================================================================
 
66
--- mutt.orig/init.c    2009-06-25 12:35:42.000000000 +0200
 
67
+++ mutt/init.c 2009-06-25 12:35:44.000000000 +0200
62
68
@@ -1892,6 +1892,26 @@
63
69
        toggle_option (MuttVars[idx].data);
64
70
       else
86
92
     }
87
93
     else if (myvar || DTYPE (MuttVars[idx].type) == DT_STR ||
88
94
             DTYPE (MuttVars[idx].type) == DT_PATH ||
89
 
--- a/init.h
90
 
+++ b/init.h
91
 
@@ -3347,6 +3347,27 @@
 
95
Index: mutt/init.h
 
96
===================================================================
 
97
--- mutt.orig/init.h    2009-06-25 12:35:42.000000000 +0200
 
98
+++ mutt/init.h 2009-06-25 12:35:44.000000000 +0200
 
99
@@ -3337,6 +3337,27 @@
92
100
   ** Also see the $$read_inc, $$net_inc and $$time_inc variables and the
93
101
   ** ``$tuning'' section of the manual for performance considerations.
94
102
   */
116
124
   /*--*/
117
125
   { NULL, 0, 0, 0, 0 }
118
126
 };
119
 
--- a/mutt.h
120
 
+++ b/mutt.h
121
 
@@ -447,6 +447,7 @@
 
127
Index: mutt/mutt.h
 
128
===================================================================
 
129
--- mutt.orig/mutt.h    2009-06-25 12:35:37.000000000 +0200
 
130
+++ mutt/mutt.h 2009-06-25 12:35:44.000000000 +0200
 
131
@@ -446,6 +446,7 @@
122
132
   OPTWRAPSEARCH,
123
133
   OPTWRITEBCC,         /* write out a bcc header? */
124
134
   OPTXMAILER,
126
136
 
127
137
   OPTCRYPTUSEGPGME,
128
138
   OPTCRYPTUSEPKA,
129
 
--- a/pager.c
130
 
+++ b/pager.c
 
139
Index: mutt/pager.c
 
140
===================================================================
 
141
--- mutt.orig/pager.c   2009-06-25 12:35:37.000000000 +0200
 
142
+++ mutt/pager.c        2009-06-25 12:35:44.000000000 +0200
131
143
@@ -1784,6 +1784,13 @@
132
144
       }
133
145
       BKGDSET (MT_COLOR_NORMAL);
142
154
     }
143
155
 
144
156
     if ((redraw & REDRAW_INDEX) && index)
145
 
--- a/status.c
146
 
+++ b/status.c
 
157
Index: mutt/status.c
 
158
===================================================================
 
159
--- mutt.orig/status.c  2009-06-25 12:35:37.000000000 +0200
 
160
+++ mutt/status.c       2009-06-25 12:35:44.000000000 +0200
147
161
@@ -195,6 +195,8 @@
148
162
       break;
149
163
 
153
167
       if (menu->top + menu->pagelen >= menu->max)
154
168
        cp = menu->top ? "end" : "all";
155
169
       else
156
 
--- a/mutt_menu.h
157
 
+++ b/mutt_menu.h
 
170
Index: mutt/mutt_menu.h
 
171
===================================================================
 
172
--- mutt.orig/mutt_menu.h       2009-06-25 12:35:37.000000000 +0200
 
173
+++ mutt/mutt_menu.h    2009-06-25 12:35:44.000000000 +0200
158
174
@@ -103,6 +103,8 @@
159
175
 void menu_current_bottom (MUTTMENU *);
160
176
 void menu_check_recenter (MUTTMENU *);