~ubuntu-branches/ubuntu/precise/qt4-x11/precise-proposed

« back to all changes in this revision

Viewing changes to debian/patches/blacklist-diginotar-certs.diff

  • Committer: Package Import Robot
  • Author(s): Jonathan Riddell, Jonathan Riddell, Felix Geyer
  • Date: 2011-11-01 16:23:55 UTC
  • mfrom: (15.3.22 sid)
  • Revision ID: package-import@ubuntu.com-20111101162355-4dhsj6563ii8enl6
Tags: 4:4.7.4-1ubuntu1
[ Jonathan Riddell ]
* Merge from Debian Git packaging.  Remaining Ubuntu changes:
  - Do not package ibase/firebird package, remove from debian/rules and
    debian/control
  - libqt4-sql-ibase not recommend for libqt4-sql
  - build with -no-phonon
  - do not build libqt4-phonon, disable in debian/control
  - Build packages with lzma compression using the dh addon from pkg-kde-tools
  - Rules to remove po dir in clean
  - Add MessagesQt.sh
  - Rules to create Messages.sh link to MessagesQt.sh and rules to create po
    dir and exectue extract-messages.sh in common-install-prehook-impl
  - Make libqt4-dev depend on libx11-dev
  - Add and install Trolltech.conf in libqtcore4.install
  - Build QtWebkit and use it only for QtAssistant
    + Rule to put qt_webkit_version.pri in mkspecs/modules
    + Rule to remove libQtWebKit* after build
    + Exclude usr/bin/assistant-qt4 from dh_shlibdeps
  - Fix Lucid upgrades: libqt4-help breaks/replaces libqtcore4 (<< 4:4.7.0)
  - Change OpenGL backend from GL to GLES 2 for armel (Debian does this for
    armhf)
    + Build-depend and make libqt4-opengl-dev depend on libgles2-mesa-dev
      instead of libgl1-mesa-dev and libglu1-mesa-dev
    + Pass "-opengl es2" to configure
  - Pass extra_configure_opts += -arch armv6 on both armel and armhf and not
    just armhf
  - In debian/rules Move documentation building to override_dh_auto_install where
    dh_listpackages works as expected with dpkg-buildpackage. (LP: #857377)
  - debian/compat is 9 and build-depend on newer debhelper for multiarch
* debian/patches/blacklist-diginotar-certs.diff is now
  debian/patches/blacklist-diginotar-cert.diff to match Debian
* Add prefix to some patches to clarify they come from Ubuntu rather than Debian
 - kubuntu_97_a11y_qt_and_qml_backport.diff
 - kubuntu_98_fix_accessible_menu.diff
 - kubuntu_99_notify_qml_name_description_change.diff

[ Felix Geyer ]
* Use DEB_*_MAINT_APPEND instead of setting CXXFLAGS and LDFLAGS.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff --git a/src/network/ssl/qsslcertificate.cpp b/src/network/ssl/qsslcertificate.cpp
2
 
index 328c5c2..1ae98f4 100644
3
 
--- a/src/network/ssl/qsslcertificate.cpp
4
 
+++ b/src/network/ssl/qsslcertificate.cpp
5
 
@@ -803,22 +803,47 @@ QList<QSslCertificate> QSslCertificatePrivate::certificatesFromDer(const QByteAr
6
 
 // These certificates are known to be fraudulent and were created during the comodo
7
 
 // compromise. See http://www.comodo.com/Comodo-Fraud-Incident-2011-03-23.html
8
 
 static const char *certificate_blacklist[] = {
9
 
-    "04:7e:cb:e9:fc:a5:5f:7b:d0:9e:ae:36:e1:0c:ae:1e",
10
 
-    "f5:c8:6a:f3:61:62:f1:3a:64:f5:4f:6d:c9:58:7c:06",
11
 
-    "d7:55:8f:da:f5:f1:10:5b:b2:13:28:2b:70:77:29:a3",
12
 
-    "39:2a:43:4f:0e:07:df:1f:8a:a3:05:de:34:e0:c2:29",
13
 
-    "3e:75:ce:d4:6b:69:30:21:21:88:30:ae:86:a8:2a:71",
14
 
-    "e9:02:8b:95:78:e4:15:dc:1a:71:0a:2b:88:15:44:47",
15
 
-    "92:39:d5:34:8f:40:d1:69:5a:74:54:70:e1:f2:3f:43",
16
 
-    "b0:b7:13:3e:d0:96:f9:b5:6f:ae:91:c8:74:bd:3a:c0",
17
 
-    "d8:f3:5f:4e:b7:87:2b:2d:ab:06:92:e3:15:38:2f:b0",
18
 
+    "04:7e:cb:e9:fc:a5:5f:7b:d0:9e:ae:36:e1:0c:ae:1e", "mail.google.com", // Comodo
19
 
+    "f5:c8:6a:f3:61:62:f1:3a:64:f5:4f:6d:c9:58:7c:06", "www.google.com", // Comodo
20
 
+    "d7:55:8f:da:f5:f1:10:5b:b2:13:28:2b:70:77:29:a3", "login.yahoo.com", // Comodo
21
 
+    "39:2a:43:4f:0e:07:df:1f:8a:a3:05:de:34:e0:c2:29", "login.yahoo.com", // Comodo
22
 
+    "3e:75:ce:d4:6b:69:30:21:21:88:30:ae:86:a8:2a:71", "login.yahoo.com", // Comodo
23
 
+    "e9:02:8b:95:78:e4:15:dc:1a:71:0a:2b:88:15:44:47", "login.skype.com", // Comodo
24
 
+    "92:39:d5:34:8f:40:d1:69:5a:74:54:70:e1:f2:3f:43", "addons.mozilla.org", // Comodo
25
 
+    "b0:b7:13:3e:d0:96:f9:b5:6f:ae:91:c8:74:bd:3a:c0", "login.live.com", // Comodo
26
 
+    "d8:f3:5f:4e:b7:87:2b:2d:ab:06:92:e3:15:38:2f:b0", "global trustee", // Comodo
27
 
+
28
 
+    "05:e2:e6:a4:cd:09:ea:54:d6:65:b0:75:fe:22:a2:56", "*.google.com", // leaf certificate issued by DigiNotar
29
 
+    "0c:76:da:9c:91:0c:4e:2c:9e:fe:15:d0:58:93:3c:4c", "DigiNotar Root CA", // DigiNotar root
30
 
+    "f1:4a:13:f4:87:2b:56:dc:39:df:84:ca:7a:a1:06:49", "DigiNotar Services CA", // DigiNotar intermediate signed by DigiNotar Root
31
 
+    "36:16:71:55:43:42:1b:9d:e6:cb:a3:64:41:df:24:38", "DigiNotar Services 1024 CA", // DigiNotar intermediate signed by DigiNotar Root
32
 
+    "0a:82:bd:1e:14:4e:88:14:d7:5b:1a:55:27:be:bf:3e", "DigiNotar Root CA G2", // other DigiNotar Root CA
33
 
+    "a4:b6:ce:e3:2e:d3:35:46:26:3c:b3:55:3a:a8:92:21", "CertiID Enterprise Certificate Authority", // DigiNotar intermediate signed by "DigiNotar Root CA G2"
34
 
+    "5b:d5:60:9c:64:17:68:cf:21:0e:35:fd:fb:05:ad:41", "DigiNotar Qualified CA", // DigiNotar intermediate signed by DigiNotar Root
35
 
+
36
 
+    "1184640176",                                      "DigiNotar Services 1024 CA", // DigiNotar intermediate cross-signed by Entrust
37
 
+    "120000525",                                       "DigiNotar Cyber CA", // DigiNotar intermediate cross-signed by CyberTrust
38
 
+    "120000505",                                       "DigiNotar Cyber CA", // DigiNotar intermediate cross-signed by CyberTrust
39
 
+    "120000515",                                       "DigiNotar Cyber CA", // DigiNotar intermediate cross-signed by CyberTrust
40
 
+    "20015536",                                        "DigiNotar PKIoverheid CA Overheid en Bedrijven", // DigiNotar intermediate cross-signed by the Dutch government
41
 
+    "20001983",                                        "DigiNotar PKIoverheid CA Organisatie - G2", // DigiNotar intermediate cross-signed by the Dutch government
42
 
+    "d6:d0:29:77:f1:49:fd:1a:83:f2:b9:ea:94:8c:5c:b4", "DigiNotar Extended Validation CA", // DigiNotar intermediate signed by DigiNotar EV Root
43
 
+    "1e:7d:7a:53:3d:45:30:41:96:40:0f:71:48:1f:45:04", "DigiNotar Public CA 2025", // DigiNotar intermediate
44
 
+//    "(has not been seen in the wild so far)", "DigiNotar Public CA - G2", // DigiNotar intermediate
45
 
+//    "(has not been seen in the wild so far)", "Koninklijke Notariele Beroepsorganisatie CA", // compromised during DigiNotar breach
46
 
+//    "(has not been seen in the wild so far)", "Stichting TTP Infos CA," // compromised during DigiNotar breach
47
 
+    "1184640175", "DigiNotar Root CA", // DigiNotar intermediate cross-signed by Entrust
48
 
+    "1184644297", "DigiNotar Root CA", // DigiNotar intermediate cross-signed by Entrust
49
 
     0
50
 
 };
51
 
 
52
 
 bool QSslCertificatePrivate::isBlacklisted(const QSslCertificate &certificate)
53
 
 {
54
 
     for (int a = 0; certificate_blacklist[a] != 0; a++) {
55
 
-        if (certificate.serialNumber() == certificate_blacklist[a])
56
 
+        QString blacklistedCommonName = QString::fromUtf8(certificate_blacklist[(a+1)]);
57
 
+        if (certificate.serialNumber() == certificate_blacklist[a++] &&
58
 
+            (certificate.subjectInfo(QSslCertificate::CommonName) == blacklistedCommonName ||
59
 
+             certificate.issuerInfo(QSslCertificate::CommonName) == blacklistedCommonName))
60
 
             return true;
61
 
     }
62
 
     return false;
63
 
diff --git a/src/network/ssl/qsslsocket_openssl.cpp b/src/network/ssl/qsslsocket_openssl.cpp
64
 
index 141d80a..b8e6c4c 100644
65
 
--- a/src/network/ssl/qsslsocket_openssl.cpp
66
 
+++ b/src/network/ssl/qsslsocket_openssl.cpp
67
 
@@ -1193,12 +1193,16 @@ bool QSslSocketBackendPrivate::startHandshake()
68
 
     X509 *x509 = q_SSL_get_peer_certificate(ssl);
69
 
     configuration.peerCertificate = QSslCertificatePrivate::QSslCertificate_from_X509(x509);
70
 
     q_X509_free(x509);
71
 
-    if (QSslCertificatePrivate::isBlacklisted(configuration.peerCertificate)) {
72
 
-        q->setErrorString(QSslSocket::tr("The peer certificate is blacklisted"));
73
 
-        q->setSocketError(QAbstractSocket::SslHandshakeFailedError);
74
 
-        emit q->error(QAbstractSocket::SslHandshakeFailedError);
75
 
-        plainSocket->disconnectFromHost();
76
 
-        return false;
77
 
+
78
 
+    // check the whole chain for blacklisting (including root, as we check for subjectInfo and issuer)
79
 
+    foreach (const QSslCertificate &cert, configuration.peerCertificateChain) {
80
 
+        if (QSslCertificatePrivate::isBlacklisted(cert)) {
81
 
+            q->setErrorString(QSslSocket::tr("The peer certificate is blacklisted"));
82
 
+            q->setSocketError(QAbstractSocket::SslHandshakeFailedError);
83
 
+            emit q->error(QAbstractSocket::SslHandshakeFailedError);
84
 
+            plainSocket->disconnectFromHost();
85
 
+            return false;
86
 
+        }
87
 
     }
88
 
 
89
 
     // Start translating errors.