~ubuntu-branches/ubuntu/precise/qt4-x11/precise-proposed

« back to all changes in this revision

Viewing changes to debian/patches/fix_accessible_menu.diff

  • Committer: Package Import Robot
  • Author(s): Jonathan Riddell, Jonathan Riddell, Felix Geyer
  • Date: 2011-11-01 16:23:55 UTC
  • mfrom: (15.3.22 sid)
  • Revision ID: package-import@ubuntu.com-20111101162355-4dhsj6563ii8enl6
Tags: 4:4.7.4-1ubuntu1
[ Jonathan Riddell ]
* Merge from Debian Git packaging.  Remaining Ubuntu changes:
  - Do not package ibase/firebird package, remove from debian/rules and
    debian/control
  - libqt4-sql-ibase not recommend for libqt4-sql
  - build with -no-phonon
  - do not build libqt4-phonon, disable in debian/control
  - Build packages with lzma compression using the dh addon from pkg-kde-tools
  - Rules to remove po dir in clean
  - Add MessagesQt.sh
  - Rules to create Messages.sh link to MessagesQt.sh and rules to create po
    dir and exectue extract-messages.sh in common-install-prehook-impl
  - Make libqt4-dev depend on libx11-dev
  - Add and install Trolltech.conf in libqtcore4.install
  - Build QtWebkit and use it only for QtAssistant
    + Rule to put qt_webkit_version.pri in mkspecs/modules
    + Rule to remove libQtWebKit* after build
    + Exclude usr/bin/assistant-qt4 from dh_shlibdeps
  - Fix Lucid upgrades: libqt4-help breaks/replaces libqtcore4 (<< 4:4.7.0)
  - Change OpenGL backend from GL to GLES 2 for armel (Debian does this for
    armhf)
    + Build-depend and make libqt4-opengl-dev depend on libgles2-mesa-dev
      instead of libgl1-mesa-dev and libglu1-mesa-dev
    + Pass "-opengl es2" to configure
  - Pass extra_configure_opts += -arch armv6 on both armel and armhf and not
    just armhf
  - In debian/rules Move documentation building to override_dh_auto_install where
    dh_listpackages works as expected with dpkg-buildpackage. (LP: #857377)
  - debian/compat is 9 and build-depend on newer debhelper for multiarch
* debian/patches/blacklist-diginotar-certs.diff is now
  debian/patches/blacklist-diginotar-cert.diff to match Debian
* Add prefix to some patches to clarify they come from Ubuntu rather than Debian
 - kubuntu_97_a11y_qt_and_qml_backport.diff
 - kubuntu_98_fix_accessible_menu.diff
 - kubuntu_99_notify_qml_name_description_change.diff

[ Felix Geyer ]
* Use DEB_*_MAINT_APPEND instead of setting CXXFLAGS and LDFLAGS.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 3046e8f275c60f518da31acd054452d226798f54 Mon Sep 17 00:00:00 2001
2
 
From: Frederik Gladhorn <frederik.gladhorn@nokia.com>
3
 
Date: Fri, 23 Sep 2011 14:23:52 +0200
4
 
Subject: [PATCH] Fix accessible menu not returning child name.
5
 
 
6
 
When accessible name is set, QAccessibleMenu would always return
7
 
the menu's name, not that of the child action.
8
 
 
9
 
Task-Number: QTBUG-21578
10
 
Reviewed-by: Jan-Arve
11
 
(cherry picked from commit 3df9ac2f0719718ceb7385e46445447d95fd7857)
12
 
---
13
 
 src/plugins/accessible/widgets/qaccessiblemenu.cpp |    2 +-
14
 
 tests/auto/qaccessibility/tst_qaccessibility.cpp   |    6 ++++++
15
 
 2 files changed, 7 insertions(+), 1 deletions(-)
16
 
 
17
 
diff --git a/src/plugins/accessible/widgets/qaccessiblemenu.cpp b/src/plugins/accessible/widgets/qaccessiblemenu.cpp
18
 
index 1454c7c..59e92c7 100644
19
 
--- a/src/plugins/accessible/widgets/qaccessiblemenu.cpp
20
 
+++ b/src/plugins/accessible/widgets/qaccessiblemenu.cpp
21
 
@@ -93,7 +93,7 @@ int QAccessibleMenu::childAt(int x, int y) const
22
 
 QString QAccessibleMenu::text(Text t, int child) const
23
 
 {
24
 
     QString tx = QAccessibleWidgetEx::text(t, child);
25
 
-    if (tx.size())
26
 
+    if (!child && tx.size())
27
 
         return tx;
28
 
 
29
 
     switch (t) {