~ubuntu-branches/ubuntu/precise/qt4-x11/precise-proposed

« back to all changes in this revision

Viewing changes to debian/patches/kubuntu_99_notify_qml_name_description_change.diff

  • Committer: Package Import Robot
  • Author(s): Jonathan Riddell, Jonathan Riddell, Felix Geyer
  • Date: 2011-11-01 16:23:55 UTC
  • mfrom: (15.3.22 sid)
  • Revision ID: package-import@ubuntu.com-20111101162355-4dhsj6563ii8enl6
Tags: 4:4.7.4-1ubuntu1
[ Jonathan Riddell ]
* Merge from Debian Git packaging.  Remaining Ubuntu changes:
  - Do not package ibase/firebird package, remove from debian/rules and
    debian/control
  - libqt4-sql-ibase not recommend for libqt4-sql
  - build with -no-phonon
  - do not build libqt4-phonon, disable in debian/control
  - Build packages with lzma compression using the dh addon from pkg-kde-tools
  - Rules to remove po dir in clean
  - Add MessagesQt.sh
  - Rules to create Messages.sh link to MessagesQt.sh and rules to create po
    dir and exectue extract-messages.sh in common-install-prehook-impl
  - Make libqt4-dev depend on libx11-dev
  - Add and install Trolltech.conf in libqtcore4.install
  - Build QtWebkit and use it only for QtAssistant
    + Rule to put qt_webkit_version.pri in mkspecs/modules
    + Rule to remove libQtWebKit* after build
    + Exclude usr/bin/assistant-qt4 from dh_shlibdeps
  - Fix Lucid upgrades: libqt4-help breaks/replaces libqtcore4 (<< 4:4.7.0)
  - Change OpenGL backend from GL to GLES 2 for armel (Debian does this for
    armhf)
    + Build-depend and make libqt4-opengl-dev depend on libgles2-mesa-dev
      instead of libgl1-mesa-dev and libglu1-mesa-dev
    + Pass "-opengl es2" to configure
  - Pass extra_configure_opts += -arch armv6 on both armel and armhf and not
    just armhf
  - In debian/rules Move documentation building to override_dh_auto_install where
    dh_listpackages works as expected with dpkg-buildpackage. (LP: #857377)
  - debian/compat is 9 and build-depend on newer debhelper for multiarch
* debian/patches/blacklist-diginotar-certs.diff is now
  debian/patches/blacklist-diginotar-cert.diff to match Debian
* Add prefix to some patches to clarify they come from Ubuntu rather than Debian
 - kubuntu_97_a11y_qt_and_qml_backport.diff
 - kubuntu_98_fix_accessible_menu.diff
 - kubuntu_99_notify_qml_name_description_change.diff

[ Felix Geyer ]
* Use DEB_*_MAINT_APPEND instead of setting CXXFLAGS and LDFLAGS.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 205f4abb9b980854e93ed58f4c2f245f63fe8116 Mon Sep 17 00:00:00 2001
 
2
From: Frederik Gladhorn <frederik.gladhorn@nokia.com>
 
3
Date: Mon, 27 Jun 2011 14:01:19 +0200
 
4
Subject: [PATCH] Notify about name/description changes for qml.
 
5
 
 
6
Declarative items would not emit the name/description/role
 
7
changed signals as they are supposed to.
 
8
Neither was updateAccessibility called.
 
9
Index: qt4-x11-4.7.4/src/declarative/accessible/qdeclarativeaccessible_p.h
 
10
===================================================================
 
11
--- qt4-x11-4.7.4.orig/src/declarative/accessible/qdeclarativeaccessible_p.h    2011-09-28 15:37:57.530973271 +0200
 
12
+++ qt4-x11-4.7.4/src/declarative/accessible/qdeclarativeaccessible_p.h 2011-09-28 15:38:08.707028685 +0200
 
13
@@ -236,13 +236,29 @@
 
14
     ~QDeclarativeAccessibleAttached();
 
15
 
 
16
     Role role() const { return (Role)m_role; }
 
17
-    void setRole(Role role) { m_role = (char)role; }
 
18
+    void setRole(Role role)
 
19
+    {
 
20
+        m_role = (char)role;
 
21
+        emit roleChanged();
 
22
+        // There is no way to signify role changes at the moment.
 
23
+        // QAccessible::updateAccessibility(parent(), 0, QAccessible::);
 
24
+    }
 
25
 
 
26
     QString name() const { return m_name; }
 
27
-    void setName(const QString &name) { m_name = name; }
 
28
+    void setName(const QString &name)
 
29
+    {
 
30
+        m_name = name;
 
31
+        emit nameChanged();
 
32
+        QAccessible::updateAccessibility(parent(), 0, QAccessible::NameChanged);
 
33
+    }
 
34
 
 
35
     QString description() const { return m_description; }
 
36
-    void setDescription(const QString &description) { m_description = description; }
 
37
+    void setDescription(const QString &description)
 
38
+    {
 
39
+        m_description = description;
 
40
+        emit descriptionChanged();
 
41
+        QAccessible::updateAccessibility(parent(), 0, QAccessible::DescriptionChanged);
 
42
+    }
 
43
 
 
44
     QDeclarativeItem *item() const {
 
45
         return static_cast<QDeclarativeItem*>(parent());