~ubuntu-branches/ubuntu/quantal/libgweather/quantal

« back to all changes in this revision

Viewing changes to debian/patches/01_gettext_not_xml.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastien Bacher
  • Date: 2011-05-17 15:26:05 UTC
  • mfrom: (1.1.28 upstream) (5.1.9 experimental)
  • Revision ID: james.westby@ubuntu.com-20110517152605-anf9c03d1ny7yn54
Tags: 3.0.0-0ubuntu1
* Resynchronize on Debian and update to the current version, remaining diff:
* debian/control.in:
  - Build-depend on dh-autoreconf, gnome-common
  - use Conflicts on the ppa binaries names differently for easier upgrades
* debian/rules:
  - Run autotools on build
  - Generate POT files on build
* debian/patches/01_gettext_not_xml.patch: 
  - using gettext rather than add translations to the xml databases
* debian/watch: 
  - Watch unstable series  

Show diffs side-by-side

added added

removed removed

Lines of Context:
3
3
 
4
4
only in patch2:
5
5
unchanged:
6
 
Index: libgweather-2.30.2/configure.in
 
6
Index: libgweather-2.91.0/configure.ac
7
7
===================================================================
8
 
--- libgweather-2.30.2.orig/configure.in        2010-06-22 05:01:54.000000000 +0200
9
 
+++ libgweather-2.30.2/configure.in     2010-06-24 10:49:23.000000000 +0200
 
8
--- libgweather-2.91.0.orig/configure.ac        2010-10-05 09:08:07.000000000 +1100
 
9
+++ libgweather-2.91.0/configure.ac     2010-12-03 09:59:03.637006567 +1100
10
10
@@ -40,6 +40,10 @@
11
11
 AM_MAINTAINER_MODE
12
12
 GNOME_MAINTAINER_MODE_DEFINES
32
32
 AC_ARG_ENABLE(locations-compression,
33
33
         [AC_HELP_STRING([--enable-locations-compression],
34
34
                         [Compress Locations.xml files])],
35
 
@@ -253,7 +250,7 @@
 
35
@@ -236,7 +233,7 @@
36
36
 Makefile
37
37
 doc/Makefile
38
38
 po/Makefile.in
39
39
-po-locations/Makefile
40
40
+po-locations/Makefile.in
41
41
 libgweather/Makefile
42
 
 libgweather/gweather.pc
43
 
 libgweather/gweather-uninstalled.pc
44
 
@@ -262,12 +259,6 @@
 
42
 libgweather/gweather-3.0.pc
 
43
 libgweather/gweather-3.0-uninstalled.pc
 
44
@@ -244,12 +241,6 @@
45
45
 icons/Makefile
46
46
 ])
47
47
 
54
54
 dnl ***************************************************************************
55
55
 dnl *** Display Summary                                                     ***
56
56
 dnl ***************************************************************************
57
 
@@ -278,6 +269,4 @@
 
57
@@ -260,6 +251,4 @@
58
58
        Source code location:           ${srcdir}
59
59
        Compiler:                       ${CC}
60
 
        Python bindings:                ${enable_python}
 
60
        Introspection support:          ${found_introspection}
61
61
-       Locations.xml translations:     ${LOCATIONS_XML_TRANSLATIONS}
62
62
-       Locations.xml compression:      ${enable_locations_compression}
63
63
 " >&2
64
 
Index: libgweather-2.30.2/data/Makefile.am
 
64
Index: libgweather-2.91.0/data/Makefile.am
65
65
===================================================================
66
 
--- libgweather-2.30.2.orig/data/Makefile.am    2010-02-09 13:28:03.000000000 +0100
67
 
+++ libgweather-2.30.2/data/Makefile.am 2010-06-24 10:49:23.000000000 +0200
68
 
@@ -4,55 +4,23 @@
 
66
--- libgweather-2.91.0.orig/data/Makefile.am    2010-10-05 09:07:31.000000000 +1100
 
67
+++ libgweather-2.91.0/data/Makefile.am 2010-12-03 10:00:26.737010377 +1100
 
68
@@ -4,61 +4,21 @@
69
69
 libgweatherlocationsdir = $(pkgdatadir)
70
70
 libgweatherlocations_in_files = Locations.xml.in
71
71
 
111
111
-       done &&                                                         \
112
112
-       xmllint --noblanks -o Locations.xml C/$(libgweatherlocations_data) && \
113
113
-       rm -f C/$(libgweatherlocations_data) &&                         \
 
114
-       test -d C && rmdir C &&                                         \
 
115
-       if test "x$(COMPRESS_EXT)" = "x.gz"; then                       \
 
116
-               gzip --force Locations.xml;                             \
 
117
-       fi &&                                                           \
 
118
-       touch $@
 
119
-
 
120
-endif # USE_ONE_BIG_XML
 
121
-
 
122
-### Locations.xml.in rebuild
 
123
-rebuild-locations: locationdb.sqlite update-locations.py
 
124
-       $(AM_V_GEN)($(srcdir)/update-locations.py > Locations.xml.in.new && mv Locations.xml.in.new Locations.xml.in) || rm -f Locations.xml.in.new
 
125
-
 
126
-locationdb.sqlite: build-locationdb.pl major-cities.txt sources/nsd_cccc.txt sources/POP_PLACES.txt sources/US_CONCISE.txt sources/geonames_dd_dms_date_*.txt city-fixups.pl station-fixups.pl
 
127
-       $(AM_V_GEN)$(srcdir)/build-locationdb.pl
114
128
+$(LOCATIONS_STAMP): $(libgweatherlocations_in_files) Makefile
115
129
+       LC_ALL=C $(INTLTOOL_MERGE) --multiple-output --xml-style --utf8 --cache=$(top_builddir)/po-locations/.intltool-merge-cache /dev/null $< $(libgweatherlocations_DATA)  && \
116
130
+       xmllint --noblanks -o Locations.xml C/$(libgweatherlocations_DATA) && \
117
131
+       rm -f C/$(libgweatherlocations_DATA) &&                         \
118
 
        test -d C && rmdir C &&                                         \
119
 
-       if test "x$(COMPRESS_EXT)" = "x.gz"; then                       \
120
 
-               gzip --force Locations.xml;                             \
121
 
-       fi &&                                                           \
122
 
        touch $@
 
132
+       touch $@
123
133
 
124
 
-endif # USE_ONE_BIG_XML
125
 
-
126
134
 check:
127
135
        xmllint --valid --noout $(top_srcdir)/data/Locations.xml.in
128
 
        $(srcdir)/check-timezones.sh $(srcdir)/Locations.xml.in
129
 
Index: libgweather-2.30.2/libgweather/gweather-location.c
 
136
Index: libgweather-2.91.0/libgweather/gweather-location.c
130
137
===================================================================
131
 
--- libgweather-2.30.2.orig/libgweather/gweather-location.c     2010-02-09 13:28:03.000000000 +0100
132
 
+++ libgweather-2.30.2/libgweather/gweather-location.c  2010-06-24 10:49:23.000000000 +0200
 
138
--- libgweather-2.91.0.orig/libgweather/gweather-location.c     2010-02-09 23:28:03.000000000 +1100
 
139
+++ libgweather-2.91.0/libgweather/gweather-location.c  2010-12-03 09:58:46.957006001 +1100
133
140
@@ -22,11 +22,14 @@
134
141
 #include <config.h>
135
142
 #endif
168
175
            xmlFree (value);
169
176
            normalized = g_utf8_normalize (loc->name, -1, G_NORMALIZE_ALL);
170
177
            loc->sort_name = g_utf8_casefold (normalized, -1);
171
 
Index: libgweather-2.30.2/libgweather/gweather-timezone.c
 
178
Index: libgweather-2.91.0/libgweather/gweather-timezone.c
172
179
===================================================================
173
 
--- libgweather-2.30.2.orig/libgweather/gweather-timezone.c     2010-02-09 13:28:03.000000000 +0100
174
 
+++ libgweather-2.30.2/libgweather/gweather-timezone.c  2010-06-24 10:49:23.000000000 +0200
 
180
--- libgweather-2.91.0.orig/libgweather/gweather-timezone.c     2010-02-09 23:28:03.000000000 +1100
 
181
+++ libgweather-2.91.0/libgweather/gweather-timezone.c  2010-12-03 09:58:46.957006001 +1100
175
182
@@ -23,6 +23,7 @@
176
183
 #endif
177
184
 
228
235
     if (name)
229
236
        xmlFree (name);
230
237
 
231
 
Index: libgweather-2.30.2/po-locations/LINGUAS
 
238
Index: libgweather-2.91.0/po-locations/LINGUAS
232
239
===================================================================
233
240
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
234
 
+++ libgweather-2.30.2/po-locations/LINGUAS     2010-06-24 10:49:23.000000000 +0200
 
241
+++ libgweather-2.91.0/po-locations/LINGUAS     2010-12-03 09:58:46.957006001 +1100
235
242
@@ -0,0 +1,78 @@
236
243
+ang
237
244
+ar
311
318
+zh_CN
312
319
+zh_HK
313
320
+zh_TW
314
 
Index: libgweather-2.30.2/po-locations/Makefile.in.in
 
321
Index: libgweather-2.91.0/po-locations/Makefile.in.in
315
322
===================================================================
316
323
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
317
 
+++ libgweather-2.30.2/po-locations/Makefile.in.in      2010-06-24 10:49:23.000000000 +0200
 
324
+++ libgweather-2.91.0/po-locations/Makefile.in.in      2010-12-03 09:58:46.957006001 +1100
318
325
@@ -0,0 +1,217 @@
319
326
+# Makefile for program source directory in GNU NLS utilities package.
320
327
+# Copyright (C) 1995, 1996, 1997 by Ulrich Drepper <drepper@gnu.ai.mit.edu>
533
540
+# Tell versions [3.59,3.63) of GNU make not to export all variables.
534
541
+# Otherwise a system limit (for SysV at least) may be exceeded.
535
542
+.NOEXPORT:
536
 
Index: libgweather-2.30.2/po-locations/POTFILES.in
 
543
Index: libgweather-2.91.0/po-locations/POTFILES.in
537
544
===================================================================
538
545
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
539
 
+++ libgweather-2.30.2/po-locations/POTFILES.in 2010-06-24 10:49:23.000000000 +0200
 
546
+++ libgweather-2.91.0/po-locations/POTFILES.in 2010-12-03 09:58:46.957006001 +1100
540
547
@@ -0,0 +1,4 @@
541
548
+# This list should contain *only* data/Locations.xml.in.
542
549
+# Everything else should be in POTFILES.skip.