~ubuntu-branches/ubuntu/raring/lightning-sunbird/raring

« back to all changes in this revision

Viewing changes to debian/patches/bz289394-align-double-on-ia64-deb-bug-303518.patch

  • Committer: Bazaar Package Importer
  • Author(s): Alexander Sack, John Vivirito
  • Date: 2007-07-30 12:18:59 UTC
  • Revision ID: james.westby@ubuntu.com-20070730121859-ygo6nkqv12m774d8
Tags: 0.5-0ubuntu1
* debian/control: adding unzip to build-depends
* debian/control: fixing short summary of summary to refer
  to Calendar instead of "mail client"
* debian/copyright: add info about
  other-licenses/{7zstub,bsdiff,branding,libart_lgpl}

[ John Vivirito ]
* Initial release.
* Made use of upstream tarball
* debian/sunbird.desktop: modified .desktop file to reflect sunbird
* debian/control: Fixed typos changed standalone to stand-alone
* debian/firefox.manpages: removed for now, not needed
* debian/sunbird.postinst: removed all code that installs sunbird as an
  alternative for x-www-browser
* debian/sunbird.prerm: removed all code that installs sunbird as an
  alternative for x-www-browser

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From f7d8435e8a3923eb783a404a9db6187ee8ce40ff Mon Sep 17 00:00:00 2001
 
2
From: asac <asac@hector.personalfree.com>
 
3
Date: Wed, 21 Feb 2007 03:34:16 +0100
 
4
Subject: [PATCH] bz289394-align-double-on-ia64-deb-bug-303518
 
5
 
 
6
  + align double on ia64 ... deb bug 303518
 
7
---
 
8
 extensions/transformiix/source/base/Double.cpp |   35 ++++++++++++-------------
 
9
 1 file changed, 17 insertions(+), 18 deletions(-)
 
10
 
 
11
Index: mozilla/extensions/transformiix/source/base/Double.cpp
 
12
===================================================================
 
13
--- mozilla.orig/extensions/transformiix/source/base/Double.cpp 2006-06-22 21:13:00.000000000 +0200
 
14
+++ mozilla/extensions/transformiix/source/base/Double.cpp      2007-04-04 18:49:14.000000000 +0200
 
15
@@ -70,33 +70,32 @@
 
16
  * differently: the 32 bit words are in little endian byte order, the two words
 
17
  * are stored in big endian`s way.
 
18
  */
 
19
 
 
20
 #if defined(__arm) || defined(__arm32__) || defined(_arm26__) || defined(__arm__)
 
21
 #define CPU_IS_ARM
 
22
 #endif
 
23
 
 
24
-#if (__GNUC__ == 2 && __GNUC_MINOR__ > 95) || __GNUC__ > 2
 
25
-/**
 
26
- * This version of the macros is safe for the alias optimizations
 
27
- * that gcc does, but uses gcc-specific extensions.
 
28
- */
 
29
-
 
30
 typedef union txdpun {
 
31
-    PRFloat64 d;
 
32
     struct {
 
33
 #if defined(IS_LITTLE_ENDIAN) && !defined(CPU_IS_ARM)
 
34
         PRUint32 lo, hi;
 
35
 #else
 
36
         PRUint32 hi, lo;
 
37
 #endif
 
38
     } s;
 
39
+    PRFloat64 d;
 
40
 } txdpun;
 
41
 
 
42
+#if (__GNUC__ == 2 && __GNUC_MINOR__ > 95) || __GNUC__ > 2
 
43
+/**
 
44
+ * This version of the macros is safe for the alias optimizations
 
45
+ * that gcc does, but uses gcc-specific extensions.
 
46
+ */
 
47
 #define TX_DOUBLE_HI32(x) (__extension__ ({ txdpun u; u.d = (x); u.s.hi; }))
 
48
 #define TX_DOUBLE_LO32(x) (__extension__ ({ txdpun u; u.d = (x); u.s.lo; }))
 
49
 
 
50
 #else // __GNUC__
 
51
 
 
52
 /* We don't know of any non-gcc compilers that perform alias optimization,
 
53
  * so this code should work.
 
54
  */
 
55
@@ -112,30 +111,30 @@
 
56
 #endif // __GNUC__
 
57
 
 
58
 #define TX_DOUBLE_HI32_SIGNBIT   0x80000000
 
59
 #define TX_DOUBLE_HI32_EXPMASK   0x7ff00000
 
60
 #define TX_DOUBLE_HI32_MANTMASK  0x000fffff
 
61
 
 
62
 //-- Initialize Double related constants
 
63
 #ifdef IS_BIG_ENDIAN
 
64
-const PRUint32 nanMask[2] =    {TX_DOUBLE_HI32_EXPMASK | TX_DOUBLE_HI32_MANTMASK,
 
65
-                                0xffffffff};
 
66
-const PRUint32 infMask[2] =    {TX_DOUBLE_HI32_EXPMASK, 0};
 
67
-const PRUint32 negInfMask[2] = {TX_DOUBLE_HI32_EXPMASK | TX_DOUBLE_HI32_SIGNBIT, 0};
 
68
+const txdpun nanMask =    {TX_DOUBLE_HI32_EXPMASK | TX_DOUBLE_HI32_MANTMASK,
 
69
+                           0xffffffff};
 
70
+const txdpun infMask =    {TX_DOUBLE_HI32_EXPMASK, 0};
 
71
+const txdpun negInfMask = {TX_DOUBLE_HI32_EXPMASK | TX_DOUBLE_HI32_SIGNBIT, 0};
 
72
 #else
 
73
-const PRUint32 nanMask[2] =    {0xffffffff,
 
74
-                                TX_DOUBLE_HI32_EXPMASK | TX_DOUBLE_HI32_MANTMASK};
 
75
-const PRUint32 infMask[2] =    {0, TX_DOUBLE_HI32_EXPMASK};
 
76
-const PRUint32 negInfMask[2] = {0, TX_DOUBLE_HI32_EXPMASK | TX_DOUBLE_HI32_SIGNBIT};
 
77
+const txdpun nanMask = {0xffffffff,
 
78
+                        TX_DOUBLE_HI32_EXPMASK | TX_DOUBLE_HI32_MANTMASK};
 
79
+const txdpun infMask =    {0, TX_DOUBLE_HI32_EXPMASK};
 
80
+const txdpun negInfMask = {0, TX_DOUBLE_HI32_EXPMASK | TX_DOUBLE_HI32_SIGNBIT};
 
81
 #endif
 
82
 
 
83
-const double Double::NaN = *((double*)nanMask);
 
84
-const double Double::POSITIVE_INFINITY = *((double*)infMask);
 
85
-const double Double::NEGATIVE_INFINITY = *((double*)negInfMask);
 
86
+const double Double::NaN = nanMask.d;
 
87
+const double Double::POSITIVE_INFINITY = infMask.d;
 
88
+const double Double::NEGATIVE_INFINITY = negInfMask.d;
 
89
 
 
90
 /*
 
91
  * Determines whether the given double represents positive or negative
 
92
  * inifinity
 
93
  */
 
94
 MBool Double::isInfinite(double aDbl)
 
95
 {
 
96
     return ((TX_DOUBLE_HI32(aDbl) & ~TX_DOUBLE_HI32_SIGNBIT) == TX_DOUBLE_HI32_EXPMASK &&