~ubuntu-branches/ubuntu/raring/lightning-sunbird/raring

« back to all changes in this revision

Viewing changes to debian/patches/myspell-hunspell-support-configure-in-add-enable-system-myspell-support.patch

  • Committer: Bazaar Package Importer
  • Author(s): Alexander Sack, John Vivirito
  • Date: 2007-07-30 12:18:59 UTC
  • Revision ID: james.westby@ubuntu.com-20070730121859-ygo6nkqv12m774d8
Tags: 0.5-0ubuntu1
* debian/control: adding unzip to build-depends
* debian/control: fixing short summary of summary to refer
  to Calendar instead of "mail client"
* debian/copyright: add info about
  other-licenses/{7zstub,bsdiff,branding,libart_lgpl}

[ John Vivirito ]
* Initial release.
* Made use of upstream tarball
* debian/sunbird.desktop: modified .desktop file to reflect sunbird
* debian/control: Fixed typos changed standalone to stand-alone
* debian/firefox.manpages: removed for now, not needed
* debian/sunbird.postinst: removed all code that installs sunbird as an
  alternative for x-www-browser
* debian/sunbird.prerm: removed all code that installs sunbird as an
  alternative for x-www-browser

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
---
 
2
 config/autoconf.mk.in                          |    4 ++++
 
3
 configure.in                                   |   16 ++++++++++++++++
 
4
 extensions/spellcheck/myspell/src/Makefile.in  |   24 ++++++++++++++++--------
 
5
 extensions/spellcheck/myspell/src/mozMySpell.h |    2 +-
 
6
 4 files changed, 37 insertions(+), 9 deletions(-)
 
7
 
 
8
Index: mozilla/config/autoconf.mk.in
 
9
===================================================================
 
10
--- mozilla.orig/config/autoconf.mk.in  2007-04-18 09:22:51.000000000 +0000
 
11
+++ mozilla/config/autoconf.mk.in       2007-04-18 09:26:37.000000000 +0000
 
12
@@ -188,16 +188,20 @@
 
13
 
 
14
 MOZ_XUL                    = @MOZ_XUL@
 
15
 
 
16
 NECKO_PROTOCOLS = @NECKO_PROTOCOLS@
 
17
 NECKO_DISK_CACHE = @NECKO_DISK_CACHE@
 
18
 NECKO_SMALL_BUFFERS = @NECKO_SMALL_BUFFERS@
 
19
 NECKO_COOKIES = @NECKO_COOKIES@
 
20
 
 
21
+MOZ_NATIVE_MYSPELL = @SYSTEM_MYSPELL@
 
22
+MOZ_MYSPELL_LIBS = @MOZ_MYSPELL_LIBS@
 
23
+MOZ_MYSPELL_CFLAGS = @MOZ_MYSPELL_CFLAGS@
 
24
+
 
25
 MOZ_NATIVE_ZLIB        = @SYSTEM_ZLIB@
 
26
 MOZ_NATIVE_JPEG        = @SYSTEM_JPEG@
 
27
 MOZ_NATIVE_PNG = @SYSTEM_PNG@
 
28
 MOZ_TREE_CAIRO = @MOZ_TREE_CAIRO@
 
29
 
 
30
 MOZ_UPDATE_XTERM = @MOZ_UPDATE_XTERM@
 
31
 MOZ_MATHML = @MOZ_MATHML@
 
32
 MOZ_XTF = @MOZ_XTF@
 
33
Index: mozilla/configure.in
 
34
===================================================================
 
35
--- mozilla.orig/configure.in   2007-04-18 09:22:51.000000000 +0000
 
36
+++ mozilla/configure.in        2007-04-18 09:26:38.000000000 +0000
 
37
@@ -3859,16 +3859,32 @@
 
38
 
 
39
 if test "${PNG_DIR}" -a -d "${PNG_DIR}" -a "$SYSTEM_PNG" = 1; then
 
40
     PNG_CFLAGS="-I${PNG_DIR}/include"
 
41
     PNG_LIBS="-L${PNG_DIR}/lib ${PNG_LIBS}"
 
42
 fi
 
43
 
 
44
 fi # SKIP_LIBRARY_CHECKS
 
45
 
 
46
+dnl system MySpell Support
 
47
+dnl ========================================================
 
48
+MOZ_ARG_ENABLE_BOOL(system-myspell,
 
49
+[  --enable-system-myspell   Use system myspell (located with pkgconfig)],
 
50
+    SYSTEM_MYSPELL=1 )
 
51
+
 
52
+if test -n "$SYSTEM_MYSPELL"; then
 
53
+    dnl PKG_CHECK_MODULES(MOZ_MYSPELL, myspell)
 
54
+    MOZ_MYSPELL_CFLAGS="-I/usr/include/hunspell -DMySpell=Hunspell"
 
55
+    MOZ_MYSPELL_LIBS="-lhunspell"
 
56
+fi
 
57
+
 
58
+AC_SUBST(SYSTEM_MYSPELL)
 
59
+AC_SUBST(MOZ_MYSPELL_LIBS)
 
60
+AC_SUBST(MOZ_MYSPELL_CFLAGS)
 
61
+
 
62
 dnl ========================================================
 
63
 dnl Java SDK support
 
64
 dnl ========================================================
 
65
 JAVA_INCLUDE_PATH=
 
66
 MOZ_ARG_WITH_STRING(java-include-path,
 
67
 [  --with-java-include-path=dir   Location of Java SDK headers],
 
68
     JAVA_INCLUDE_PATH=$withval)
 
69
 
 
70
Index: mozilla/extensions/spellcheck/myspell/src/Makefile.in
 
71
===================================================================
 
72
--- mozilla.orig/extensions/spellcheck/myspell/src/Makefile.in  2006-06-29 21:23:45.000000000 +0000
 
73
+++ mozilla/extensions/spellcheck/myspell/src/Makefile.in       2007-04-18 09:26:38.000000000 +0000
 
74
@@ -55,30 +55,38 @@
 
75
 REQUIRES       = xpcom \
 
76
                  string \
 
77
                  uconv \
 
78
                  unicharutil \
 
79
                  spellchecker \
 
80
                  xulapp \
 
81
                  $(NULL)
 
82
 
 
83
-CPPSRCS =         affentry.cpp \
 
84
-                 affixmgr.cpp \
 
85
-                 hashmgr.cpp \
 
86
-                 suggestmgr.cpp \
 
87
-                 csutil.cpp \
 
88
-                 myspell.cpp \
 
89
-                 mozMySpell.cpp \
 
90
-                 mozMySpellFactory.cpp \
 
91
+CPPSRCS =         mozMySpell.cpp \
 
92
+                  mozMySpellFactory.cpp \
 
93
                   $(NULL)
 
94
+ifndef MOZ_NATIVE_MYSPELL
 
95
+CPPSRCS +=        affentry.cpp \
 
96
+                  affixmgr.cpp \
 
97
+                  hashmgr.cpp \
 
98
+                  suggestmgr.cpp \
 
99
+                  csutil.cpp \
 
100
+                  myspell.cpp \
 
101
+                  $(NULL)
 
102
+endif
 
103
 
 
104
 ifdef MOZ_XUL_APP
 
105
 CPPSRCS += mozMySpellDirProvider.cpp
 
106
 endif
 
107
 
 
108
 EXTRA_DSO_LDOPTS = \
 
109
                $(LIBS_DIR) \
 
110
                $(XPCOM_LIBS) \
 
111
                $(NSPR_LIBS) \
 
112
                $(MOZ_UNICHARUTIL_LIBS) \
 
113
+               $(MOZ_MYSPELL_LIBS) \
 
114
                $(NULL)
 
115
 
 
116
 include $(topsrcdir)/config/rules.mk
 
117
+
 
118
+ifdef MOZ_NATIVE_MYSPELL
 
119
+CXXFLAGS += $(MOZ_MYSPELL_CFLAGS)
 
120
+endif
 
121
Index: mozilla/extensions/spellcheck/myspell/src/mozMySpell.h
 
122
===================================================================
 
123
--- mozilla.orig/extensions/spellcheck/myspell/src/mozMySpell.h 2006-06-29 21:46:59.000000000 +0000
 
124
+++ mozilla/extensions/spellcheck/myspell/src/mozMySpell.h      2007-04-18 09:26:38.000000000 +0000
 
125
@@ -51,17 +51,17 @@
 
126
  * and affix compression in general, please see:
 
127
  * http://www.cs.ucla.edu/ficus-members/geoff/ispell.html
 
128
  * (the home page for ispell)
 
129
  *
 
130
  * ***** END LICENSE BLOCK ***** */
 
131
 #ifndef mozMySpell_h__
 
132
 #define mozMySpell_h__
 
133
 
 
134
-#include "myspell.hxx"
 
135
+#include "hunspell.hxx"
 
136
 #include "mozISpellCheckingEngine.h"
 
137
 #include "mozIPersonalDictionary.h"
 
138
 #include "nsString.h"
 
139
 #include "nsCOMPtr.h"
 
140
 #include "nsIObserver.h"
 
141
 #include "nsIUnicodeEncoder.h"
 
142
 #include "nsIUnicodeDecoder.h"
 
143
 #include "nsInterfaceHashtable.h"