~ubuntu-branches/ubuntu/raring/lightning-sunbird/raring

« back to all changes in this revision

Viewing changes to debian/patches/bz331818-fix-crash-xpidl-zero-arguments.patch

  • Committer: Bazaar Package Importer
  • Author(s): Alexander Sack, John Vivirito
  • Date: 2007-07-30 12:18:59 UTC
  • Revision ID: james.westby@ubuntu.com-20070730121859-ygo6nkqv12m774d8
Tags: 0.5-0ubuntu1
* debian/control: adding unzip to build-depends
* debian/control: fixing short summary of summary to refer
  to Calendar instead of "mail client"
* debian/copyright: add info about
  other-licenses/{7zstub,bsdiff,branding,libart_lgpl}

[ John Vivirito ]
* Initial release.
* Made use of upstream tarball
* debian/sunbird.desktop: modified .desktop file to reflect sunbird
* debian/control: Fixed typos changed standalone to stand-alone
* debian/firefox.manpages: removed for now, not needed
* debian/sunbird.postinst: removed all code that installs sunbird as an
  alternative for x-www-browser
* debian/sunbird.prerm: removed all code that installs sunbird as an
  alternative for x-www-browser

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 30b1bbc3c3d380aa459b932cf3c0c4b448a91086 Mon Sep 17 00:00:00 2001
 
2
From: asac <asac@hector.personalfree.com>
 
3
Date: Wed, 21 Feb 2007 03:34:16 +0100
 
4
Subject: [PATCH] bz331818-fix-crash-xpidl-zero-arguments
 
5
 
 
6
  + patch that fixes a crash if xpidl gets not enough arguments
 
7
---
 
8
 xpcom/typelib/xpidl/xpidl.c |    4 ++--
 
9
 1 file changed, 2 insertions(+), 2 deletions(-)
 
10
 
 
11
Index: mozilla/xpcom/typelib/xpidl/xpidl.c
 
12
===================================================================
 
13
--- mozilla.orig/xpcom/typelib/xpidl/xpidl.c    2006-02-03 15:41:11.000000000 +0100
 
14
+++ mozilla/xpcom/typelib/xpidl/xpidl.c 2007-04-04 18:49:07.000000000 +0200
 
15
@@ -255,21 +255,21 @@
 
16
         }
 
17
     }
 
18
  done_options:
 
19
     if (!mode) {
 
20
         fprintf(stderr, "ERROR: must specify output mode\n");
 
21
         xpidl_usage(argc, argv);
 
22
         return 1;
 
23
     }
 
24
-    if (argc != i + 1) {
 
25
+    if (argc > i + 1) {
 
26
         fprintf(stderr, "ERROR: extra arguments after input file\n");
 
27
     }
 
28
 
 
29
     /*
 
30
      * Don't try to process multiple files, given that we don't handle -o
 
31
      * multiply.
 
32
      */
 
33
-    if (xpidl_process_idl(argv[i], inc_head, file_basename, mode))
 
34
+    if ((i < argc) && xpidl_process_idl(argv[i], inc_head, file_basename, mode))
 
35
         return 0;
 
36
 
 
37
     return 1;
 
38
 }