~ubuntu-branches/ubuntu/raring/python3.3/raring-proposed

« back to all changes in this revision

Viewing changes to debian/patches/bsddb-libpath.diff

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2012-03-22 06:14:01 UTC
  • Revision ID: package-import@ubuntu.com-20120322061401-vvrgvw3nvi68rtqq
Tags: 3.3.0~a1-1
* Python 3.3.0 alpha1 release.
* Update to 20120321 from the trunk.
* Update debian/copyright.
* Build-depend on expat (>= 2.1~).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
# DP: Don't add the bsddb multilib path, if already in the standard lib path
 
2
 
 
3
--- a/setup.py
 
4
+++ b/setup.py
 
5
@@ -943,7 +943,13 @@
 
6
             if db_setup_debug:
 
7
                 print("bsddb using BerkeleyDB lib:", db_ver, dblib)
 
8
                 print("bsddb lib dir:", dblib_dir, " inc dir:", db_incdir)
 
9
-            db_incs = [db_incdir]
 
10
+            # only add db_incdir/dblib_dir if not in the standard paths
 
11
+            if db_incdir in inc_dirs:
 
12
+                db_incs = []
 
13
+            else:
 
14
+                db_incs = [db_incdir]
 
15
+            if dblib_dir[0] in lib_dirs:
 
16
+                dblib_dir = []
 
17
             dblibs = [dblib]
 
18
         else:
 
19
             if db_setup_debug: print("db: no appropriate library found")