~ubuntu-branches/ubuntu/raring/python3.3/raring-proposed

« back to all changes in this revision

Viewing changes to debian/patches/profiled-build.diff

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2012-03-22 06:14:01 UTC
  • Revision ID: package-import@ubuntu.com-20120322061401-vvrgvw3nvi68rtqq
Tags: 3.3.0~a1-1
* Python 3.3.0 alpha1 release.
* Update to 20120321 from the trunk.
* Update debian/copyright.
* Build-depend on expat (>= 2.1~).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
# DP: Ignore errors in the profile task.
 
2
 
 
3
Index: b/Makefile.pre.in
 
4
===================================================================
 
5
--- a/Makefile.pre.in
 
6
+++ b/Makefile.pre.in
 
7
@@ -411,18 +411,18 @@
 
8
        $(MAKE) build_all_use_profile
 
9
 
 
10
 build_all_generate_profile:
 
11
-       $(MAKE) all CFLAGS="$(CFLAGS) -fprofile-generate" LIBS="$(LIBS) -lgcov"
 
12
+       $(MAKE) all PY_CFLAGS="$(PY_CFLAGS) -fprofile-generate" LIBS="$(LIBS) -lgcov"
 
13
 
 
14
 run_profile_task:
 
15
-       ./$(BUILDPYTHON) $(PROFILE_TASK)
 
16
+       -./$(BUILDPYTHON) $(PROFILE_TASK)
 
17
 
 
18
 build_all_use_profile:
 
19
-       $(MAKE) all CFLAGS="$(CFLAGS) -fprofile-use"
 
20
+       $(MAKE) all PY_CFLAGS="$(PY_CFLAGS) -fprofile-use -fprofile-correction"
 
21
 
 
22
 coverage:
 
23
        @echo "Building with support for coverage checking:"
 
24
        $(MAKE) clean
 
25
-       $(MAKE) all CFLAGS="$(CFLAGS) -O0 -pg -fprofile-arcs -ftest-coverage" LIBS="$(LIBS) -lgcov"
 
26
+       $(MAKE) all PY_CFLAGS="$(PY_CFLAGS) -O0 -pg -fprofile-arcs -ftest-coverage" LIBS="$(LIBS) -lgcov"
 
27
 
 
28
 
 
29
 # Build the interpreter