~ubuntu-branches/ubuntu/raring/python3.3/raring-proposed

« back to all changes in this revision

Viewing changes to debian/patches/cthreads.diff

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2012-03-22 06:14:01 UTC
  • Revision ID: package-import@ubuntu.com-20120322061401-vvrgvw3nvi68rtqq
Tags: 3.3.0~a1-1
* Python 3.3.0 alpha1 release.
* Update to 20120321 from the trunk.
* Update debian/copyright.
* Build-depend on expat (>= 2.1~).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
# DP: Remove cthreads detection
 
2
 
 
3
--- a/configure.ac
 
4
+++ b/configure.ac
 
5
@@ -2046,7 +2046,6 @@
 
6
 
 
7
 # Templates for things AC_DEFINEd more than once.
 
8
 # For a single AC_DEFINE, no template is needed.
 
9
-AH_TEMPLATE(C_THREADS,[Define if you have the Mach cthreads package])
 
10
 AH_TEMPLATE(_REENTRANT,
 
11
   [Define to force use of thread-safe errno, h_errno, and other functions])
 
12
 AH_TEMPLATE(WITH_THREAD,
 
13
@@ -2128,17 +2127,6 @@
 
14
     AC_MSG_RESULT($unistd_defines_pthreads)
 
15
 
 
16
     AC_DEFINE(_REENTRANT)
 
17
-    AC_CHECK_HEADER(cthreads.h, [AC_DEFINE(WITH_THREAD)
 
18
-    AC_DEFINE(C_THREADS)
 
19
-    AC_DEFINE(HURD_C_THREADS, 1,
 
20
-    [Define if you are using Mach cthreads directly under /include])
 
21
-    LIBS="$LIBS -lthreads"
 
22
-    THREADOBJ="Python/thread.o"],[
 
23
-    AC_CHECK_HEADER(mach/cthreads.h, [AC_DEFINE(WITH_THREAD)
 
24
-    AC_DEFINE(C_THREADS)
 
25
-    AC_DEFINE(MACH_C_THREADS, 1,
 
26
-    [Define if you are using Mach cthreads under mach /])
 
27
-    THREADOBJ="Python/thread.o"],[
 
28
     # Just looking for pthread_create in libpthread is not enough:
 
29
     # on HP/UX, pthread.h renames pthread_create to a different symbol name.
 
30
     # So we really have to include pthread.h, and then link.
 
31
@@ -2174,7 +2162,7 @@
 
32
     LIBS="$LIBS -lcma"
 
33
     THREADOBJ="Python/thread.o"],[
 
34
     USE_THREAD_MODULE="#"])
 
35
-    ])])])])])])])
 
36
+    ])])])])])
 
37
 
 
38
     AC_CHECK_LIB(mpc, usconfig, [AC_DEFINE(WITH_THREAD)
 
39
     LIBS="$LIBS -lmpc"