~ubuntu-branches/ubuntu/raring/simutrans/raring-proposed

« back to all changes in this revision

Viewing changes to debian/patches/revert-svn-1937.diff

  • Committer: Package Import Robot
  • Author(s): Ansgar Burchardt
  • Date: 2011-11-03 19:59:02 UTC
  • mfrom: (1.2.7)
  • Revision ID: package-import@ubuntu.com-20111103195902-uopgwf488mfctb75
Tags: 111.0-1
* New upstream release.
* debian/rules: Update get-orig-source target for new upstream release.
* Use xz compression for source and binary packages.
* Use override_* targets to simplify debian/rules.

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
This patch reverts SVN commit 1937 to make simutrans use ~/.simutrans for
6
6
savegames instead of ~/simutrans.
7
7
 
8
 
--- simutrans.orig/simsys_s.cc
9
 
+++ simutrans/simsys_s.cc
10
 
@@ -317,7 +317,7 @@
11
 
        return NULL;
12
 
 #else
13
 
 #ifndef __APPLE__
14
 
-       sprintf( buffer, "%s/simutrans", getenv("HOME") );
15
 
+       sprintf( buffer, "%s/.simutrans", getenv("HOME") );
16
 
 #else
17
 
        sprintf( buffer, "%s/Library/Simutrans", getenv("HOME") );
 
8
--- simutrans.orig/simsys.cc
 
9
+++ simutrans/simsys.cc
 
10
@@ -39,7 +39,7 @@
 
11
 #elif defined __APPLE__
 
12
        sprintf(buffer, "%s/Library/Simutrans", getenv("HOME"));
 
13
 #else
 
14
-       sprintf(buffer, "%s/simutrans", getenv("HOME"));
 
15
+       sprintf(buffer, "%s/.simutrans", getenv("HOME"));
18
16
 #endif
 
17
 
 
18
        dr_mkdir(buffer);