~ubuntu-branches/ubuntu/saucy/gdm/saucy-proposed

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu_slave-only-set-up-autologin.patch

  • Committer: Package Import Robot
  • Author(s): Jeremy Bicha, Tim Lunn, Jeremy Bicha, Robert Ancell
  • Date: 2013-05-31 22:36:08 UTC
  • mfrom: (1.4.55)
  • Revision ID: package-import@ubuntu.com-20130531223608-33uo85niksee5460
Tags: 3.8.1.1-0ubuntu1
[ Tim Lunn ]
* New upstream release
* debian/patches/ubuntu_dont_catch_sigsegv.patch:
  - Dropped, obsolete
* debian/rules:
  - Don't rename gdm binary since that's already been
    done in the new version

[ Jeremy Bicha ]
* debian/control.in: Bump minimum glib
* debian/watch: Watch for unstable releases
* debian/patches/00git_logind_check.patch:
  - Dropped, applied in new release
* debian/patches/08_frequent-users_greeter.patch: Refreshed

[ Robert Ancell ]
* New upstream release
* debian/patches/ubuntu_daemon_autologin_tracking.patch:
* debian/patches/ubuntu_ensure_dirs.patch:
* debian/patches/ubuntu_slave-only-set-up-autologin.patch:
  - Applied upstream

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 2e97338d34dd9fa65069335dbb66579b54970425 Mon Sep 17 00:00:00 2001
2
 
From: Ray Strode <rstrode@redhat.com>
3
 
Date: Thu, 4 Oct 2012 17:36:57 -0400
4
 
Subject: [PATCH] slave: only set up autologin conversations
5
 
 
6
 
Right now any time any session conversation is started,
7
 
we run its setup call if autologin is enabled. We should only do this
8
 
for autologin sessions, otherwise, we may repeat work done by
9
 
the greeter.
10
 
 
11
 
https://bugzilla.gnome.org/show_bug.cgi?id=682467
12
 
 
13
 
--- gdm-3.6.0.orig/daemon/gdm-simple-slave.c
14
 
+++ gdm-3.6.0/daemon/gdm-simple-slave.c
15
 
@@ -467,8 +467,12 @@ on_session_conversation_started (GdmSess
16
 
         char    *username;
17
 
         int      delay;
18
 
 
19
 
+        g_debug ("GdmSimpleSlave: session conversation started for service %s", service_name);
20
 
+
21
 
+        if (g_strcmp0 (service_name, "gdm-autologin") != 0) {
22
 
+                return;
23
 
+        }
24
 
 
25
 
-        g_debug ("GdmSimpleSlave: session conversation started");
26
 
         enabled = FALSE;
27
 
         gdm_slave_get_timed_login_details (GDM_SLAVE (slave), &enabled, &username, &delay);
28
 
         if (! enabled) {