~ubuntu-branches/ubuntu/trusty/cairo-dock-plug-ins/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/bzr3021_Terminal_launch_default_terminal_middle_click.patch

  • Committer: Package Import Robot
  • Author(s): Matthieu Baerts (matttbe)
  • Date: 2014-04-07 00:48:03 UTC
  • mfrom: (48.1.3 cairo-dock-plug-ins)
  • Revision ID: package-import@ubuntu.com-20140407004803-5s5leqg9iplbngje
Tags: 3.3.99.beta1.2.really.3.3.2-0ubuntu1
* Revert back to the 3.3.2 version: (LP: #1302246)
  Unfortunately, due to the lack of time, we have to revert back to the
  latest stable version. Sorry for that but feel free to help us ;-)
* debian/patches: cherry-pick patches from upstream BZR repo, all 'bug-fix'
  and changes that were already in the 3.3.99.beta1 version except all
  changes linked to the new style, the menu and the configuration.
  - bzr3008_GMenu_new_apps_in_the_list.patch: GMenu: New Apps: if there are
    new apps when the 'new apps' dialogue is opened, add these new apps in
    the list
  - bzr3010_GMenu_option_hide_new_apps_dialogue.patch: GMenu: Config: Added
    the possibility to not display notification to quickly launch new apps
  - bzr3021_Terminal_launch_default_terminal_middle_click.patch: Terminal:
    middle click: launch the default terminal
  - bzr3031-3032_GMenu_remove_empty_submenus.patch: GMenu: do not add empty
    submenus when creating them and remove empty submenus
  - bzr3035_DND2Share_History_was_empty.patch: DnD2Share: history menu was
    empty
  - bzr3036-3040_Shortcuts_removed_disk_usage_on_bookmarks_and_support_
    x-nautilus_URI.patch: Shortcuts: correctly removed an old bookmark ;
    added support for x-nautilus-(...) URI ; avoid duplicated code +
    bookmarks doesn't have a disk usage ; translated a few sentences from
    French to English
  - bzr3043_Fixed_typo_with_some_sentences.patch: Fixed typo with some
    sentences which were not correctly translated
  - bzr3045-3046_GVFS_support_x-nautilus-desktop_and_fixed_typos_and_memory_
    leaks.patch: gvfs: fixed typo and tiny memory leak ; GTK3: 'x-nautilus-
    desktop' is just an URI where the root is the path to the desktop
  - bzr3047-3048_Status-Notifier_Added_support_of_middle_click_and_scroll:
    Status-Notifier: IAS (ubuntu): added the support of the middle click ;
    Scroll signals were not catched
  - bzr3051_Logout_Added_support_of_Cinnamon.patch: logout: added support of
    Cinnamon
  - bzr3057_GMenu_new_apps_show_dialog_after_installation.patch: GMenu: new
    apps: show the dialog only after the end of the installation
  - bzr3065_Impulse_do_not_redraw_icon_when_not_needed.patch: Impulse: stop
    animations: do not redraw the icon if it's not needed (e.g. when
    disabling the applet)
  - bzr3067_AlsaMixer_support_cinnamon_settings.patch: AlsaMixer: added the
    support of cinnamon-settings
  - bzr3068_Clock_fixed_a_crash_when_configuring_when_not_enabled.patch:
    Clock: fixed a crash when configuring the applet if it's not activated
  - bzr3069_Indicator_Generic_no_need_to_hide_the_icon_before_removing_it:
    Indicator Generic: stop: no need to hide the icon before removing it
* debian/control: bumped Core versions

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
revno: 3021
 
2
committer: Matthieu Baerts <matttbe@gmail.com>
 
3
branch nick: cairo-dock-plug-ins
 
4
timestamp: Sat 2013-11-30 18:57:54 +0100
 
5
message: Terminal: middle click: launch the default terminal
 
6
The previous function was useless (hide the dialogue) because if the dialogue is displayed, it has the focus: we can't do a middle click on the icon
 
7
 
 
8
=== modified file 'terminal/src/terminal-menu-functions.c'
 
9
Index: cairo-dock-plug-ins/terminal/src/terminal-menu-functions.c
 
10
===================================================================
 
11
--- cairo-dock-plug-ins.orig/terminal/src/terminal-menu-functions.c     2014-04-06 22:33:07.983528641 +0200
 
12
+++ cairo-dock-plug-ins/terminal/src/terminal-menu-functions.c  2014-04-06 22:33:07.979528641 +0200
 
13
@@ -51,11 +51,10 @@
 
14
 
 
15
 CD_APPLET_ON_MIDDLE_CLICK_BEGIN
 
16
 {
 
17
-       if (myData.tab)
 
18
-       {
 
19
-          if (myData.dialog)
 
20
-           gldi_dialog_hide (myData.dialog);
 
21
-       }
 
22
+       if (myConfig.cTerminal != NULL)
 
23
+               cairo_dock_launch_command (myConfig.cTerminal);
 
24
+       else
 
25
+               cairo_dock_launch_command (cairo_dock_get_default_terminal ());
 
26
 }
 
27
 CD_APPLET_ON_MIDDLE_CLICK_END
 
28
 
 
29
Index: cairo-dock-plug-ins/terminal/data/terminal.conf.in
 
30
===================================================================
 
31
--- cairo-dock-plug-ins.orig/terminal/data/terminal.conf.in     2014-04-06 22:33:07.983528641 +0200
 
32
+++ cairo-dock-plug-ins/terminal/data/terminal.conf.in  2014-04-06 22:33:07.975528642 +0200
 
33
@@ -146,3 +146,7 @@
 
34
 
 
35
 #k Shortkey to show the terminal:
 
36
 shortkey = <Control>F5
 
37
+
 
38
+#s[Default] Open this terminal when doing a middle click on the icon:
 
39
+#{The default terminal is defined by the COLORTERM environment variable}
 
40
+terminal app =
 
41
Index: cairo-dock-plug-ins/terminal/src/terminal-config.c
 
42
===================================================================
 
43
--- cairo-dock-plug-ins.orig/terminal/src/terminal-config.c     2014-04-06 22:33:07.983528641 +0200
 
44
+++ cairo-dock-plug-ins/terminal/src/terminal-config.c  2014-04-06 22:33:07.979528641 +0200
 
45
@@ -61,6 +61,7 @@
 
46
        myConfig.shortcut = CD_CONFIG_GET_STRING_WITH_DEFAULT ("Configuration", "shortkey", "<Ctrl>F1");
 
47
        myConfig.iNbRows = CD_CONFIG_GET_INTEGER_WITH_DEFAULT ("Configuration", "nb lines", 25);
 
48
        myConfig.iNbColumns = CD_CONFIG_GET_INTEGER_WITH_DEFAULT ("Configuration", "nb columns", 80);
 
49
+       myConfig.cTerminal = CD_CONFIG_GET_STRING ("Configuration", "terminal app");
 
50
 CD_APPLET_GET_CONFIG_END
 
51
 
 
52
 
 
53
@@ -68,6 +69,7 @@
 
54
        g_free (myConfig.shortcut);
 
55
        myConfig.shortcut = NULL;
 
56
        g_free (myConfig.cCustomFont);
 
57
+       g_free (myConfig.cTerminal);
 
58
 CD_APPLET_RESET_CONFIG_END
 
59
 
 
60
 
 
61
Index: cairo-dock-plug-ins/terminal/src/terminal-struct.h
 
62
===================================================================
 
63
--- cairo-dock-plug-ins.orig/terminal/src/terminal-struct.h     2014-04-06 22:33:07.983528641 +0200
 
64
+++ cairo-dock-plug-ins/terminal/src/terminal-struct.h  2014-04-06 22:33:07.979528641 +0200
 
65
@@ -39,6 +39,7 @@
 
66
        gchar *shortcut;
 
67
        gint iNbRows;
 
68
        gint iNbColumns;
 
69
+       gchar *cTerminal;
 
70
        } ;
 
71
 
 
72
 struct _AppletData {