~ubuntu-branches/ubuntu/trusty/cairo-dock-plug-ins/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/bzr3067_AlsaMixer_support_cinnamon_settings.patch

  • Committer: Package Import Robot
  • Author(s): Matthieu Baerts (matttbe)
  • Date: 2014-04-07 00:48:03 UTC
  • mfrom: (48.1.3 cairo-dock-plug-ins)
  • Revision ID: package-import@ubuntu.com-20140407004803-5s5leqg9iplbngje
Tags: 3.3.99.beta1.2.really.3.3.2-0ubuntu1
* Revert back to the 3.3.2 version: (LP: #1302246)
  Unfortunately, due to the lack of time, we have to revert back to the
  latest stable version. Sorry for that but feel free to help us ;-)
* debian/patches: cherry-pick patches from upstream BZR repo, all 'bug-fix'
  and changes that were already in the 3.3.99.beta1 version except all
  changes linked to the new style, the menu and the configuration.
  - bzr3008_GMenu_new_apps_in_the_list.patch: GMenu: New Apps: if there are
    new apps when the 'new apps' dialogue is opened, add these new apps in
    the list
  - bzr3010_GMenu_option_hide_new_apps_dialogue.patch: GMenu: Config: Added
    the possibility to not display notification to quickly launch new apps
  - bzr3021_Terminal_launch_default_terminal_middle_click.patch: Terminal:
    middle click: launch the default terminal
  - bzr3031-3032_GMenu_remove_empty_submenus.patch: GMenu: do not add empty
    submenus when creating them and remove empty submenus
  - bzr3035_DND2Share_History_was_empty.patch: DnD2Share: history menu was
    empty
  - bzr3036-3040_Shortcuts_removed_disk_usage_on_bookmarks_and_support_
    x-nautilus_URI.patch: Shortcuts: correctly removed an old bookmark ;
    added support for x-nautilus-(...) URI ; avoid duplicated code +
    bookmarks doesn't have a disk usage ; translated a few sentences from
    French to English
  - bzr3043_Fixed_typo_with_some_sentences.patch: Fixed typo with some
    sentences which were not correctly translated
  - bzr3045-3046_GVFS_support_x-nautilus-desktop_and_fixed_typos_and_memory_
    leaks.patch: gvfs: fixed typo and tiny memory leak ; GTK3: 'x-nautilus-
    desktop' is just an URI where the root is the path to the desktop
  - bzr3047-3048_Status-Notifier_Added_support_of_middle_click_and_scroll:
    Status-Notifier: IAS (ubuntu): added the support of the middle click ;
    Scroll signals were not catched
  - bzr3051_Logout_Added_support_of_Cinnamon.patch: logout: added support of
    Cinnamon
  - bzr3057_GMenu_new_apps_show_dialog_after_installation.patch: GMenu: new
    apps: show the dialog only after the end of the installation
  - bzr3065_Impulse_do_not_redraw_icon_when_not_needed.patch: Impulse: stop
    animations: do not redraw the icon if it's not needed (e.g. when
    disabling the applet)
  - bzr3067_AlsaMixer_support_cinnamon_settings.patch: AlsaMixer: added the
    support of cinnamon-settings
  - bzr3068_Clock_fixed_a_crash_when_configuring_when_not_enabled.patch:
    Clock: fixed a crash when configuring the applet if it's not activated
  - bzr3069_Indicator_Generic_no_need_to_hide_the_icon_before_removing_it:
    Indicator Generic: stop: no need to hide the icon before removing it
* debian/control: bumped Core versions

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
revno: 3067
 
2
committer: Matthieu Baerts <matttbe@gmail.com>
 
3
branch nick: cairo-dock-plug-ins
 
4
timestamp: Tue 2014-02-25 09:51:08 +0100
 
5
message: AlsaMixer: added the support of cinnamon-settings
 
6
And first check if gnome-control-center (GNOME 3) is available
 
7
 
 
8
=== modified file 'alsaMixer/src/applet-notifications.c'
 
9
Index: cairo-dock-plug-ins/alsaMixer/src/applet-notifications.c
 
10
===================================================================
 
11
--- cairo-dock-plug-ins.orig/alsaMixer/src/applet-notifications.c       2014-04-06 22:33:37.271527122 +0200
 
12
+++ cairo-dock-plug-ins/alsaMixer/src/applet-notifications.c    2014-04-06 22:33:37.267527122 +0200
 
13
@@ -33,15 +33,22 @@
 
14
 static void _check_mixer_cmd (void)
 
15
 {
 
16
        // check for Gnome2 before Gnome3, since during the transition, both were present, and "gnome-control-center sound" didn't work (and it was anyway just a shortcut to gnome-volume-control).
 
17
-       gchar *cResult = cairo_dock_launch_command_sync ("which gnome-volume-control");  // Gnome2
 
18
+       gchar *cResult = cairo_dock_launch_command_sync ("which gnome-control-center");  // Gnome3
 
19
        if (cResult != NULL && *cResult == '/')
 
20
-               s_cMixerCmd = "gnome-volume-control -p applications";
 
21
+               s_cMixerCmd = "gnome-control-center sound";
 
22
        else
 
23
        {
 
24
                g_free (cResult);
 
25
-               cResult = cairo_dock_launch_command_sync ("which gnome-control-center");  // Gnome3
 
26
-               if (cResult != NULL && *cResult == '/')  /// TODO: other DE...
 
27
-                       s_cMixerCmd = "gnome-control-center sound";
 
28
+               cResult = cairo_dock_launch_command_sync ("which gnome-volume-control");  // Gnome2
 
29
+               if (cResult != NULL && *cResult == '/')
 
30
+                       s_cMixerCmd = "gnome-volume-control -p applications";
 
31
+               else
 
32
+               {
 
33
+                       g_free (cResult);
 
34
+                       cResult = cairo_dock_launch_command_sync ("which cinnamon-settings");  // cinnamon (Mint >= 13)
 
35
+                       if (cResult != NULL && *cResult == '/')
 
36
+                               s_cMixerCmd = "cinnamon-settings sound";
 
37
+               }
 
38
        }  /// TODO: handle other DE ...
 
39
        g_free (cResult);
 
40
 }