~ubuntu-branches/ubuntu/trusty/lifelines/trusty

« back to all changes in this revision

Viewing changes to debian/patches/01_docs-Makefile.in.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Felipe Augusto van de Wiel (faw)
  • Date: 2007-08-14 00:02:04 UTC
  • mfrom: (1.1.4 upstream) (3.1.4 gutsy)
  • Revision ID: james.westby@ubuntu.com-20070814000204-mpv5faygl0dgq3qi
Tags: 3.0.61-1
* New upstream release. (Closes: #387856).
* Fixing documentation build problems also fixes FTBFS if built twice in a
  row. (Closes: #424543).
* Adding lynx as a build dependency. This is necessary to generate txt files
  from html, discovered while fixing #424543.
* Upstream fix: charset for gedcom file in unicode. (Closes: #396206).
* Upstream fim: updating documentation about desc-tex2. (Closes: #405501).
* Bumping Standards-Version to 3.7.2 without package changes.
* Dropping local debian patches added upstream.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh -e
 
2
## 002_docs-Makefile.dpatch by  <bubulle@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Tim Dijkstra patch for proper handling of autocomments
 
6
 
 
7
if [ $# -lt 1 ]; then
 
8
    echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
 
9
    exit 1
 
10
fi
 
11
 
 
12
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
 
13
patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
 
14
 
 
15
case "$1" in
 
16
    -patch) patch -p1 ${patch_opts} < $0;;
 
17
    -unpatch) patch -R -p1 ${patch_opts} < $0;;
 
18
    *)
 
19
        echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
 
20
        exit 1;;
 
21
esac
 
22
 
 
23
exit 0
 
24
 
 
25
@DPATCH@
 
26
 
 
27
--- lifelines-3.0.61.orig/docs/Makefile.in
 
28
+++ lifelines-3.0.61/docs/Makefile.in
 
29
@@ -209,14 +209,9 @@
 
30
 MANUALS_en = ll-reportmanual.html ll-reportmanual.pdf \
 
31
                ll-reportmanual.txt \
 
32
                ll-userguide.html ll-userguide.pdf \
 
33
-               ll-userguide.txt ll-devguide.html \
 
34
-               ll-index.html ll-index.sv.html
 
35
+               ll-userguide.txt ll-devguide.html
 
36
 
 
37
-MANUALS_sv = ll-reportmanual.sv.html \
 
38
-               ll-userguide.sv.html
 
39
-
 
40
-MANUALS = $(MANUALS_en) $(MANUALS_sv)
 
41
-IMAGES = listops.jpg
 
42
+MANUALS = $(MANUALS_en)
 
43
 MANUALSSRC = ll-reportmanual.xml \
 
44
                ll-userguide.xml \
 
45
                ll-devguide.xml
 
46
@@ -239,7 +234,7 @@
 
47
 ###################
 
48
 # Rules
 
49
 ###################
 
50
-EXTRA_DIST = $(MANUALSSRC) $(MANUALS) $(MANPAGES) $(IMAGES) lifelines.vim
 
51
+EXTRA_DIST = $(MANUALSSRC) $(MANUALS) $(MANPAGES) lifelines.vim
 
52
 man1_MANS = $(MANPAGES)
 
53
 CONFIG_CLEAN_FILES = $(OLDGENFILES) $(OLDSRCFILES) $(OLDFILES) $(MANUALS)
 
54
 doc_DATA = $(MANUALSSRC) $(MANUALS)