~ubuntu-branches/ubuntu/trusty/screen/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/01configure_fix_alpha_vsprintf.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Jan Christoph Nordholz
  • Date: 2008-06-12 19:33:30 UTC
  • mfrom: (1.1.13 intrepid)
  • Revision ID: james.westby@ubuntu.com-20080612193330-1tt3qhpxonbgdmq2
Tags: 4.0.3-11
* Unbreak <End> and <^A Bksp> using a patch from Loïc Minier
  (thanks!) - introduced as new 45suppress_remap.dpatch.
  Closes: #484647.
* Bump Standards version to 3.8.0. No changes necessary.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 01configure_fix_alpha_vsprintf.dpatch by  <hesso@pool.math.tu-berlin.de>
 
3
##
 
4
## DP: Enhance the vsprintf() test to also succeed on Alpha.
 
5
## DP: Cf. #213842.
 
6
 
 
7
@DPATCH@
 
8
diff -Naur screen-4.0.3.orig/configure.in screen-4.0.3/configure.in
 
9
--- screen-4.0.3.orig/configure.in      2008-06-01 23:39:48.000000000 +0200
 
10
+++ screen-4.0.3/configure.in   2008-06-01 23:39:51.000000000 +0200
 
11
@@ -1210,7 +1210,7 @@
 
12
 rm -f /tmp/conftest*
 
13
 
 
14
 AC_MSG_CHECKING(for vsprintf)
 
15
-AC_TRY_LINK(,[vsprintf(0,0,0);], AC_MSG_RESULT(yes);AC_DEFINE(USEVARARGS), AC_MSG_RESULT(no))
 
16
+AC_TRY_LINK([#include <stdarg.h>],[va_list valist; vsprintf(0,0,valist);], AC_MSG_RESULT(yes);AC_DEFINE(USEVARARGS), AC_MSG_RESULT(no))
 
17
 
 
18
 AC_HEADER_DIRENT
 
19