~ubuntu-branches/ubuntu/trusty/subversion/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/perl-compiler-flags

  • Committer: Package Import Robot
  • Author(s): Andy Whitcroft
  • Date: 2012-06-21 15:36:36 UTC
  • mfrom: (0.4.13 sid)
  • Revision ID: package-import@ubuntu.com-20120621153636-amqqmuidgwgxz1ly
Tags: 1.7.5-1ubuntu1
* Merge from Debian unstable.  Remaining changes:
  - Create pot file on build.
  - Build a python-subversion-dbg package.
  - Build-depend on python-dbg.
  - Build-depend on default-jre-headless/-jdk.
  - Do not apply java-build patch.
  - debian/rules: Manually create the doxygen output directory, otherwise
    we get weird build failures when running parallel builds.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Add to, but don't replace, Perl ExtUtils::MakeMaker's CCFLAGS.
2
 
Evidently this was a problem exposed by Perl 5.14.  From upstream r1145203.
3
 
 
4
 
 
5
 
--- a/subversion/bindings/swig/perl/native/Makefile.PL.in
6
 
+++ b/subversion/bindings/swig/perl/native/Makefile.PL.in
7
 
@@ -48,7 +48,7 @@ chomp $apr_shlib_path_var;
8
 
 my %config = (
9
 
     ABSTRACT => 'Perl bindings for Subversion',
10
 
     DEFINE => $cppflags,
11
 
-    CCFLAGS => $cflags,
12
 
+    CCFLAGS => join(' ', $cflags, $Config{ccflags}),
13
 
     INC  => join(' ',$apr_cflags, $apu_cflags, 
14
 
                  " -I$swig_srcdir/perl/libsvn_swig_perl",
15
 
                  " -I$svnlib_srcdir/include",