~ubuntu-branches/ubuntu/trusty/subversion/trusty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/ruby-no-strict-aliasing

  • Committer: Package Import Robot
  • Author(s): Andy Whitcroft
  • Date: 2012-06-21 15:36:36 UTC
  • mfrom: (0.4.13 sid)
  • Revision ID: package-import@ubuntu.com-20120621153636-amqqmuidgwgxz1ly
Tags: 1.7.5-1ubuntu1
* Merge from Debian unstable.  Remaining changes:
  - Create pot file on build.
  - Build a python-subversion-dbg package.
  - Build-depend on python-dbg.
  - Build-depend on default-jre-headless/-jdk.
  - Do not apply java-build patch.
  - debian/rules: Manually create the doxygen output directory, otherwise
    we get weird build failures when running parallel builds.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
##
3
 
## ruby-no-strict-aliasing by <peter@p12n.org>
4
 
##
5
 
## DP: Compile ruby bindings with -fno-strict-aliasing.
6
 
## DP: It seems swig is generating _really_ bad code here, or something.
7
 
## DP:
8
 
## DP: Whatever it is, this line suppresses 1323 warnings, any of which might
9
 
## DP: be real bugs with real consequences.
 
1
It seems swig is generating _really_ bad code here, or something.
 
2
Whatever it is, this line suppresses 1323 warnings, any of which might
 
3
be real bugs with real consequences.
10
4
 
11
 
@DPATCH@
12
5
--- a/Makefile.in
13
6
+++ b/Makefile.in
14
 
@@ -126,7 +126,7 @@
 
7
@@ -138,7 +138,7 @@
15
8
 SWIG_PY_LIBS = @SWIG_PY_LIBS@
16
9
 SWIG_PL_INCLUDES = @SWIG_PL_INCLUDES@
17
10
 SWIG_RB_INCLUDES = @SWIG_RB_INCLUDES@ -I$(SWIG_SRC_DIR)/ruby/libsvn_swig_ruby