~ubuntu-branches/ubuntu/vivid/sysstat/vivid-proposed

« back to all changes in this revision

Viewing changes to debian/patches/05-scripts.patch

  • Committer: Bazaar Package Importer
  • Author(s): Robert Luberda
  • Date: 2011-02-07 20:57:05 UTC
  • mfrom: (12.1.2 experimental)
  • Revision ID: james.westby@ubuntu.com-20110207205705-6rbilpmalr1gkfra
Tags: 9.1.7-2
* Upload to unstable.
* debian/rules:
  + call dpkg-buildflags for initial values of CFLAGS & LDFLAGS;
  + use dh_auto_{configure,install,clean} debhelper commands;
  + provide build-arch and build-indep targets.
* Updated 00-Makefile.patch to make it possible to install isag only.
* 09-format-warning.patch: Fix a warning given by gcc -Wformat.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Minor sa2 script fixes.
2
 
 
3
 
--- sysstat-9.0.6.1.orig/sa2.in
4
 
+++ sysstat-9.0.6.1/sa2.in
5
 
@@ -49,7 +49,7 @@
6
 
 [ -f "$DFILE" ] || exit 0
7
 
 cd ${ENDIR}
8
 
 [ -L ${RPT} ] && rm -f ${RPT}
9
 
-${ENDIR}/sar $* -f ${DFILE} > ${RPT}
10
 
+${ENDIR}/sar.sysstat $* -f ${DFILE} > ${RPT}
11
 
 find ${DDIR} \( -name 'sar??' -o -name 'sa??' -o -name 'sar??.gz' -o -name 'sa??.gz' -o -name 'sar??.bz2' -o -name 'sa??.bz2' \) \
12
 
        -mtime +"${HISTORY}" -exec rm -f {} \;
13
 
 find ${DDIR} \( -name 'sar??' -o -name 'sa??' \) -type f -mtime +"${COMPRESSAFTER}" \
14
 
@@ -60,4 +60,4 @@
15
 
 done
16
 
 cd ${DDIR}
17
 
 rmdir [0-9]????? > /dev/null 2>&1
18
 
-
19
 
+exit 0