~ubuntu-branches/ubuntu/vivid/sysstat/vivid-proposed

« back to all changes in this revision

Viewing changes to debian/patches/06-exec.patch

  • Committer: Bazaar Package Importer
  • Author(s): Robert Luberda
  • Date: 2011-02-07 20:57:05 UTC
  • mfrom: (12.1.2 experimental)
  • Revision ID: james.westby@ubuntu.com-20110207205705-6rbilpmalr1gkfra
Tags: 9.1.7-2
* Upload to unstable.
* debian/rules:
  + call dpkg-buildflags for initial values of CFLAGS & LDFLAGS;
  + use dh_auto_{configure,install,clean} debhelper commands;
  + provide build-arch and build-indep targets.
* Updated 00-Makefile.patch to make it possible to install isag only.
* 09-format-warning.patch: Fix a warning given by gcc -Wformat.

Show diffs side-by-side

added added

removed removed

Lines of Context:
2
2
    - remove call to execvp() as it's not needed and has potential
3
3
      security problems.
4
4
 
5
 
--- sysstat-9.0.6.1.orig/sar.c
6
 
+++ sysstat-9.0.6.1/sar.c
7
 
@@ -1306,7 +1306,6 @@
 
5
Index: sysstat/sar.c
 
6
===================================================================
 
7
--- sysstat.orig/sar.c  2011-01-19 21:56:44.000000000 +0100
 
8
+++ sysstat/sar.c       2011-01-19 21:56:48.000000000 +0100
 
9
@@ -1389,7 +1389,6 @@
8
10
 
9
11
                /* Call now the data collector */
10
12
                execv(SADC_PATH, args);